Preparing for HISE 2.0



  • is this turning into a feature request? Okay! πŸ™‚

    I know I can build send with the containers but its awkward and frustrating, so a nice send module would be nice.. Okay feature requests OFF....



  • #define FEATUREREQUESTMODE_H_
        bool syncedOscilators = true;
    #endif
    

    😁



  • Nah, this is more a β€žI worked with the master branch version, but the development branch version set my house on fireβ€œ kind of thread. If I start accepting feature requests, hell breaks loose πŸ˜‰



  • @christoph-hart if you want to use a svg flat version for the HISE logo on 2.0 πŸ™‚

    <?xml version="1.0" encoding="utf-8"?>
    <!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
    <!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
    <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
    	 width="354.036px" height="339.034px" viewBox="0 0 354.036 339.034" enable-background="new 0 0 354.036 339.034"
    	 xml:space="preserve">
    <g>
    	<circle fill="#2A2B2A" cx="172.636" cy="163.444" r="128.4"/>
    	<path fill="#67C18C" d="M172.636,296.703c-73.479,0-133.26-59.779-133.26-133.259c0-73.48,59.78-133.26,133.26-133.26
    		c73.48,0,133.259,59.78,133.259,133.26C305.895,236.923,246.117,296.703,172.636,296.703z M172.636,39.903
    		c-68.121,0-123.54,55.42-123.54,123.541s55.419,123.541,123.54,123.541c68.121,0,123.54-55.42,123.54-123.541
    		S240.757,39.903,172.636,39.903z"/>
    </g>
    <g>
    	<path fill="#67C18C" d="M128.394,195.541h-11.242v-24.618H93.026v24.618H81.784v-59.985h11.242v23.803h24.126v-23.803h11.242
    		V195.541z"/>
    	<path fill="#67C18C" d="M159.713,195.541h-11.201v-59.985h11.201V195.541z"/>
    	<path fill="#67C18C" d="M210.322,146.466c-0.305,0.609-0.657,1.037-1.058,1.286s-0.878,0.374-1.431,0.374s-1.176-0.214-1.867-0.643
    		c-0.691-0.429-1.507-0.906-2.447-1.431c-0.94-0.525-2.04-1.002-3.298-1.431c-1.259-0.429-2.745-0.643-4.459-0.643
    		c-1.549,0-2.897,0.187-4.045,0.56c-1.147,0.373-2.115,0.892-2.904,1.556c-0.788,0.664-1.376,1.459-1.763,2.385
    		c-0.388,0.927-0.581,1.943-0.581,3.049c0,1.411,0.394,2.586,1.183,3.526c0.788,0.941,1.832,1.743,3.132,2.406
    		c1.299,0.664,2.779,1.259,4.438,1.784c1.66,0.526,3.353,1.086,5.082,1.68c1.728,0.595,3.422,1.286,5.082,2.074
    		s3.139,1.784,4.438,2.987s2.344,2.676,3.132,4.418s1.182,3.858,1.182,6.347c0,2.711-0.463,5.248-1.39,7.612
    		c-0.927,2.365-2.282,4.425-4.065,6.181c-1.784,1.756-3.961,3.139-6.534,4.148c-2.572,1.009-5.517,1.514-8.836,1.514
    		c-1.908,0-3.789-0.187-5.642-0.56c-1.853-0.373-3.63-0.905-5.331-1.597s-3.292-1.521-4.771-2.489
    		c-1.48-0.968-2.8-2.046-3.962-3.236l3.236-5.351c0.304-0.387,0.67-0.712,1.1-0.975c0.428-0.262,0.905-0.394,1.431-0.394
    		c0.691,0,1.438,0.284,2.24,0.851c0.802,0.567,1.749,1.196,2.842,1.887c1.092,0.692,2.378,1.321,3.858,1.888
    		c1.479,0.567,3.256,0.851,5.331,0.851c3.18,0,5.642-0.753,7.384-2.261c1.743-1.507,2.614-3.671,2.614-6.492
    		c0-1.577-0.394-2.862-1.183-3.858c-0.788-0.996-1.832-1.832-3.132-2.51c-1.3-0.678-2.779-1.251-4.438-1.722
    		c-1.66-0.47-3.347-0.981-5.061-1.535c-1.715-0.553-3.402-1.216-5.061-1.991c-1.659-0.774-3.139-1.784-4.438-3.028
    		c-1.3-1.245-2.344-2.8-3.132-4.667s-1.182-4.169-1.182-6.907c0-2.184,0.436-4.314,1.307-6.388s2.143-3.913,3.816-5.517
    		c1.673-1.604,3.727-2.89,6.16-3.858c2.434-0.968,5.213-1.452,8.338-1.452c3.54,0,6.803,0.554,9.79,1.659
    		c2.987,1.106,5.531,2.655,7.633,4.646L210.322,146.466z"/>
    	<path fill="#67C18C" d="M267.154,135.556v8.877h-26.591v16.635h20.948v8.587h-20.948v16.967h26.591v8.919h-37.833v-59.985H267.154z
    		"/>
    </g>
    </svg>
    
    


  • I know this is for issues / bugs, but just thought I'd mention the polyphonic lfos again... ☺



  • Has the parameter list in the Module Browser been fixed yet?



  • @dustbro said in Preparing for HISE 2.0:

    Has the parameter list in the Module Browser been fixed yet?

    That was the second issue posted in this thread πŸ˜›



  • @d-healey said in Preparing for HISE 2.0:

    @dustbro said in Preparing for HISE 2.0:

    Has the parameter list in the Module Browser been fixed yet?

    That was the second issue posted in this thread πŸ˜›

    Fourth actually πŸ™‚ First two lines are the issues in my post, these aren't future requests πŸ˜‰ πŸ˜‹

    • If fx the plugin has convolution reverb unit, knob automations of AU plugins, cause crash or cound clicks. (I've tried with the latest HISE version)
    • Custom Shape Modulation (in tempo sync mode) synchronizes only play button triggered in DAW. Δ±t should be in sync as soon as plugins is loaded. (for fx plugins)


  • What parameter? The damping and decay parameters are not supposed to be automated because they recalculate the entire IR.



  • @christoph-hart It's not about any specific parameter. If the fx plugin contains a convolution reverb unit, any parameter automations cause distortion sound while automating (only in Logic Pro X - AU plugin).

    For example I've made a plugin that is a combination of convolution, eq and delay. If I automate a delay or eq parameter, plugin couse distortions. But if the plugin doesn't contain convolution reverb, it's ok. I've experienced it several times.

    In AU plugins, there is an issue for automations while the fx plugin has conv. unit.



  • Ah Ok so this is only happening on Logic? Can you make a minimal example for me to replicate?



  • @d-healey said in Preparing for HISE 2.0:

    The embedded impulse responses are still not working correctly in the exported plugin. It's very strange because some of the impulses are embedded correctly but others aren't. This is the project I'm building that requires the functionality - https://github.com/davidhealey/sordina - I'm not using IPP btw (could that be the problem).

    This is weird. I can reproduce it and can pin it down to the FLAC encoding in JUCE - when exporting, all embedded audio files are encoded to FLAC to make the binary as small as possible - however if the impulse response is smaller than 4096 samples (which is the case with ~20% of the impulse responses of your project, it fails to encode.

    Fast fix: use uncompressed audio format for files < 4096 samples. Longer fix: debug FLAC.



  • Oops, apparently, I've used the JUCE class wrongly so it didn't flush the last block. Should be fixed now.



  • @christoph-hart Excellent!



  • HISE 2.0 depend of new JUCE 5.4.0 ? or same as actual JUCE/HISE version ?

    remember a thread you wrote about JUCE and SDK updates for adding new functions & modules in hise ...



  • Hmm, I was thinking about updating the JUCE version before going to the ADC, but it's a little bit too tight. But I have manually cherry-picked the most interesting additions for me anyway. Nevertheless you shouldn't bother about this, since HISE uses the customized JUCE codebase in the HISE repo anyway.



  • OK, mono support for FX plugins and the ability to set the AAX category is implemented. Just set the option in the Project Settings.

    0_1541680013118_New.PNG

    Note that mono plugins will still render everything in stereo, but just use the left channel as input / output. But this makes the balance slider effectively a gain knob πŸ™‚



  • @christoph-hart I was working for the last 4 month with hise master 1.5.0
    Yesterday downloaded develop, and it struck loading the same .hip making the cpu stuck at 99% for a while and makes Hise unresponsive. Maybe a minute or more. Then it runs smoothly.
    I admit I'm running and old 2009 Macbook, El Capitan. But it's very noticeable, in fact, I turned back to Hise Master 1.5.0. If any other detail is needed just tell me



  • Please send me the .hip then Iβ€˜ll check whats wrong.



  • @christoph-hart you already have it πŸ™‚


Log in to reply
 

18
Online

616
Users

2.5k
Topics

19.5k
Posts