Volume burst when changing preset with Convolution.



  • When Audio is running through the convolution reverb and I switch Presets I get this short Volume burst ?
    Is this another bug or has anyone encountered this ?



  • @lalalandsynth - Conv reverb isnt set up for real time changes like that.



  • @lalalandsynth I see, but shouldnt it ?
    It seems reasonable to be able to change preset without a problem.
    I guess I could script a small fade in or something ?



  • @lalalandsynth well you have to think about how delays and convolution work....they are not real time param changing effects....and that's what you are trying to do. No convolution reverb will change its IR in real time without artifacts...same with Delays - there's "zipper" sounds when you try and make real time changes.



  • @Lindon said in Volume burst when changing preset with Convolution.:

    No convolution reverb will change its IR in real time without artifacts

    That might be true , but there should be a "fix" for that , a small fade in or something, volume jumps or glitches are not acceptable in plugins.

    I am just changing presets , and I should not get a huge volume bump/glitch, sounds a bit like its bypassed and fully dry for a a few milliseconds. (not sure though why this jump happens)

    Btw , there is also a glitch when I switch impulses , also unacceptable and should be fixed.

    As for delays , the delay plugins I am using dont have that zipper noise.



  • @lalalandsynth - fixed by who? You want this feature maybe you could decide how to implement this?



  • @Lindon First I would need to know what is actually happening , recalling a preset does not give the same Glitch issue as when just switching impulses.

    So.

    1. Impulse switching - Ticks/pops , this needs to be fixed in the Convolution engine or so I was told by @Christoph-Hart .
      In the meantime I could make a small fade , I could even make it so that when the impulse is switched , it actually delays the switching by a few milliseconds, applies a fadeout -switch impulse - fade in.
      This can be scripted or even included as an option on the convolution verb.

    2. Preset Switching . I dont know what the issue is , as I said its not the same as when switching impulses.
      Again...possible fix, fade in after preset switch ?

    3. Delay , I dont know how other plugin dev make it so that it has no zipper noise but its definitely possible.

    To be honest I dont consider it a "feature" to be able to use the convolution reverb without clicks , pops and bypassing/volume jumps. I realize how convolution reverbs work but the ones I use dont do that.



  • @lalalandsynth I'm using a couple Convolution modules that I flip-flop with a crossfade for program changes. Still tinkering, but it works pretty well so far.



  • Ah, I understand now. I think the problem is that I've added a "kill voices before changing IR samples" function that will smooth out clicks when you switch IRs in a virtual instrument, but if you use it in a audio effect, it will still produce incontinuities in the incoming audio stream.

    However the delay should already be made clickless (it basically doubles the delay processing and applies a fade between the two delays when you change the delay time, but I'll take a look why it isn't working). The other way of changing delay times dynamically would be interpolating the delay time but this would introduce a pitch-shift effect during changing of the delay time which is rather undesirable...



  • @Christoph-Hart said in Volume burst when changing preset with Convolution.:

    this would introduce a pitch-shift effect during changing of the delay time which is rather undesirable...

    This might actually sound fun 🙂


Log in to reply
 

18
Online

736
Users

2.9k
Topics

24.7k
Posts