Trying to get a slider animation to follow the LFO mod



  • @SteveRiggs the reference to the LFOMod seems to be wrong, if you want it declared as "generic script"

    const var LFOModulator1 = Synth.getModulator("LFOModulator1");
    

    or as Typed table script

    const var LFOModulator1 = Synth.getTableProcessor("LFOModulator1");
    


  • I don't know, if i got you right, but i think you need "LFOModulator1.getCurrentLevel()" to modulate the slider.

    HiseSnippet 1239.3oc0XEraaaDDcor2Fa0pzjzdnGIL5AEjTEpZG2XTTDEKaYHDYKgRGmVzCoqHWIs0j6RStRNJAAHG5g9YTzuf7ITf9Izuf7GzK8b6rKonHcUrMThKh4ABM6Nyruc12NyP0IT3PihDgHik2eb.EY7QX6wb4f5CHLNp4VHiOGuOMRZ1PDZto2PpYKFGd0nsosGykFZ9.NyGs43.RTD0EYXrvNJKMVdQj94ut+lDOB2gNcHD5.Ayg1h4yjSGsSsGx77ZPbo6y7yn8Z0Z5H30Edhg.JW.agBHNGR5S2inTq.FY7Aa6xjhPaIQRiPFKtovcr8.ww7X8OfEw55QUBUQ1fihGtgvyUgX0nn5CXdtclDMhPfW5LM1rPbr4Sw6xbYoiOMFcM8DlSsHa7vnvoAupYgm04GdFYf2hwv65XamPVfb5LJr8g3lbIMrGANBxBqXcQE9aCbcAnAWVwmbHsQHHjZQ40srts4csrt4WWpHbL.DgQjP0w+tB2gdDXaU07aL0TlJ8oxzQKuRNcVQY+ctSohY8xC4htJqmr7f80E9ABNHTdE8rZ6xZiDzeadefCVwIjBATEYIrc2eh5HKqTVVIhJ0CVm340EnJk6Mj6HYBd4aVp3yKUzDdTtZD3pbfTCfgggvx2hNh5o8mR6ru0vRsFGPfaCkGoz4EwnDVZIILdwKupNjMYoME78DRZa.CEedwkK9hhlmbpd8l4bpfSnvyCb4rlNdwNECKyG52kFdaXKC3MUQfzjmUheyrxrWZbhOqxnnf2jyjsCn72DWEkb.Cr1BInBTUp4rWMgyFmLAw.p4Uv5XLRC3j7.+9q9i+79nTiWL13RIFuOQgTksKg0+Nuw5GWhjfLdDdcqJ4eF0N3o8t2FU52dUq5Z4ipri8sVciFGrdrbT+io2Ro5FwxvqdYkQnG0bKk6gqUIaUX6GPCkLUj0XK5HHcW7czkwaQiNTJBzwhDxND8OynwSS2LuraswoBl+XsHIMvl8rI61Zu9Y+rJTk56qblAqL9tUFe+xCqEL4XrIn+GiyccAcLyUNHU6WcTsATV+ASSo+qt0P+2rTPtxItHaBTUUijI.9atLUprQ7Hlbb1pJWHYUOuv853NLoyfYi2By.uJp+ELdSpQUBucudPxvofcQbiuadKHM65kVmUAokR6kf4G3Q2YBTJkYfpmRSCHzVTORt32iyQ1PeesYzVQS9H3RWGgGI7jQ+ExukW37skOi1BNcJhZKY91PomePl8r3pwfDqt7pQ1IuFel3pQH8ngTtStHppQsl4NxdLYDsmHzOIQWx3eVsVz9vBkUy8oPxInmAmrqhsuPHGv38yz9WsW+a+RsVBQv1bUlJ2r52Y.IRU0DJEm020GFIE9SvxEUFeaHmqNkuwOfWesJ4me01uajQu6HDENmr1OQwMLSYAJ5664ohiQbJE8R.huAVmby7RS0taf0Ieu7.3qg6P3uG.2uULTBIz1kHCYPOV38F5aCeEqCEfJmS8TscaTPkzJV1RIq.jMk6pE9G3IYxpJYijIqNYx+WVCehSn3INwceqRmrjdDXey0eC9x3cUxlosciwVUrP9v2D+DGGUGHeADelsMe4bXypygMqMG1b24vl0mCa9p4vl6cp1n96HdvPnPXL+GFny1w0qLRKkZr.5eAte.LL�
    


  • @ulrik @toxonic Spot on fellas! Thank you. That makes much more sense now.

    🙂 Nice one



  • Does this snippet export correctly for anyone using the latest develop build?

    It looks correct within hise interface preview but the animation of the knob does not work for me when I export the project as a vsti or standalone. Is this a bug or am I missing something?



  • This post is deleted!


  • @crd works fine here



  • @DanH Did you try and export it?

    I think Engine.createTimerObject() works for gui elements in the interface preview but not on an exported plugin.

    I think using an empty panel's timer is the right approach. I'm exporting that attempt now to see if that works.



  • @crd In hise it works fine, but compiled as a standalone it's not working



  • @ulrik
    Thanks... I'm not going nuts 🙂

    maybe it is a getCurrentLevel() issue. Using a panel timer in the above scenario doesn't work either. (It'd be easier to trouble shoot if I didn't have to wait to export to see if what I've done helps.)



  • I think it must be an issue with getCurrentLevel. The snippet below should export okay but doesn't. It does work fine in the Hise interface preview though.

    @Christoph-Hart Am I missing something?

    HiseSnippet 1325.3oc2X0saaTDEd13LPsKIhVBkBWsJhKbDkHGRZ.TEJahSbTTyONYcaQhKJSVO1dT1clkYmMfEpuAHwqPeT3Qf2D5MbAWAmY1016lXbMKoPZ8EQY94Lmu4b9luyLaSoviFEIjHqxs5GRQVuC1sOW0qdOBii1aaj06i6RUdwRIkq1mdN0uEMRg1peHIJh1FYYUZW8TsJOKx76EarEwmv8ni5Bgdrf4Q2mEvTi5soyCY99MHsosXAYl8ZN64I30E9hX.Vkv0PgDuyHcoGRzSaFLx5s1oMSIjtJhhFgrlcKQ69t8DeOOY9OlEwN0mparBxEVnjtaH7aqQr9+Q06w7a2bv1OBgrvMGELJkDLV.e.qMaX+iBJuqY.6QVjMdXMyjf2JEDdVYf2rIv6VXWOIKTMZDM1tIdOthJ6PfTPVXkLWzL+gEtt.lAWsb.4LZCIzXnEUWuVs6Ye+Z0V5AyUYtJPhHRYeNQZ2jvo9qX+U1CrEXE0EAgBNzn5hICu3Es5gbwo+8FYF8R1reiiNPzN1m.gPssF9n1xg8VcQXN1ilDrDvJj.gkinJMeRVm36eJPbp1Il6oXBd0kp7iyUorwo5Y8XheLsZNuYvWFpd0kzfK0DudDdWZ6pfydVNGpHxDWVcUSXafCsE7CEJ5QFOWobkmUw9hC0oyXGSGtjBeeXIG2vINaBFVkGGbJUdOHdB6wgSDHN4Yl3oiY5kj8xLQAeONScTHMs8k4qnzTtl4lhJXpJCuc9TdqqOqMUhX.87swlfLx.3Ts.mOX4eaCzi1aahhLXYfUD7RHUpX5Mf01zyAkkjiCkwaSiNSIBAQhgrLXOm3z4FbXQm0L97F3jLH5GFJ97sBm9iThdfC5xqyD.+n0449YVGmm3ft7gWPBY.uKqthVLMc.Hkl6.r9PJOho5mUr8efXSswJ1L1j2TB2agaxTd8FOdmYL3ERiupwapz8b3c5zg5oFA1YwM95hpSWLnLeBTtI1kwoFYLCPtios8SHmSs2kxoRi1yDJo9qSaI0votj5QdJv8sjDdTnHJ2B6RCXs.NeT1NeTDTnf9cmnyxY6utfHG6PuXiFvlbr13RTwRCcYy.QLWkidTpP0NyepIy7GSgzY+enN+U+Qu+8JEklN39RtJR4AXzkED5S2gCkMA8YCFuMHH2gD6qFzadR9ABtHrmfy7xx.NgpjrtcoxrXeranMUJn99ndVv4DpOkjkM+wN6CrPhDhSzBFKVY5iESJecWbBbs0mLseyPguzaPJ7E7l3oz+aiaJ76mPlav7gKSa.TYbRiIItiPZQxXJ2aPT74g69SNGmkBjm9dWmiiI9WHpuEKT3SjSUFo3r8YmRZycvC2Tup35ELgkVSFigK9mJjl+wDubPdw70u76U+HGcQ28FkVc9YGc88NBYP5kSGZ99ztfix1SKJbIS39A4zAcCDBUOFua9R4K3ruPDtCm.gg1YWjl8.kO3AEvKaxUfNNRIBFfEyymcUzPycps9F75qsL7qymn+6WVG9ypGc0z9JjzMyTR5dOSlbXJSmSulqtlf3bGUt1WOPqd85S8qODmJLZhxu9f64wGeM.rmHhUfBzAD3JYviawGFG3BOgviB.kCOcV+IDrlQqxjztltcxaH3sMM9S3W5fqnaakN3JCF7+DeDP7jhm5k7YHzRJ2vzCru4luoXY7A511C+9CXbskqgBf69+TOO8EK9TH9Lda9rBXypEvl0JfM2u.1rdAr4yKfMewDsQ+rqMigJWI7enil6jTyxZXsOqRn+BrQnEHD
    


  • @crd said in Trying to get a slider animation to follow the LFO mod:

    @ulrik
    Thanks... I'm not going nuts 🙂

    maybe it is a getCurrentLevel() issue. Using a panel timer in the above scenario doesn't work either. (It'd be easier to trouble shoot if I didn't have to wait to export to see if what I've done helps.)

    -- remember when using panel timers, they are suspended when you hide your plugin in the DAW...



  • @crd standalone worked fine



  • @crd said in Trying to get a slider animation to follow the LFO mod:

    pet below should export okay but doesn't. It does work fine in the Hise interface preview though.

    ENABLE_ALL_PEAK_METERS=1 My Friend
    ENABLE_ALL_PEAK_METERS=1 My Friend 🙂



  • @Natan said in Trying to get a slider animation to follow the LFO mod:

    ENABLE_ALL_PEAK_METERS=1

    Yes, this will make it work! 🙂



  • @Natan well done, I forgot I already had these enabled 😆



  • @Natan said in Trying to get a slider animation to follow the LFO mod:

    ENABLE_ALL_PEAK_METERS=1

    That was it. Thank you!



  • @crd Glad To Help 🙂



  • @DanH Haha, This Happens To Me Quite Often 🙂 😆
    So I Stored This On My Mind
    It's A Meter >>> Enable That Friend = 1 😆


Log in to reply
 

6
Online

1.5k
Users

4.6k
Topics

42.1k
Posts