i386 deprecated!?!?!



  • @hisefilo really honestly - whats "option click" - I've tried cmd click that doesnt show me any thing more than normal click



  • @Lindon option = alt



  • @Lindon Go to the "Go" menu, then press and hold "alt" button, the hidden library folder appears.

    alt text



  • @orange so its not called "Libaries" at all as per Christoph's post - its called "Library"

    This in the end this is moot as when I go to LibraryI can see Application Support but any way I get to Application Support there is no folder in it called Audio - so I still have no idea where my VST plug-ins are going.



  • @Lindon this is the place /Users/filo/Library/Audio/Plug-Ins/VST

    replace "filo" for your usename on macos

    You can also directly go to this folder on the Go menu >> Go to folder



  • @hisefilo yes so everyone keeps telling me, but ...

    whilst /Users/filo/Library exists, there is no Audio folder in there.



  • @Lindon replace filo with your username



  • @Lindon is your vst plugin accesible within your daw? I mean can you load it correctly?



  • @hisefilo ...er, yes obviously...sorry talking about the user name replacement...



  • @Lindon if your daw on macos is loading it, it is somewhere. Also check /Library/Audio



  • @Christoph-Hart said in i386 deprecated!?!?!:

    /Libraries/Application Support/Audio/Plug-Ins/VST

    So, been through this as well, managed to build an AU plugin , shows up as .component in the plugins folder.
    I have another plugin in that folder (Hello world) from Juce.
    The plugin from Juce shows up in Reaper but my plugin does not.

    Same plugin was built on Win as VST and works nicely.

    Next up is trying to build a VST on Mac and see if that works.



  • I got this error just now trying to build. I am wondering if someone could please provide a compiled version on the github that works properly so that everyone doesn't have to re-build HISE. I am going to try and do that process now, but im having to do a fair bit in the process and I feel like thats something that should be made available, if I am successful in building the newer HISE, I would love to help in posting the mac version. I just want to make sure something like that is available to anyone new that comes to HISE. It seems like its starting to fall out of active production and its too good to become abandoned, but I am also not enough of a developer to be the guy to help take over and push it forward yet.



  • @MacroMachines The fact is that having a prebuilt version of Hise will not help you to export final products if you don't have the right tools anyway.
    Another important part is that one can have different preprocessor settings in the Projucer, as well as other settings.

    And this is not talking about the bug fixes and updates, especially with the V3 coming soon, and any custom modifications, custom nodes you need to compile with, etc…

    My guess is that it worth having a setup that works so you're good to build by yourself. And once it works, re-compiling is very easy



  • @ustk Ok, I was able to get xcode working on mojave downloading an old version, I adjusted the settings in the projucer project to 64 bit and recompiled HISE successfully and now im still getting the same error when I compile my plugin test:

    "❌ error: The i386 architecture is deprecated. You should update your ARCHS build setting to remove the i386 architecture. (in target 'VibratorBass - Shared Code' from project 'VibratorBass')"



  • @Christoph-Hart Wait I need to stop the terminal from compiling my HISE project after hitting export for audio unit and then look for a projucer project and edit that one and change the export settings on that and compile it?



  • I get failed in xcode when I build the autogenerated projucer, error : /Users/nicholascraftisiii/Dropbox/Myplugin/HISE/Myplugin/Binaries/Source/Plugin.cpp:8:45: No member named 'MidiFiles' in 'hise::FileHandlerBase'



  • @MacroMachines You should be able to build in the terminal. You might have a 32bit thingy ticked in the Hise preferences (I'm not in front of my computer…)



  • @MacroMachines
    2c10b0aa-b653-416e-9829-1a523b27a432-image.png

    -- this should be OFF



  • @Lindon Ok I tried that, now getting this error in the terminal compile:

    ▸ Processing Info-AU.plist
    ** BUILD FAILED **

    The following build commands failed:
    Rez /Users/nicholascraftisiii/Dropbox/Vibrator\ Synths/HISE/VibratorBass/Binaries/Builds/MacOSX/build/VibratorBass.build/Release/VibratorBass\ -\ AU.build/ResourceManagerResources/Objects/include_juce_audio_plugin_client_AU.rsrc /Users/nicholascraftisiii/Dropbox/Vibrator\ Synths/HISE/VibratorBass/Binaries/JuceLibraryCode/include_juce_audio_plugin_client_AU.r
    (1 failure)


    Is there an issue with AU for mac?



  • @MacroMachines said in i386 deprecated!?!?!:

    @Lindon Ok I tried that, now getting this error in the terminal compile:

    ▸ Processing Info-AU.plist
    ** BUILD FAILED **

    The following build commands failed:
    Rez /Users/nicholascraftisiii/Dropbox/Vibrator\ Synths/HISE/VibratorBass/Binaries/Builds/MacOSX/build/VibratorBass.build/Release/VibratorBass\ -\ AU.build/ResourceManagerResources/Objects/include_juce_audio_plugin_client_AU.rsrc /Users/nicholascraftisiii/Dropbox/Vibrator\ Synths/HISE/VibratorBass/Binaries/JuceLibraryCode/include_juce_audio_plugin_client_AU.r
    (1 failure)


    Is there an issue with AU for mac?

    Not as long as you have the AU library installed - do you? where?


Log in to reply
 

9
Online

694
Users

2.8k
Topics

23.6k
Posts