Trying to get a slider animation to follow the LFO mod



  • @DanH Did you try and export it?

    I think Engine.createTimerObject() works for gui elements in the interface preview but not on an exported plugin.

    I think using an empty panel's timer is the right approach. I'm exporting that attempt now to see if that works.



  • @crd In hise it works fine, but compiled as a standalone it's not working



  • @ulrik
    Thanks... I'm not going nuts 🙂

    maybe it is a getCurrentLevel() issue. Using a panel timer in the above scenario doesn't work either. (It'd be easier to trouble shoot if I didn't have to wait to export to see if what I've done helps.)



  • I think it must be an issue with getCurrentLevel. The snippet below should export okay but doesn't. It does work fine in the Hise interface preview though.

    @Christoph-Hart Am I missing something?

    HiseSnippet 1325.3oc2X0saaTDEd13LPsKIhVBkBWsJhKbDkHGRZ.TEJahSbTTyONYcaQhKJSVO1dT1clkYmMfEpuAHwqPeT3Qf2D5MbAWAmY1016lXbMKoPZ8EQY94Lmu4b9luyLaSoviFEIjHqxs5GRQVuC1sOW0qdOBii1aaj06i6RUdwRIkq1mdN0uEMRg1peHIJh1FYYUZW8TsJOKx76EarEwmv8ni5Bgdrf4Q2mEvTi5soyCY99MHsosXAYl8ZN64I30E9hX.Vkv0PgDuyHcoGRzSaFLx5s1oMSIjtJhhFgrlcKQ69t8DeOOY9OlEwN0mparBxEVnjtaH7aqQr9+Q06w7a2bv1OBgrvMGELJkDLV.e.qMaX+iBJuqY.6QVjMdXMyjf2JEDdVYf2rIv6VXWOIKTMZDM1tIdOthJ6PfTPVXkLWzL+gEtt.lAWsb.4LZCIzXnEUWuVs6Ye+Z0V5AyUYtJPhHRYeNQZ2jvo9qX+U1CrEXE0EAgBNzn5hICu3Es5gbwo+8FYF8R1reiiNPzN1m.gPssF9n1xg8VcQXN1ilDrDvJj.gkinJMeRVm36eJPbp1Il6oXBd0kp7iyUorwo5Y8XheLsZNuYvWFpd0kzfK0DudDdWZ6pfydVNGpHxDWVcUSXafCsE7CEJ5QFOWobkmUw9hC0oyXGSGtjBeeXIG2vINaBFVkGGbJUdOHdB6wgSDHN4Yl3oiY5kj8xLQAeONScTHMs8k4qnzTtl4lhJXpJCuc9TdqqOqMUhX.87swlfLx.3Ts.mOX4eaCzi1aahhLXYfUD7RHUpX5Mf01zyAkkjiCkwaSiNSIBAQhgrLXOm3z4FbXQm0L97F3jLH5GFJ97sBm9iThdfC5xqyD.+n0449YVGmm3ft7gWPBY.uKqthVLMc.Hkl6.r9PJOho5mUr8efXSswJ1L1j2TB2agaxTd8FOdmYL3ERiupwapz8b3c5zg5oFA1YwM95hpSWLnLeBTtI1kwoFYLCPtios8SHmSs2kxoRi1yDJo9qSaI0votj5QdJv8sjDdTnHJ2B6RCXs.NeT1NeTDTnf9cmnyxY6utfHG6PuXiFvlbr13RTwRCcYy.QLWkidTpP0NyepIy7GSgzY+enN+U+Qu+8JEklN39RtJR4AXzkED5S2gCkMA8YCFuMHH2gD6qFzadR9ABtHrmfy7xx.NgpjrtcoxrXeranMUJn99ndVv4DpOkjkM+wN6CrPhDhSzBFKVY5iESJecWbBbs0mLseyPguzaPJ7E7l3oz+aiaJ76mPlav7gKSa.TYbRiIItiPZQxXJ2aPT74g69SNGmkBjm9dWmiiI9WHpuEKT3SjSUFo3r8YmRZycvC2Tup35ELgkVSFigK9mJjl+wDubPdw70u76U+HGcQ28FkVc9YGc88NBYP5kSGZ99ztfix1SKJbIS39A4zAcCDBUOFua9R4K3ruPDtCm.gg1YWjl8.kO3AEvKaxUfNNRIBFfEyymcUzPycps9F75qsL7qymn+6WVG9ypGc0z9JjzMyTR5dOSlbXJSmSulqtlf3bGUt1WOPqd85S8qODmJLZhxu9f64wGeM.rmHhUfBzAD3JYviawGFG3BOgviB.kCOcV+IDrlQqxjztltcxaH3sMM9S3W5fqnaakN3JCF7+DeDP7jhm5k7YHzRJ2vzCru4luoXY7A511C+9CXbskqgBf69+TOO8EK9TH9Lda9rBXypEvl0JfM2u.1rdAr4yKfMewDsQ+rqMigJWI7enil6jTyxZXsOqRn+BrQnEHD
    


  • @crd said in Trying to get a slider animation to follow the LFO mod:

    @ulrik
    Thanks... I'm not going nuts 🙂

    maybe it is a getCurrentLevel() issue. Using a panel timer in the above scenario doesn't work either. (It'd be easier to trouble shoot if I didn't have to wait to export to see if what I've done helps.)

    -- remember when using panel timers, they are suspended when you hide your plugin in the DAW...



  • @crd standalone worked fine



  • @crd said in Trying to get a slider animation to follow the LFO mod:

    pet below should export okay but doesn't. It does work fine in the Hise interface preview though.

    ENABLE_ALL_PEAK_METERS=1 My Friend
    ENABLE_ALL_PEAK_METERS=1 My Friend 🙂



  • @Natan said in Trying to get a slider animation to follow the LFO mod:

    ENABLE_ALL_PEAK_METERS=1

    Yes, this will make it work! 🙂



  • @Natan well done, I forgot I already had these enabled 😆



  • @Natan said in Trying to get a slider animation to follow the LFO mod:

    ENABLE_ALL_PEAK_METERS=1

    That was it. Thank you!



  • @crd Glad To Help 🙂



  • @DanH Haha, This Happens To Me Quite Often 🙂 😆
    So I Stored This On My Mind
    It's A Meter >>> Enable That Friend = 1 😆


Log in to reply
 

5
Online

1.5k
Users

4.6k
Topics

42.1k
Posts