Issue for build on MacOs



  • Hi everyone !

    I have a problem to export from Hise in vst or standalone on MacOs. I have this message :

    ▸ Building microcosm_dev/microcosm_dev - Shared Code [Release]
    ▸ Check Dependencies
    ▸ Compiling include_hi_dsp_library.mm
    ▸ Compiling include_hi_components.cpp

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling PresetData.cpp
    ▸ Compiling include_hi_core.mm

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling include_hi_dsp.cpp

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling Plugin.cpp

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling include_hi_frontend.mm

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling include_hi_lac.mm
    ▸ Compiling include_hi_modules.mm

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ** BUILD FAILED **

    The following build commands failed:
    CompileC build/microcosm_dev.build/Release/microcosm_dev\ -\ Shared\ Code.build/Objects-normal/x86_64/Plugin.o /Users/macbook/Desktop/HaddockAudio/microcosm_plugin/microcosm_dev/Binaries/Source/Plugin.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler
    (1 failure)

    ❌ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../hi_tools/../hi_streaming/hi_streaming.h:69:10: 'ipp.h' file not found

    #include "ipp.h"
    ^~~~~~~

    ▸ Compiling include_hi_sampler.cpp

    ⚠️ /Users/macbook/Desktop/HISE/HISE-master/hi_core/../JUCE/modules/juce_dsp/processors/juce_IIRFilter_Impl.h:93:20: unused variable 'isBypassed' [-Wunused-variable]

    constexpr bool isBypassed = bypassed;
                   ^
    

    ▸ Compiling include_hi_scripting_01.cpp
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.

    [Opération terminée]

    I followed the instruction for Compiling without IPP on OSX on the @Christoph-Hart github but don't woks for the moment 😕



  • Seems like it's still looking for IPP, double check your settings in the Projucer (or install IPP).



  • I double check and don't works.. there is not another place where I have to make changes? Only in the Projucer plugin and standalone?



  • I couldn't get mine to work without IPP.



  • Ok, there's a topic which explain the method to install the IPP ?

    Thanks a lot.



  • @Haddock a quick use of the search function at the top right of this page give you:
    https://forum.hise.audio/topic/702/ipp-on-mac-how-to-install



  • @Lindon Thanks ! I check it



  • Ok it seems to work with the IPP, but another failed appear :

    ❌ /Users/macbook/Desktop/HISE/HISE-master/JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp:95:10: 'pluginterfaces/vst2.x/aeffect.h' file not found

    #include "pluginterfaces/vst2.x/aeffect.h"
    ^

    ** BUILD FAILED **

    The following build commands failed:
    CompileC build/microcosm_dev.build/Release/microcosm_dev\ -\ VST.build/Objects-normal/x86_64/include_juce_audio_plugin_client_VST2.o /Users/macbook/Desktop/HaddockAudio/microcosm_plugin/microcosm_dev/Binaries/JuceLibraryCode/include_juce_audio_plugin_client_VST2.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler
    (1 failure)
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.

    I'm not sure to understand what it concerns 😐



  • @Haddock said in Issue for build on MacOs:

    /Users/macbook/Desktop/HISE/HISE-master/JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp:95:10: 'pluginterfaces/vst2.x/aeffect.h' file not found

    You're missing the VST2 SDK



  • @Haddock look here to see if you have this structure in the hise folder:
    https://forum.hise.audio/topic/1702/managed-to-compile-vst3-on-windows/13



  • @ulrik thanks for your message, yes I have this structure in the SDK folder.

    Capture d’écran 2019-09-16 à 10.33.37.png



  • @Haddock well your asiosdk folders not the same for a start...



  • Well, there is no ASIO on macOS as far as I know, I think there is no need for that



  • @Haddock did you decompress the "sdk.zip" and placed the 2 folders "VST3 SDK" and "ASIOSDK2.3" directly under the "SDK" folder?
    It looks like you have other folders judging by the contents in them, have you downloaded the SDK from Steinberg? if so, it will not work.
    You need to decompress the "sdk.zip" and place it like I said above.



  • @ulrik I directly download it from Steinberg, I will delet the other folder, but when I try to unzip the "sdk.zip" it ask me a password for ASIO



  • @Haddock well its NOT 1234 - but if you simply rearrange these then it might be that.



  • Thanks @Lindon !



  • @Haddock how is it going, did you manage to build successfully?



  • @ulrik No sorry I was not here for few days, I relpaced the sdk folder and he gave me the same error, I was wondering if you need to locate the project you want to build in a particular folder or not ? Or the Hise path location enough.

    This is my actual sdk folder :

    Capture d’écran 2019-09-21 à 12.04.59.png

    Thanks for your help ! 🙂



  • @Haddock hmm, looks right to me.
    You have to have the right path to Hise but the project you're building is open when you export it to au or vst, so there's no need to set any other path I think


Log in to reply
 

16
Online

540
Users

2.0k
Topics

15.9k
Posts