Discard VS2015?


  • administrators

    Hi everybody,

    who is still using (and depending) on VS2015? I can't use the latest DSP functions from JUCE because it requires a newer compiler which is shipped in VS2017 (on macOS it's not a problem and clang / gcc on Linux should also support the new C++ standard).



  • me ! 😄
    but because i don't know if VS2017 use vst sdk 3.6.6.

    if nothing change (in the way working/compiling) with VS2017 - Last SDK vst than VS2015 - SDK 3.6.6 ... so no problem for me to migrate to the last version ... 😉



  • When we want to compile Hise with VS2017, it gives "Can't find v141 toolset" error. I've installed it but it still gives that anyway too. Could it be possible that VS2017 installer software installs "toolset v141" to different location? How can we change that location in VS2017 before compiling?



  • Ok I've solved the v141 toolset with selecting it manually from project > options menu in VS2017.

    But this time, while compiling HISE, it gives this message, "fatal error ip.cpp couldn't be found." I've installed IPP but why it says this? Which expansions of VS2017 should I install?



  • @orange Try reinstalling the IPP, it has to integrate itself with VS


  • administrators

    Yes the migration is a bit painful, but reinstalling IPP might work.

    You also have to select VisualStudio2017 as target in the projucer and resave so that it sets the toolkit automatically.



  • I'm gettin' this in IPP installation...

    Integration(s) in Microsoft Visual Studio* components will not be installed because they require that a supported Microsoft Visual Studio...
    


  • The IPP version that you are trying to install can't detect VS2017. Are you sure that you are installing the most fresh IPP version?
    Because old IPP versions might not detect the newest VS2017 updates.



  • You are great @remarkablex 😄 Yes you are right, I was trying to install IPP 2017 update 3. now I installed IPP 2018 update 1 version and it is working. I've even managed to comply hise too 🙂



  • @orange said in Discard VS2015?:

    You are great @remarkablex 😄 Yes you are right, I was trying to install IPP 2017 update 3. now I installed IPP 2018 update 1 version and it is working. I've even managed to comply hise too 🙂

    No, I'm just a beginner, and I'm just a student of @christoph-hart & @d-healey 😜


Log in to reply
 

2
Online

315
Users

919
Topics

6.0k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.