Sample Map .xml Properties Reset ID to ""



  • I just finished my first sampler instrument and had an absolute nightmare right at the end.

    In the .xml files for each sample in my sample maps, every one of the files reset the ID to "" with no name inbetween the quotation marks.

    Luckily, this project only had 35 samples (but it still took forever having to manually go into each .xml file and copy and paste the names into them between the "")

    Another sampler instrument I'm working on already has 500 samples, and I'm aiming for 900. I do not fancy doing that process again for 900 samples. That would actually take days! 🤣

    @Christoph-Hart Is there going to be a way to fix this so that the .xml's don't reset to "" every time?

    Also, when trying to 'convert all samples as monolith + sample maps', and 'export samples for installer', no .ch or .hr1 files exported to the project folder like they used to in older HISE builds, even though it said it had exported sucessfully. For now while it's in testing phase I've just had to redirect to the samples folder inside the HISE project. Hopefully I can find out a way to fix this before it gets to release stage.

    I'm using the scriptnode build from 1st Sept btw.



  • You used one sample map per sample?



  • @d-healey For this first sample plugin for my client it has been. He only sent me sampled C3's for his basses, and then 1 drum sample map that has a few samples in one... but for the most part it was just 1 sample per mapping spread across the octaves. A weird, and quite lazy way of doing it I know, but surprisingly considering there is no timestretch algorithm, it sounds good. I just built the GUI, graphics, and put it all together using his sounds. I've had words with him now though don't worry 🤣



  • You know there‘s an update samplemap IDs based on filename function that does exactly this with the click of a button?

    This is also helpful if you start moving around the samplemaps or change their name.



  • @Christoph-Hart I didn't know that. I stand corrected then 🤣 My apologies! Where would I find the button?



  • @Christoph-Hart It's ok, found it!! Thank you



  • @Christoph-Hart

    It's still not exporting the .hr1 files though, that I can see. I have the .ch1 files now but no .hr1 file ☹

    I have my target directory set to the main project folder. That's correct, right?



  • What happens if you go to Export -> Export samples for installer ?



  • Nevermind, switching to the other thread were you posted it 🙂


Log in to reply
 

14
Online

517
Users

1.9k
Topics

14.6k
Posts