AU Plug-in not showing up



  • OK now I'm having big problems with an AU plug-in.

    I've compiled the project on both Windows and Mac, everything works fine on windows.

    But on the Mac the VST shows up in Reaper, but the AU doesnt - and it wont show up in GarageBand either. All my other plug-ins compile(as AU) and show up on the Mac no problem.

    I'm getting no errors on the compile - the component is sitting there in the usual spot... but I cant get a DAW to recognise it

    Anyone get any clues?



  • Try running auval on it - it‘s a built in command line tool that validates AU plugins.



  • @Christoph-Hart Ok well I tried that - well I tried this first:

    auval -a

    -- and it doesnt appear in the list,

    it cant be its name can it its called "S One.component"



  • @Lindon ...hang on it might be I've duplicated the Plugin code...checking...checking



  • @Lindon yes user error - had the same Plug In code.

    So for those of you arriving here with the problem that your Mac VSTs work but the AU version doesn't -

    VST doesn't seem to care what the plugin code is - but AU does - so if you have duplicates then it will load the first and not any duplicate.. check you are using a unique code for each product.



  • @Lindon I've had the same issues in the past. Ended up being the same code. Blacklisted in Cubase and wouldn't open in garageband or logic.


Log in to reply
 

6
Online

491
Users

1.7k
Topics

13.0k
Posts