Missing sample archive file after compiling sampler vst



  • Hi all,

    I just compiled my first sampler to test in Ableton, but when I open the VST it asks for me to choose the sample archive location and a 'resources 1.0.0hr1' file? Any idea where I would find that file at all, please?

    I've searched through all of the folders in the project folder but can't find it anywhere.

    Thanks in advance 🙂



  • If you haven't created a HR file for distribution, you'll want to select the 2nd option to "choose location", then point it to your sample folder.



  • @SteveRiggs Before you exported did you use the tool to convert your samples to a h1 archive. This tool is in the export menu >> Export Samples for Installer.

    If you didn't use this tool then did you convert your samples to monoliths? These will be .ch files.



  • @d-healey Ah, that's what it probably is then. I didn't know about the 'Export samples for installer' option. Thanks mate. I'll try that now...



  • @SteveRiggs You only need to use that to bundle your samples to send to users. Once in HISE it will export them back to ch files anyway.



  • @d-healey Got ya. I've only used 1 sample at the moment mapped across C-1 to C7 just to test it out and learn some more really.

    I managed to get the sample archive file in now and directed it to the samples folder, but in Ableton, the plugin interface works now, but no sample seems to be loaded.

    Could it be something to do with that it's not loading an 'actual' user preset when it loads up as default?

    or maybe I just need to recompile it from scratch now I made the sample install file?



  • @SteveRiggs If it's the first time you're loading it, you may need to unload, and then reload the plugin



  • @dustbro Cheers. Tried it but still no joy though 😟



  • HISE doesn't load a default preset, but it will load up in the state it was last saved in before you exported.



  • @d-healey I thought that. Very strange that it's not playing any sound when using it in Ableton. It works perfectly running in HISE with my MIDI keyboard. I'll try and recompile....



  • @SteveRiggs I'm having the same issue. Did you figure out a way to resolve this?



  • @TNTHM I did at the time of this post, but now the .hr1 files are not exporting. @Christoph-Hart said it's not finding the .ch1 files properly for some reason, but it's still inconclusive why, or how to fix it.

    I've had to make my own workaround for the time being while I'm testing my current exported sample instrument...

    The first time you open your exported plugin in your DAW, it should give you 2 options on the screen to install the samples. Choose the bottom one and redirect it to the folder where your samples for this plugin are stored (I sent mine to the samples folder in the HISE project temporarily)

    It will give you a pop-up message saying something like 'only do this is you have already extracted the .hr1 file that came with your download'... or something like that.. but just ignore that. Click ok and your sample folder should be redirected and your instrument should work.



  • @SteveRiggs That's interesting. I had no problem exporting the .hr1 file, however I tried both methods of connecting samples when I first open the exported plugin (sourcing to the .hr1 & sourcing the folder with the .ch1 files) and I am still having trouble getting consistent audio from the plugin when hosted in a daw. Were you able to get your instrument to play in a daw once you directed it to the .ch1 files in your samples folder?



  • @TNTHM That is weird. Yeah mine works fine since I redirected to the sample folder. I'm using Ableton 10 on Mac. I haven't tested it on anything else yet. What are you testing in?



  • @SteveRiggs It certainly is. That's good to know. I'm going to try mine as a standalone instrument as well and see if everything is working there. I'm testing in Logic 10 and Element. I was unable to get the plugin to export as an aui but it exports fine as a vsti for me so I am using element as a plugin wrapper to host my synth in Logic.



  • @TNTHM I've been having problems with Logic finding AU plugins recently. They export from HISE ok but Logic doesn't pick them up. A couple of other friends said the same. I'll have a look at element. That could be a good workaround. I assume element lets you use vst in logic then? (I don't use Logic much)



  • @SteveRiggs said in Missing sample archive file after compiling sampler vst:

    They export from HISE ok but Logic doesn't pick them up

    If this happens, it's usually the case that auval crashes when validating the plugin. You can run it from the command line and it should give you some clues.

    Another option is just Logic being stupid, if you recompile the project and forget to bump the version number, it won't load unless you clean the AU plugin cache (google that for a howto instruction)



  • @SteveRiggs The problem for me is that I cannot successfully export the aui from hise. It gives me an error:

    2019-09-28 16:00:37.918 xcodebuild[4920:735050] unable to create build operation: Error Domain=com.apple.xcbuild Code=1 "unknown error while handling message: missingTarget(guid: "1a8c342c680a9fe7d3cc99cc35c54a7f215e0fc7a7dbdd87b008a4b5e5d0b1e4")" UserInfo={NSLocalizedDescription=unknown error while handling message: missingTarget(guid: "1a8c342c680a9fe7d3cc99cc35c54a7f215e0fc7a7dbdd87b008a4b5e5d0b1e4")}
    ** BUILD FAILED **

    Compiling finished. Cleaning up...
    logout

    In terms of Element, yes definitely check it out. It hosts vst synths in logic. It can be used as either an fx plugin or an instrument plugin so whatever vsts you export from hise can be loaded into Element in Logic.


Log in to reply
 

7
Online

591
Users

2.3k
Topics

18.2k
Posts