Convolution Reverb or Audioloop Player doesn't load file



  • @Christoph-Hart it happens with every file I've tried...I will check the script node branch when i get a chance.

    I only have sporadic access to the Mac right now... any one else can check?



  • That's so weird as it loads perfectly here. What macOS version are you using?



  • @Christoph-Hart Mojave 10.14.5 - I listed this earlier in the thread, I also note @forgotpassword says he/she is on 10.14.4.

    @d-healey - I have no idea but he also cannot get it to load



  • Ah alright if somebody with a different macOS can confirm that it‘s just Mojave I‘ll update my OS and try to reproduce it.

    Last time I updated the macOS to High Sierra the code font was invisible but only with font size 16, so I expect another party of weird bugs, yay!



  • OK anyone out there with a MacOS other than Mojave? Could you do all us Mojave users a favour and check this?



  • @Lindon @Christoph-Hart
    Just checked on High Sierra with several versions of Hise from the master branch of 1st May up to scriptnode from 2-3 days ago including the last master, and everything is loading just fine...



  • @ustk thanks a lot... @Christoph-Hart -- it looks like this IS a Mojave problem then... sorry.



  • OK last attempt before going through the horror of updating my OS:

    If you run HISE in Debug mode inside of XCode, is it throwing an assertion if you try to load a audio file?

    Maybe I can remote-debug my way out of this...



  • @Christoph-Hart well it looks like no one else has the time to do this so I will give it a go, so from first principles how would I do this?

    • Assume I have opened Xcode from the projucer.....


  • Press on the play button on the top left (in the menu it's something like Product -> Build -> Debug).

    It should build the binary and execute it with the debugger attached. (You might have to skip a few assertions during startup). Then try to load an audio file and if we're lucky, the execution stops and points at a code location that reveals what's wrong.



  • Well interesting in a frustrating sort of way...

    So I ran Product>Build for>Testing

    --- and ran the resulting image (called HISE Debug) that was in:

    Hise Master>projects>standalone>Builds>MacOSX>build>Debug

    --- I couldnt see any debugger anywhere.... I also ran the same thing pressing the "play button" - that built the image and then did noting (didnt even start it..)

    But......

    HISE Debug WILL load wav files into the Convolution reverb - I ctrl-clicked and selected a file - it loaded. I opened a project with a convolution reverb in it - it loaded the wav file on start up - I selected another reverb from the projects combo box and this loaded too, so script based loading is also working.

    Just to be on the safe side I ran

    I ran Product>Build for>Profiling

    -- and ran the resulting image from:

    Hise Master>projects>standalone>Builds>MacOSX>build>Release>

    This WILL NOT open wav files in the convolution reverb.

    -- Im not sure this helps that much, it might help me if you tell me I can (as a temp work around) build plug-ins using the debug version of Hise Standalone...



  • So, not only is it only happening in macOS mojave only, it's also just in the Release mode? Oh lord.

    You absolutely must not ship the debug build of a plugin build with HISE. The performance is about 100x slower, all sorts of debugging functions might create drop outs at random occassions.

    But you can of course use the Debug version of HISE to build it - the export will use the Release configuration anyway (so in your end user plugin you won't be able to load convolution reverbs either. Not sure if this helps with your problem.



  • A while back, I had an issue where Debug was working properly, and Release was not. I think it ended up being an optimization issue...
    I could be way off, but try building the release version of HISE with Optimization disabled in the Projucer and see if that works:
    OPTIMIZATION.png



  • @dustbro I had this also with something on Linux Mint, disabling optimization was a temporary fix I used.



  • @dustbro that looks like Visual Studio - so happening on Windows, not Mac? - of course I will try it.



  • @Lindon NOT happening on Windows. I was just showing you were the setting was



  • @dustbro thanks. - On more than one front... because:

    @Christoph-Hart --- that seems to fix it. I re-compiled with optimisation set at its lowest(no optimisation) level -O0 ...and it now works.

    -- what a relief, now I can get the customer off my back....



  • @dustbro thanks for the tip with the »no-optimisation« setting! loading loops and impulses works with this on mojave.

    @Lindon thanks for your time figuring it out!!!

    @Christoph-Hart after working with HISE for over a year on my day off for 12-hours every week I was so frustrated by this, that i bought kontakt. believe me, i had a quite a few of this ******-moments, and i´m not a guy that easily gives up. i really love what your doing and i love the project and all the guys/girls around here, but, at in the end i want to spend time creating instruments and not fiddling around with random-settings for hours/days just to get HISE to work (again). It was a pain to get it to work the first time on mac. It was a pain getting it kinda to work on windows. It was a pain trying to get it to work after I had to update my mac to handle my dayjob. and, believe me, I delayed that os-update as long as possible.

    ok, with this off my chest: do you see any chance to get this heavyweight off the shoulders of the not-so-c++sy-users, like me?

    I am thinking of a HISE-build-server:

    1. you connect your instruments github-repo
    2. you merge your dev-branch to release-branch
    3. which triggers automatic builds for any target platforms (windows, mac, and linux...)
    4. you receive the links to the builds

    You would use it to build new HISE-updates, which would ensure that it works. No user would have to compile HISE or their own instruments ever again.

    You said once in a post: »Life/time is too precious to rebuild the pool files on every compile« which made me smile. I think: Lifetime is too precious to setup build environments at all!

    Christoph, what do you think? Can i help to set something like this up? Would it be possible with something like:
    https://azure.microsoft.com/de-de/services/devops/pipelines/

    Cheers
    Peter



  • Christoph, what do you think?

    Yes, having a "hosted" option for people who don't want to compile themselves is on our roadmap (will be part of the resurrection of the HISE Player).

    I re-compiled with optimisation set at its lowest(no optimisation) level -O0 ...and it now works.

    This is not a solution, you don't want to ship a product which is not optimised. I've just updated to Mojave and can reproduce the issue - it has something to do with new security settings that prevent unsigned apps from loading files. I am working on a fix right now.



  • OK, I need more time, this seems to be impossible to debug without contacting Apple about their new security policy.

    In the meantime, you can deactivate Link Time Optimisation (which is the culprit). The binary won't be as fast as with it enabled, but it's 100x better than O0


Log in to reply
 

11
Online

521
Users

1.9k
Topics

14.7k
Posts