General issues with exported plugins. HISE feb 6 build



  • Hey Guys,
    I'm having some general issues with the latest version of hise. Exported vsti are getting blacklisted in Cubase 9+10 PC (haven't checked mac yet) and AU vsti aren't showing up in Logic or Garageband. Looks like the last time this worked for me was the build in mid January. @Christoph-Hart What's the proper way to debug something that wont show up in the DAW plugin list?



  • @dustbro I had a problem with plugins being blacklisted. Try disabling link time optimisation before building and see if that solves the problem. This tool might also be useful - https://github.com/Tracktion/pluginval



  • blacklisting is extremely annoying - the reason might be as simple as having another binary with the same version number and some hosts think you're using a cracked plugin and boom - blacklist.

    There's not too much to debug I am afraid, but you might try cleaning the plugin cache, then set the debug executable to the host in question, start debugging and try to capture anything funky in the initial loading of the plugin during the scan.



  • @Christoph-Hart It's strange how Cubase interacts with the plugin. I can export a version that works fine, make some tweaks, and then the new version gets flagged.... and then re-export the same plug and it doesn't get blacklisted?/



  • @Christoph-Hart
    I'm having issues exporting AU plugs that load in Logic/GarageBand.

    Error message in /var/log/system.log

    Mar1 10:38:13 imacs-iMac kernel[0]: Sandbox: coreaudiod(169) deny file-read-data /Library/Audio/Plug-Ins/Components/Test.component
    
    Mar1 10:38:13 imacs-iMac kernel[0]: Sandbox: coreaudiod(169) deny file-read-metadata /Library/Audio/Plug-Ins/Components/Test.component/Contents
    
    Mar1 10:38:13 imacs-iMac kernel[0]: Sandbox: coreaudiod(169) deny file-read-metadata /Library/Audio/Plug-Ins/Components/Test.component
    
    Mar1 10:38:13 imacs-iMac.local coreaudiod[169]: 10:38:13.560 WARNING: [SystemSoundServer] >compload> AudioComponentPluginLoader.cpp:596: QueryBundle: AudioComponentPluginLoader: can't create bundle: Test.component -- file:///Library/Audio/Plug-Ins/Components/
    
    Mar1 10:57:48 imacs-iMac kernel[0]: Sandbox: coreaudiod(165) deny file-read-data /Library/Audio/Plug-Ins/Components/Test.component
    
    Mar1 10:57:48 imacs-iMac kernel[0]: Sandbox: coreaudiod(165) deny file-read-metadata /Library/Audio/Plug-Ins/Components/Test.component/Contents
    
    Mar1 10:57:48 imacs-iMac kernel[0]: Sandbox: coreaudiod(165) deny file-read-metadata /Library/Audio/Plug-Ins/Components/Test.component
    
    Mar1 10:57:48 imacs-iMac.local coreaudiod[165]: 10:57:48.218 WARNING: [SystemSoundServer] >compload> AudioComponentPluginLoader.cpp:596: QueryBundle: AudioComponentPluginLoader: can't create bundle: Test.component -- file:///Library/Audio/Plug-Ins/Components/


  • Is this also happening with one of the plugins in the tutorials repository? I haven't heard any issues from HEXERACT users and I've pushed out an update a few weeks ago.



  • @Christoph-Hart im gonna do a proper debug and figure out what's up. I should note that this issue is only with FX plugin export. Virtual Instruments are okay.


Log in to reply
 

8
Online

503
Users

1.8k
Topics

13.7k
Posts