New Layout Bugs (not feature requests)



    • Bookmarks, //! Enter bookmark title, don't show up in the bookmarks side panel

    • The Add code bookmark context menu item doesn't do anything

    • When loading a saved project xml file I get a Component with name ... not found error for every component. But the project works just fine.

    • ctrl+shift+f and ctrl+g don't do anything - probably Linux only because I see others are using these - the context menu items work.

    • Changes made to module names arn't shown in the module tree until the edit button is clicked again.

    • F6 doesn't toggle global layout mode

    • Snex editor can't be added to custom workspace or tab (at least I don't see a way to do it without editing the xml manually)

    • More an oversight than a bug - there is no API browser or module list without adding custom popups - would be good if these were tabs in the sidebar like the module tree.

    • Adding an API browser as a custom popup, saving the popup, closing it and reopening it causes HISE to crash.

    • Long standing bug - the parameter list in the module browser are shifted. Right click on the midi channel setter for example and you'll see the parameters for the midi muter.

    • Clicking the Routing button in the Create Node window causes HISE to crash

    • If you close/minimize the script editor, then close HISE, when you reopen HISE and reopen the script editor it doesn't show the contents of the interface script.

    • Routing matrix buttons are missing, how do you access the matrix? Mystery solved f39df306-c533-4e28-926d-ca69cda87167-image.png

    • Scroll wheel doesn't affect table node curves



  • Scroll wheel doesn't affect table node curves

    Yeah, I removed it, it's now a right-click drag, the mouse wheel was interfering with too many things.

    F6 doesn't toggle global layout mode

    Also intentional, I pressed it too many times with my monkey fingers when trying to compile a script, it's still available in the menu (View -> toggle layout mode), and it's used very infrequently

    More an oversight than a bug - there is no API browser or module list without adding custom popups - would be good if these were tabs in the sidebar like the module tree.

    Fixed.

    Adding an API browser as a custom popup, saving the popup, closing it and reopening it causes HISE to crash.

    Fixed.



  • Loving this

    b134ca9c-2424-4bc7-b644-a76dad2e68e8-image.png



  • @d-healey Was afraid I had to develop my own spectrum, now it's becoming wouaw 😍



  • @ustk This is part of the sample editor, not a component for the UI - but you never know what the future holds 🙂



  • @d-healey noice



  • @d-healey Nice, Where is This Beauty?
    Develop Branch?





  • @d-healey Thank you sir, I Was watching the develop Branch, and Wondering why There Is no New Updates Since 26 Days ago.

    is Everything mode to This New Layout?



  • @Natan said in New Layout Bugs (not feature requests):

    is Everything mode to This New Layout?

    No. The new layout branch is where Christoph is developing the new layout, it will be merged into the develop branch when it's complete, or you can use it now if you want to help test it. In my own repo I've already merged it into the develop branch if you want to have the best of both until Christoph is ready to merge.



  • The sampler workspace is getting a overhaul at the moment and I added the spectrograph from the scriptnode test system to the waveform:

    80a1d75c-271e-4297-a5bb-e1909db3aa3a-image.png

    The idea is to have a slider to blend between the waveform and the spectrogram (here it's about 50/50).



  • @d-healey said in New Layout Bugs (not feature requests):

    own repo

    Thank you so much, and thanks for the link



  • @Christoph-Hart said in New Layout Bugs (not feature requests):

    workspace is getting a overhaul

    Can you add some keyboard shortcuts for shifting the pitch? Also can you prevent focused being lost from the mapping editor when adjusting the start position using the mouse in the waveform view? 😄

    The idea is to have a slider to blend between the waveform and the spectrogram (here it's about 50/50).

    Looks awesome!



    • HISE crashes when loading project with external script files - JUCE Assertion failure in BackendApplicationCommandWindows.cpp:460


  • You mean if you use include("SomeFile.js") or if you connect a script to an external file (because I didn't check the latter for years).



  • @Christoph-Hart The latter, connecting to an external file. Seems the bug was only introduced in the last few days, trying to narrow down the commit now.



  • It's strange. I rolled back to a commit I knew would definitely work and I still had the same issue. So then I removed my .hise folder (that's the one that holds on the config stuff on Debian) then when I opened HISE everything worked, and that issue with the cannot find component with name... error is fixed too.



  • Uh I'm narrowing it down by removing one config file at a time. Yesterday I setup pipewire on my system and it seems it's the DeviceSettings.xml file that was causing the trouble, changing the output device to JACK (which is still running through pipewire) solves it!

    The component wasn't found issue was resolved by removing projects.xml but since this is recreated by HISE that problem returns on the next load.



  • Last update broke the spectrogram slider 😞 easy come easy go 😛 But we gained external audio editor button!



  • The Lord giveth, and the Lord taketh away.


Log in to reply
 

11
Online

1.6k
Users

4.6k
Topics

42.8k
Posts