Linking error (Undefined symbols) when compiling an instrument



  • After having spent a few hours troubleshooting it seems that the instrument I am building has an error when trying to build the instrument using the very latest HISE scriptnode version on OSX Mojave and Xcode 10.1:

    ▸ Linking atma\
    
    ❌  Undefined symbols for architecture x86_64
    > Symbol: hise::Unlocker::Unlocker()
    > Referenced from: hise::FrontendProcessor::FrontendProcessor(juce::ValueTree&, juce::AudioDeviceManager*, juce::AudioProcessorPlayer*, juce::MemoryInputStream*, juce::MemoryInputStream*, juce::MemoryInputStream*, juce::MemoryInputStream*, juce::ValueTree*, juce::ValueTree*) in lto.o
    
    
    
    ❌  ld: symbol(s) not found for architecture x86_64
    
    
    
    ❌  clang: error: linker command failed with exit code 1 (use -v to see invocation)
    
    
    ** BUILD FAILED **
    
    
    The following build commands failed:
    	Ld /Users/briandoliveira/Documents/ATMA/Bruitage-master/Binaries/Compiled/atma\ 210.app/Contents/MacOS/atma\ 210 normal x86_64
    (1 failure)
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    
    [Process completed]
    

    After much googling and searching forums, this seems to be a C++ resource mismatch with the "hise::Unlocker::Unlocker()" callback, so if anybody knows how this can be worked out ( and defined ) it would be super appreciated 🙏🏽



  • exact same thing here with Catalina and Xcode 11.3.1 .. help on this would be awesome.



  • I'm able to compile VST and VSTi on Catalina + Xcode 11.3

    Do you have "support 32bit OS" unchecked in your HISE preferences?



  • @dustbro @meyerkeys on my side the only way I was able to get around it was to completely rebuild the project from scratch and load a HISE snippet from the bugged version. You just have to make sure to copy any assets over from the old project to make sure you keep all images etc.



  • Do you have a RSA.xml file in your old project?



  • @dustbro yes, support 32bit is unchecked.



  • @Christoph-Hart yes. ProjectFolder/RSA.xml



  • Delete it, you‘ve accidently turned on copy protection without having the additional code files used by the license server.



  • @Christoph-Hart 🙏🏽🙏🏽🙏🏽 thanks for the insight!



  • @Christoph-Hart thanks a lot Master Hart! After deleting it the file the building works.


Log in to reply
 

17
Online

612
Users

2.5k
Topics

19.3k
Posts