Projucer And macOS Catalina

  • Hello Music lovers

    Trying To Build Hise On A Macbook With Catalina, But The App Projucer Won't Open.
    Any Advice?
    Screen Shot 2020-01-07 at 2.38.46 AM.png

  • I just upgraded my mac mini. I'll let you know what happens shortly

  • did I just shoot myself in the foot? IPP isn't compatible with Catalina yet 😞

    I'm so confused. IPP 2020 says it's 10.15 compatible... but the download page only has 2019v5 available?
    Anyone have a link to IPP2020 ?

  • I can't see a download link for it either. Send them an email.

  • @d-healey from what I've read, it's only available as a bundle within Parallel Studio XE or System Studio.
    Stand-Alone and integration with X-code 11 isn't available yet.

  • @dustbro

    Also The Command gem install xcpretty.
    Doesn't Install Anything on Catalina

    I Found An Updated Line OF Codes Here :
    The Guy Said:

    sudo gem install xcpretty -n /usr/local/bin did the trick for me
    you also might have to reinstall ruby brew reinstall ruby before

  • @Natanr I'll give 2019v4 a shot, but according to their site, it's not compatible with 10.15

    Screen Shot 2020-01-06 at 9.56.31 PM.png

    I was able to get xcpretty to install with:

    sudo gem install xcpretty

  • @dustbro And What About The Projucer?
    The App Won't Run Here 😞

  • @Natanr the Projucer bundled with HISE doesn't launch here either.
    V5.4.5 from the JUCE site does. I'm not sure if it's recommended to use though. Maybe @Christoph-Hart could advise.

  • Here are my findings.
    2019v4 gives me a warning when launching the installer (as does 2019v5)
    Screen Shot 2020-01-07 at 6.26.36 AM.png

    You're able to install the software even though you get the warning. I'll bet v5 would work as well. Make sure you do a "custom" install to additionally select "multi thread" support. Regular install will only do single thread.

    Once that's done, I was able to use projucer 4.5.4 from the juce website to create the xcode project for HISE standalone (haven't tested plugin version yet).
    It compiled fine in xcode 11.3 (with the usual warning messages).

    Screen Shot 2020-01-07 at 8.19.28 AM.png

    You can also see I'm running Catalina on an unsupported mid 2010 mac mini. All seems to be well so far... other than some heavy CPU usage by kernel_task.

    I haven't compiled a project from HISE yet, so that's the next step.

  • batchCompileOSX: line 2: /Applications/HISE-scriptnode/tools/Projucer/ Permission denied

    We'll probably have to redirect HISE to the newer version of Projucer, or just copy the new version to the HISE folder.
    I'll tinker with that later today.

  • Looks like it's a no go to compile a plugin as the Hi_Modules seem to be referenced from a modified version of Projucer.
    Maybe @Christoph-Hart can update the included version of projucer to 4.5.4 at some point in the future?

  • @dustbro I'm always using the last version from the official Juce website.
    I don't know anything about Cataclysma... Euuhh Catavista... Euuhh Catalina I wanted to say!!!

  • @ustk I only looked at it quickly. Good to know you're successfully using the latest juce

  • Good to know you're successfully using the latest juce

    But how did you back port the customizations I did to the juce codebase? I am sure there are a few ones that prevent compiling HISE with the stock JUCE code.

    BTW, if you want a better projucer, just build it again using the source code in the HISE codebase, the projucer binary in the repo is just a compiled version of this.

  • I mistakenly replaced the JUCE folder within HISE instead of just swapping out Projucer.

    It appears to be working.

  • @Christoph-Hart Humm that's strange, I just launch the 5.4.5 Projucer, then I open the Hise standalone.jucer file, apply the current IPP and OS structure change if needed, and compile...

  • @ustk I've just tried to build HISE on Catalina, using:

    • Xcode 11.4
    • Projucer 5.4.7

    As the rest of this thread suggests, the modified Projucer included in the HISE repository doesn't open on Catalina, so I tried to build using Projucer 5.4.7 downloaded directly.

    I'm running into a bunch of build errors, however. I was able to fix preliminary ones about IPP (by building without IPP as the HISE wiki suggests), but now I'm getting these:

    Screen Shot 2020-04-12 at 7.16.46 PM.png

    Any advice would be much appreciated!

  • @breezykermo not a supported OS... wait until it is supported

  • While you wait for a solution, here is a build that will work -

Log in to reply