Export Samples for Installer - failing.



  • OK I have my project ready to roll.

    I press

    Export>Export Samples For Installer

    The dialog box shows up and I press OK

    Immediately HISE comes back and tells me:

    "All samples were exported without errors"

    I go look for the hr1 file(s) and there is nothing there.

    I tried both

    resume on existing archive: yes

    and

    resume on existing archive: no

    Clearly some flag is set somewhere ..

    here's an example sample map:

    <?xml version="1.0" encoding="UTF-8"?>
    
    <samplemap ID="AccentPiano" RRGroupAmount="1" MicPositions=";" SaveMode="2">
      <sample Root="84" LoKey="83" HiKey="97" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/C6.wav" Duplicate="1"
              MonolithOffset="0" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="51" LoKey="50" HiKey="52" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/D#3.wav" Duplicate="1"
              MonolithOffset="442368" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="63" LoKey="62" HiKey="64" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/D#4.wav" Duplicate="1"
              MonolithOffset="884736" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="75" LoKey="74" HiKey="76" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/D#5.wav" Duplicate="1"
              MonolithOffset="1327104" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="54" LoKey="53" HiKey="55" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/F#3.wav" Duplicate="1"
              MonolithOffset="1769472" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="66" LoKey="65" HiKey="67" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/F#4.wav" Duplicate="1"
              MonolithOffset="2211840" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="78" LoKey="77" HiKey="79" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/F#5.wav" Duplicate="1"
              MonolithOffset="2654208" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="57" LoKey="56" HiKey="58" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/A3.wav" Duplicate="1"
              MonolithOffset="3096576" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="69" LoKey="68" HiKey="70" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/A4.wav" Duplicate="1"
              MonolithOffset="3538944" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="81" LoKey="80" HiKey="82" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/A5.wav" Duplicate="1"
              MonolithOffset="3981312" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="48" LoKey="35" HiKey="49" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/C3.wav" Duplicate="1"
              MonolithOffset="4423680" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="60" LoKey="59" HiKey="61" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/C4.wav" Duplicate="1"
              MonolithOffset="4866048" MonolithLength="442368" SampleRate="44100"/>
      <sample Root="72" LoKey="71" HiKey="73" LoVel="0" HiVel="127" RRGroup="1"
              FileName="{PROJECT_FOLDER}Pianos/Accent Piano/C5.wav" Duplicate="1"
              MonolithOffset="5308416" MonolithLength="442368" SampleRate="44100"/>
    </samplemap>
    

    here's the samples folder:
    e5e5390c-7ec3-467c-8a41-9ad2060411e5-image.png



  • OK right well I can repeat this easily.

    I created a brand-new project.

    I created as sampler...

    I copied into the folders one sample map and one ch1 file....

    I can manually load the samplemap into the sampler

    • It plays fine

    I try and export samples for installer and nothing happens.

    -- I can upload the project if you like.



  • OK somehting is pretty badly broken I think.

    I ...

    created a new project.

    loaded some audio into the Samples folder

    created a sampler
    dragged in the audio wav files and mapped them

    • they all play fine.

    Created a samplemap

    • exported them as a ch1 file

    tried to Export for Installer - again nothing is being created.....





  • @Christoph-Hart great - all good - again.


Log in to reply
 

8
Online

517
Users

1.9k
Topics

14.6k
Posts