Sample Maps are losing their path



  • I create a sample Map... and save it on my D drive , then attempt to save the sample map as a monolith and I get this:

    Missing files:
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A#2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A#3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A#4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_A#5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_B2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_B3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_B4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_B5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C6.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C#3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C#4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_C#5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D#3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D#4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_D#5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_E3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_E4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_E5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F#2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F#3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F#4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_F#5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G5.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G#2.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G#3.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G#4.wav
    C:\Users\Lindon\Desktop{PROJECT_FOLDER}Slow_G#5.wav

    thats not the path!!! "C:\Users\Lindon\Desktop" has never been referenced in my project. How do I correct this?



  • @Lindon Change the paths in the sample map to the correct location. If they are in the project's samples folder then you should be able to remove the C:\Users\Lindon\Desktop part.



  • @d-healey yeah that was my first port of call but this is what the sample map looks like(well part of it anyway):

    <?xml version="1.0" encoding="UTF-8"?>

    <samplemap ID="SlowLeslie" RRGroupAmount="1" MicPositions=";" SaveMode="2">
    <sample Root="45" LoKey="45" HiKey="45" LoVel="0" HiVel="127" RRGroup="1"
    FileName="{PROJECT_FOLDER}Slow_A2.wav" Duplicate="0" SampleStart="5230"
    LoopStart="46606" LoopXFade="32400" LoopEnd="213250" LoopEnabled="1"
    MonolithOffset="0" MonolithLength="233472" SampleRate="44100"/>

    • so you can see its using a combo of {PROJECT FOLDER} and the file name.

    I have another sampleMap in the same instrument, here's what its look like:

    <?xml version="1.0" encoding="UTF-8"?>

    <samplemap ID="FastLeslie" RRGroupAmount="1" MicPositions=";" SaveMode="2">
    <sample Root="41" LoKey="41" HiKey="41" LoVel="0" HiVel="127" RRGroup="1"
    FileName="{PROJECT_FOLDER}Fast_F2.wav" Duplicate="1" SampleStart="7820"
    LoopEnd="201435" LoopEnabled="1" LoopStart="51918" LoopXFade="2300"
    MonolithOffset="0" MonolithLength="229376" SampleRate="44100"/>

    -- yeah exactly the same - but this one will build a ch1 file no problem.

    The only diff I see is Duplicate="1"



  • And what if you change the Duplicate property manually using a text editor?


Log in to reply
 

6
Online

474
Users

1.6k
Topics

12.1k
Posts