SliderPack Resolution in Compiled plugins



  • I seem to have hit a problem.

    I have a number of sliderpacks in my instrument. All are set to stepSize 0.01, however when I build a 32-bit VST plugin under windows (I havent tried any other target yet) they all resolve in the finished VST to resolve at 0.1 - which a disappointment - what am I doing wrong?

    Edit: built a 64-bit VST - same problem.



  • OK I have done some more investigating.

    When you load an independent sliderPack it works fine in the compiled plug with the correct resolution, BUT....

    if you attach the sliderpack to an LFO that is using steps, then it works fine inside HISE, but resolves to 0.1 increment steps in the compiled plug-in.

    Any chance of getting this looked at ASAP? -- every instrument I am looking at porting/building uses these step-based LFOs for their independent modulation sources. So I need these to work correctly and I need it pretty bad....so this problem is holding up all my potential releases.



  • Are you using the master branch?



  • Nevermind, I've fixed it on the master branch 🙂




Log in to reply
 

9
Online

551
Users

2.1k
Topics

16.1k
Posts