Win Audio Driver on Standalone App



  • Hi there, I'm getting this on Win standalone compiled .exe every time I open it. Cleaned preferences on /Roamin/AppData/ but still happening. I'm using this as option for setup menu.
    Also most of them are "false" but keeps happening. Any idea?

    alt text

    
    const var audioSettingsData = {
      "Type": "CustomSettings",
      "Font": "Arial", 
      "FontSize": 12,
      "ColourData": {
      	"bgColour": "0xFF2b2b2b",
      	"textColour": "0xFFafaeae"
      },
      "ScaleFactor": true,
      "Driver": false,
      "Device": false,
      "Output": false,
      "BufferSize": false,
      "SampleRate": false,
      "GlobalBPM": false,
      "StreamingMode": false,
      "GraphicRendering": false,
      "SustainCC": false,
      "ClearMidiCC": false,
      "SampleLocation": false,
      "DebugMode": false,
    };
    
    settingsPanel.setContentData(channelData);
    settingsPanel2.setContentData(audioSettingsData);
    settingsPanel3.setContentData(midiInput);
    


  • @hisefilo that has nothing to do with anything you can do, it happens on Mac as well, the only work around I found to eliminate that was compiling the plug-in/instrument from the juce file that is automatically generated when you exports your projects. Once you do that you won't need to add the audio device, juce add it automatically



  • @jay I did that in order to fix it. Worked. But i needed to delete the entire audio settings call. I wish to keep UI scale factor, max voices and some others. is it possible?



  • @hisefilo yes you can, I set up mine exactly like what you are saying, I'll post you a snippet in a bit when I get home.



  • @jay awesome!!!! thanks



  • @hisefilo Here is the snippet, sorry I don't know how to formatted property

    HiseSnippet 1364.3ocsWsraaaDEcnsoQrpUPLP.5tBBsnPA00fTVxVtEEIQxVAN0OTkbCBPQgwHxQRCB4LDjCcpSfW1ujtn+AE4qna6GQ2zks.Ev8Nb3SIAWqBTuwbtOFdtuN7p9AbaRXHO.oswEW6SPZapO7ZlXZ2oXJCc7gHsGpeJNTPBLTh5bsONLj3fzzV8ERAZarFJ9u+3ocvtXlMIWDB8JN0lbB0iJxk1+YeM00sG1gbA0qf0Me1w1bVWtKOBvyp5lHer8avSHmgklshNRa8ibnBdvPAVPBQZq0g6b8vo72xT1+JZHcjKQdvBMDtHk3dbWGIhkRQcmRcc5mF2gH3V5mmEVUkEdr9oTGZl77rwihUXj6Qw7g1J2E7r92gm4hfmVA3slBdaoOzNf5Kx0Hw1GoeLCJTiwPInHrT1hVwaU8tbvBlXGO7aH8BfCYdTeOSysMZYZ9jurZkpUfBQnv3Jbfw.RH8cX.1FekQp6XGmNQBAmUuVl5Zaazvp01FV6su5JRMNjHwoOIPPIgvK06kCO+rxN99pULf+p8VpiXZsuvX21amHYJgNYpnjnwTWuPADRG6A8FfpZuu+fye4Qcu3xdmexgGM3lyHucHQHnSB2wmMAteiDWCswtjdXanFA9YtSilUqbiBsUqjAHIhkfOf61E65NBZBqmoraGk8TlKkQLFGwrETNynfA0sUNuMj+biHOoZkj3KGW8wLh6NgPqQxKptxT3puQgl7BvLdUtLDKpdsYrQVKZ0VVK18dUKl28XDmUOZzpQb1OubzbWkfQSTyqxxvAsOncqV62b2ZJcTAwKWaudcZ1vpg0bJanzZZ1p4AlIZGwCbHACvNznPPskYQwCouSV1kHHo3kUE3ry3Bx4r5Oox6qrQkalSy3wKRURQvkDrHsRVpf6vs5rHuQjfzxchcvvZY1f0uerA1pRUAC4riYTw49jjy2McFJoVKYNR.HXpHl23gI7FpgWD0QRZj04hhweQ1az2d7gXAN8pfaMu6AjcH4JfcWQIsg9gjv2H39.QcWtmOmIwf1CtWu3e.ooq8av66Z4C+L7PbmGbqq+oIHQ04UTRYd.jlg9cyCfJL8KCxO7I+3u+Me3WeJp.b2TA2po7qxogXztk9LyHJLuhVBl+ohX9umCyeVhj7tdjVE8zQhBhanjqFFPoSWxrU1zEp3vg7xqjb44SGRoqlH8pz1L36SZyGpONIT64xwBJaxETvVU8wNNdYSBUw5ec6s2FGq+I7PRrpq8wZ4wot1dvKzGG.ufBuo4yc4w0l5MareaqCLMaaVJ6HUbPyCZYYY0pb9ojlj1RUO3iz6FEJ3dY3Nt4ckeQSWQmcX.8JhjLZL1MjnnTT8vkkcdjvORTVVmnwiyndJHeH1y2kL.FwKK+Et7QX2N8OcFyEADrG.tS4Ny5Q.1eJ0d.gAUQvhYbrzmtDAQoxgHFVNoa2xlGu20y83QLwoQtBpuKc1HuqKAGH2lYVeUgzIbarjma1z0nnEf8Bn6DZnL08cpO4YtSqsSeZ+zGsR++NMxDkYWC4+9dfZGVTbtEef0u3NQtXQ4cxjKhln.PbokejK3vBohqKtn5Rrnl48dOx6Kb2RuOUXOcw3ckEfWf98+a7lr1aU8iftbaQNXWSu2q+uti6R.kA7H4D6oXfOWR1bVj2PXZ2l.HgALFgwjsxOtoNaJOKyLCgok3C.mzsIJsjm0RTZkpD4gsC3Wlralbw5GDKAvDK92WrA7CcfyFVoeGThaOX93RaaYh3yAjuXOZrzdr6R6Qyk1iVKsG6szdr+R6Q66vCIYzyi.Bb0XAHn+QwT3ZZGwjKJD2Ah9GnnzCjK

    Just change "false" to "true" on the options you need.



  • @Jay thanks!!!! I can see it. But when I set any other item to "true", json is not updated. It comes back to the "false" you setted. How did you set it to true on UI Scale factor?



  • Press F5 to apply the changes (really need to add something here to make this more clear).



  • @hisefilo press F5 to save changes



  • @jay don't have that key 😞 on mac. Will try to find how to do that on my mac keyboard



  • @jay also Del key is a pain for mac users. I need to do Fn+Backspace LOL Christoph loves PCssssssss



  • @christoph-hart didn't see you reply!!!!! Yep. Will be cool



  • @hisefilo just tell me what do you need "true" and I'll send it to you



  • @jay on a Mac laptop you have F5 too



  • Fn+F5 🙂



  • @jay Fn+F5 yay!!! Thanks for your offer. 🙂



  • @christoph-hart Yep!!! f5 text is a small gray thing in my mac. The key is operating keyboard brightness by just pressing it



  • @hisefilo fn+F5 will do change the brightness setting to regular F5 key function



  • By the way, can you describe again the exact steps to reproduce the issue and how to fix it? This is nagging me for quite some time now too.



  • @christoph-hart you mean the audio driver issue?

    Compiled the standalone .exe version for the rhodes you already have, but adding the audio settings panel.

    By opening the .exe it says audio driver could not be initialized. (Looks like compilation saves the audio driver from mac or whatever, and looks for Core Audio instead of Windows Audio or whatever)

    Fix attempt 1:
    Turned audio driver to false. But doesn't work out
    Turned all of them false but ui scale factor. Doesn't work out either

    Fix:
    Removed the audio settings call completely and worked.

    Also, midi source on plug-in version also kills the plugin when you click it (obviously)


 

3
Online

353
Users

1.1k
Topics

7.6k
Posts