Works on Intel but not AMD...



  • A user is running Ubuntu 18.04 on three systems, two are AMD, once is Intel. My library works on his Intel one but not on either of the AMD ones. Any ideas?

    These are the two stack traces from the plugin trying to run in Carla:

    Thread 1 "carla" received signal SIGILL, Illegal instruction.
    0x00007fffbbe51c50 in juce::AffineTransform::AffineTransform() () from /home/michael/sofia-plugin/Sofia Woodwinds.so
    (gdb) bt
    #0  0x00007fffbbe51c50 in juce::AffineTransform::AffineTransform() () at /home/michael/sofia-plugin/Sofia Woodwinds.so
    #1  0x00007fffbbdafb22 in _GLOBAL__sub_I_include_juce_graphics.cpp.lto_priv.4838 () at /home/michael/sofia-plugin/Sofia Woodwinds.so
    #2  0x00007fffbbdb5ea7 in global constructors keyed to 65535_0_include_juce_audio_plugin_client_VST2_dd551e08.o.351337 ()
        at /home/michael/sofia-plugin/Sofia Woodwinds.so
    

    When running the standalone version, it crashes here:

    Program received signal SIGILL, Illegal instruction.
    0x00000000007dfdc5 in juce::Component::Component(juce::String const&) ()
    (gdb) bt
    #0  0x00000000007dfdc5 in juce::Component::Component(juce::String const&) ()
    #1  0x0000000000870918 in juce::TopLevelWindow::TopLevelWindow(juce::String const&, bool) ()
    #2  0x00000000008718d8 in juce::DocumentWindow::DocumentWindow(juce::String const&, juce::Colour, int, bool) ()
    #3  0x00000000005284c0 in hise::FrontendStandaloneApplication::MainWindow::MainWindow(juce::String) ()
    #4  0x000000000042d126 in hise::FrontendStandaloneApplication::initialise(juce::String const&) ()
    #5  0x00000000007b13e1 in juce::JUCEApplicationBase::initialiseApp() ()
    #6  0x00000000004139cc in main ()
    

  • administrators

    I need a bit more info about the processors. Illegal instruction means that the CPU instruction is not available on the CPU, which usually happens with older CPUs. AFAIK the CPUS from AMD and Intel from the same period should be 100% compatible with each other - even the Intel IPP library works on AMD although I have read somewhere that they made it a bit slower there 🙂



  • Oh yeah, looks like these processors are ancient:

    AMD Phenom(tm) II X4 980 Processor and AMD Phenom(tm) II X4 980 Processor

    Also older nvidia gpus but not sure that will make much difference.


  • administrators

    Yeah, HISE needs SSE 4.1 in different places, and they only have SSE 4a.



  • @christoph-hart So is this SSE 4.1 requirment also system requirment of HISE exported plugins? Because of that should we give this information to the user before they buy the plugin?


Log in to reply
 

4
Online

343
Users

1.1k
Topics

7.1k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.