Uninitialized FX chain



  • I'm getting this message in the latest version of HISE when opening a project that contains effects:

    FX:! Trying to add a processor to a uninitialized effect chain (internal engine error).�
    


  • Interestingly, after restarting my system and loading the project again this message has vanished. However I have a new one 🙂

    So I have this line in a paint routine function:

    g.fillTriangle([this.get("width")-18, this.get("height")/2-2, 10, 5], Math.toRadians(900));
    

    and HISE is complaining

    paintRoutines.js (88): '-' is not allowed on the String type 
    

  • administrators

    Ah yes sometimes when you load a project from XML it looses the value type so a 50 becomes a “50“ and “50“ - 18 is sometimes quirky - that‘s the weirder corners of a type agnostic scripting language.

    This can be easily solved by wrapping the get calls into a parseInt call. But I‘ll take a look at the internals maybe I can do something in the importer code that prevents this.



  • @christoph-hart Yes parseInt was the solution I came to as well



  • I just opened the project again and the uninitialized FX message has returned... both with the XML and the .HIP


  • administrators

    This happens if you create a module before the processing is initialised but actually is not too critical (it‘s rather a warning than an error)



  • This string thing is more of an issue, it also causes the min and max values of sliders (and I would think other controls) to be strings which messes with some of my other functions that are expecting numbers.


  • administrators

    Can you make an example that consistently reproduces the issue? It only causes troubles under certain conditions that I haven‘t figured out yet.



  • @christoph-hart

    If the issue doesn't appear straight after pasting the snippet and hitting compile then it needs to be saved as XML first and reopened.

    HiseSnippet 799.3ocsU8+SSCDE+5XmxltDIw+.Z1O0k.jN1FpgXDXioKJvBCQSLFyQ6s0KzdWS6UfEB+Q4+Y9ef9tdazBVHtn1rrr2W9b6y8deduNLR3PiiEQHiJGOMjhLdJdzTtzqqGgwQC5gLdDVRikncmFRhiotHCikdqJlQkxnzme7lcI9DtCMyEBchf4P+.KfIy7Ft86Y998ItziYA4xt81CbD7tBeQBvikv1nPhyYjIzCHpzJgQF38bYRQzHIAHCxn7tB2oi7DWv04eBKlcpOUYzDMBNHs69BeWEiUdQc8X9tCmeeiQvoLL61uj91+b79LW1M9ypBOKMfYFh70CiROD8Zlmd1ERO6hnmQN5UVSuUvibhXgxrHJt8D7.tjFMl.sf7zRmKpz2MvcEPFb45Ajyn8i.iaPXsos8plcrsarUsp0pBMhXo44jHyPyWaNG1DprqHHTvACq5CIbpey5Z.gqGSkCgxj7HQhjwoViS3NRlfaMowU0pZBO5umr9Xn8uiuuk8k862J8QcF4yHV8GozAo4Xa2pklX28TNh5Hs9BPb3iziEqX3mXtROqFqM21pd.4x5MxR3cT1DOoUiulchW2Xq4z0TvOPHoGxsZT8ppUpdc06FY73hBopQQBeeZTQQUJ8nG.lEOI3TZzpPI2OgNOOngeaEE99UT4E7N59UtDE7Abl7vPJ+9FCPyZxvu93fdDIQI8l4CxKjFIYJJXzidNLSqEhUv8nwmIEgo4NSYfLdrLMZs4xTkPAw.w3xXsnAcIbWvaztMZJbGwupE5BUWS4rosMxKsCohzwFAcO0u1nCB86SBv7nvMwmHu8PpZyzr.PY9VSCJEOOlImley0e8jagUz+P5tBdHS53ULeKU.egNy+a9NaOXM7diGCyXYjsLt+m+2tzqPpnWhLYehLhozJGjDLBVG3PAlvAEjZVvnjR0pssU1pJyHJ2M03mvyrfMU1FyB1bdPPX4DI9lid.Tsoc4TO.m3ouvoBdeksYST5Pol2Av5+u43nJDqALuXDarvHZsvHZuvH5rvH1bgQ7hEFwKe.Dp20tShTDnGKPneASe.TfA�
    

    I think I solved the FX chain issue, it seemed to only be occurring when Jack hadn't been started, I was having some teething problems with a new audio interface.


  • administrators

    Ah I think I know how to solve this. Will do it tomorrow.


  • administrators

    This is fixed now.


Log in to reply
 

2
Online

282
Users

767
Topics

5.0k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.