IR Loader Doesn'twork & Some Errors....



  • @christoph-hart

    • It works on older Hise versions and exports / works as vst. But old Hise exported AU version gives that validation error. (above)
    • On the latest Hise version, when I press the button, it loads (updates waveform) IR sample but there is no sound and after 4 - 5 seconds it crashes/closes Hise automatically.

    I've sent the project link to you....



  • sorry for that, but agree with David.

    Less is more...

    sure your intension is good.
    but just let (as i wrote before) the user choose IR by external files (more flexibility) than as you would do.

    lot of work (too many) and just 1 chance, but THE chance to break the code and make the compiling impossible.
    the powerfull of your plugin is maybe to choose IR that the user want, not only YOUR IR...

    and just to finish you spent a lot of time to solve this instead of creating.... Imaginating you're not the slave of your plugin ... maybe, in fact, it is yours, but not reverese. and just let users some liberty.

    with your system user can just choose what you decide, not what he decides. and it makes the diffrence (not for you, sig ! )

    like we say in French: we say that, we say nothing. and of course you can not be agree with me.

    but i feel you can spend more time creative, than absolutly trying to stuck users in this IR files limited choosing sytem.

    but once and again, it's my feeling, and you can absolutly not be agrre with me ...

    Best VST are made by musicians for musicians. I want to expalin you that sometimes you have a great idea (like this one) but just try with a simplier function (in this case the onboard Christoph system) and let the customers tell you if it's good or not. if "or not" so continue in your way. if you want to create something like altiverb, just let me explain that i hate it. I prefer something with more liberty...

    my goal is to create music, as i feel, not depending of the creator decision.

    I know all this is very pretentious. but we Frenchmen sum it up, in truth.

    I know that blocking an idea is frustrating. and David and Christoph can certify it by my posts.

    but when we begin to code we forget an essential function: to create, to compose.
    I speak by experience. I stopped coding, I compose again.



  • @staiff I'm not making a plugin that uses common IR sample styles (Hall, room, plate..etc). I'm just building a speacial IR loader stuff that it simulates special (hard or impossible to find their IR samples) speakers. Like 1950 grampophone, vintage phone...etc... You think just like on your usage. But there is not a one way. So everyone's purpose is different, user's will be different too....



  • @orange

    ooooooooh like "speakerphone" (don't remember the developer name)

    i unsterstand now.

    i remember i had the same problem with rackafx new system. stuked by the C++ possibility.

    but why don't you create an "open" system with external IR that you can put with your plugin. (?)

    in this case you could update your IR library independently of your plugin if no update needed ?

    and in this case create 1 - plugin section (with updates) and 1 IR file section (with updates)

    you kill two birds with one stone, as they say in French

    wow, not sure for the translate after reading it ๐Ÿ˜‰



  • I've took a look at the project you sent me. The problem was that the metadata of your impulse responses contained weird values (the loop range was 12303425723456345 samples), so it created a ridiculously high impulse response and crashed ๐Ÿ™‚

    I've added a protection to the metadata parser that prevents this kind of malfunction.

    Apart from that everything is working fine.



  • Thank you so much Christoph, I appreciate it...
    But did you export the project as AU unit? Logic Pro X gives this error when startup (validation error); ๐Ÿ˜ž

    --------------------------------------------------
    PUBLISHED PARAMETER INFO:
    
    # # # 34 Global Scope Parameters:
    WARNING: retrievedValue = 1.000000 (was 1.000000), Parameter did not retain maximum value when set
    WARNING: retrievedValue = nan (was nan), Parameter did not retain default value when set
    ERROR: Parameter values are different since last set - probable cause: a Meta Param Flag is NOT set on a parameter that will change values of other parameters.
    
    * * FAIL
    --------------------------------------------------
    AU VALIDATION FAILED: CORRECT THE ERRORS ABOVE.
    --------------------------------------------------
    
    

    NOTE: I've removed all metadata tags from IR samples....



  • Hello @Christoph-Hart

    I saw this thread on Juce forum about AU validation fail, maybe it helps to solve this issue. Please help ๐Ÿ˜ž

    How are you declaring your parameters? Are you using AudioProcessorParameter? You seem to have stripped some output from auval too, but essentially auval is trying to set values on one your parameters but the value being returned doesnโ€™t match what was set and in the last case it returned nan !



  • I need to debug your project in order to find out, there is some weird empty string to double casting going on somewhere.



  • @christoph-hart Thank you,
    If you deleted my project, you can still download from the same link.



  • Nope still have it but I donโ€˜t have time today. Iโ€˜ll try to look at it tomorrow.



  • Alright, I've fixed the AU validation for this project. The reason was that you were using buttons in a radio group as plugin parameters and Logic expects all parameters that change other parameters to be marked as Meta Parameter or the au validation fails - so in this case the error message was actually right, which happens in like 1% of all cases.

    From now on, all buttons that are in a radio group are automatically propagated as meta parameters, however I've added a isMetaParameter which must be manually set for all parameters that change other controls in their control callback.



  • @christoph-hart Wow it works like a charm ๐Ÿ™‚ ๐Ÿ‘ ๐Ÿ‘Œ
    I've disabled "isPluginParameter" in all of the radiogroups buttons. I don't know what "isMetaParameter" does but it's disabled too.

    But AU plugin passed the validation. You are genious Christoph ๐Ÿ™‚

    Am I making something bad with disabling "isMetaParameter"?



  • Do We Need To Enable isMetaParameter For Buttons That Not Goint To Saved On Presets?
    Such as Next/Prev Buttons?
    Or Show/Hide Switches For Tabs?


Log in to reply
 

5
Online

1.5k
Users

4.6k
Topics

42.1k
Posts