Random crashes when using mapping editor



  • I've been experiencing quite a few crashes (HISE instantly closing) while working with the mapping editor. Sometimes it happens when I merge mic samples, other times it's when I try to open a sampler in the sampler workspace. I also get crashes when pressing the X2 button to duplicate samples.

    Another problem I'm having is sometimes when I click on a mapped sample nothing shows up in the waveform display, but the sample does show up in the table view.



  • experiencing the same thing for the last lines:
    "Another problem I'm having is sometimes when I click on a mapped sample nothing shows up in the waveform display, but the sample does show up in the table view."

    but seems only with sfz files. You too or also with raw wav samples ?



  • I'm only experiencing it with HLAC monoliths but I haven't tried with other formats



  • oh sorry ... of course HLAC monolith, but made by sfz (import) before. the problem is the sfz allocation (in the sfz/xml file).
    changing the path of .sfz and samples before creating the monolith fix this.

    with raw file i had no problem. But i most of time use sfz (i create it in sforzando with my wav files before creating my samplemap in hise) to create my monolith file.



  • I've managed to narrow down one crash a little I think. If I merge the mic samples and hit duplicate I get an instant crash, if I duplicate first then no crash - unfortunately I've just adjusted the start position of about 200 samples that were already merged, now I want to duplicate them 😞 maybe I can edit the XML directly though...


Log in to reply
 

4
Online

337
Users

1.0k
Topics

7.0k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.