Linux build of HISE



  • @macromachines I can't remember what I was doing back then exactly. But now I'm using the Linux native version of Reaper and HISE has Linux export so I'm not using WINE at all for this.



  • GitHub master currently failing on Linux Mint

    Makefile:188: recipe for target 'build/intermediate/Release/include_hi_modules_263b29.o' failed
    make: *** [build/intermediate/Release/include_hi_modules_263b29.o] Error 1
    


  • Oops, I didn't touch the master branch for a long time. I'll take a look what's wrong there.



  • The last time I built was the 5th of June, I just tried rebuilding that version and it didn't work either, so I'm thinking maybe there has been some update to my OS which is causing the problem. I also noticed there is more to the error.

                     from ../../JuceLibraryCode/include_hi_modules.cpp:9:
    ../../../../../HISE/hi_modules/effects/fx/ShapeFX.cpp: In member function ‘virtual void hise::PolyshapeFX::getWaveformTableValues(int, const float**, int&, float&)’:
    ../../../../../HISE/hi_modules/effects/fx/ShapeFX.cpp:867:60:error: ‘atanf’ is not a member of ‘std’
      case ShapeFX::ShapeMode::Atan:    normalizeValue = 1.0f / std::atanf(displayPe
                                                                ^
    ../../../../../HISE/hi_modules/effects/fx/ShapeFX.cpp:867:60: note: suggested alternative:
    In file included from /usr/include/c++/5/cmath:44:0,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/../hi_components/../hi_dsp/../hi_core/../JUCE/modules/juce_core/system/juce_StandardHeader.h:47,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/../hi_components/../hi_dsp/../hi_core/../JUCE/modules/juce_core/juce_core.h:178,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/../hi_components/../hi_dsp/../hi_core/hi_core.h:65,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/../hi_components/../hi_dsp/hi_dsp.h:55,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/../hi_components/hi_components.h:57,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/../hi_sampler/hi_sampler.h:54,
                     from ../../../../../HISE/hi_backend/../hi_modules/../hi_scripting/hi_scripting.h:61,
                     from ../../../../../HISE/hi_backend/../hi_modules/hi_modules.h:57,
                     from ../../../../../HISE/hi_backend/hi_backend.h:55,
                     from ../../JuceLibraryCode/JuceHeader.h:17,
                     from ../../../../../HISE/hi_modules/hi_modules.cpp:2,
                     from ../../JuceLibraryCode/include_hi_modules.cpp:9:
    /usr/include/x86_64-linux-gnu/bits/mathcalls.h:58:1: note:   ‘atanf’
     __MATHCALL (atan,, (_Mdouble_ __x));
     ^
    At global scope:
    cc1plus: warning: unrecognized command line option ‘-Wno-inconsistent-missing-override’
    Makefile:188: recipe for target 'build/intermediate/Release/include_hi_modules_263b29.o' failed
    make: *** [build/intermediate/Release/include_hi_modules_263b29.o] Error 1
    


  • I just tried building on an older install of Linux Mint (my laptop that hasn't been updated for a few months) and I still get the same error about atanf.

    Update: I managed to compile by going into the ShapeFX.cpp file and commenting out the line referencing antaf. I'm not using the ShapeFX so hopefully it won't break anything.



  • Congratulations, you are now a C++ developer 😉



  • Well, I, finally built (I think) the HISE under Ubuntu 18.10.
    And, in the build directory HISE Standalone (18mb) appeared. It's been recognized as an extended library and I can't run it...
    The last output from the terminal was linking solution or something like this. Anything is wrong?))



  • @Levitanus try opening in terminal



  • @d-healey said in Linux build of HISE:

    try opening in terminal

    I've trashed the HDD with Linux partition, and have not reinstalled it yet. But Termnal said it can not find the command (opened from the build folder with the file)



  • @Levitanus Drag the executable onto the terminal window and hit enter



  • Greetings,

    I would like to confirm that I have successfully built both HISE standalone and VST2 on Debian Stretch 9.8



  • @Levitanus There is a fix for this. Editing the make file from memory.



  • Use no-pie as an argument(I think it’s argument) in the command line when compiling. Fingers crossed!



  • @danial I use -no-pie as a linker flag in Projucer. Might work as a command line argument too.



  • Attempting to build master branch.

    /hi_scripting/scripting/scripting_audio_processor/ScriptDspModules.h:502:21: error: ‘sqrtf’ is not a member of ‘std’ data[c][i] = std::sqrtf(v);

    None standard standard library strikes again.

    And then there's this stuff, all related to the new Markdown feature. I have the webbrowser disabled in the JUCE project so that might have something to do with it.

    /HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:792:17: error: ‘WebBrowserComponent’ was not declared in this scope
       ScopedPointer<WebBrowserComponent> gifPlayer;
                     ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:792:36: error: template argument 1 is invalid
       ScopedPointer<WebBrowserComponent> gifPlayer;
                                        ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp: In member function ‘virtual void hise::MarkdownParser::ImageElement::GifPlayer::scrolled(juce::Rectangle<int>)’:
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:756:15: error: cannot convert ‘std::nullptr_t’ to ‘int’ in assignment
         gifPlayer = nullptr;
                   ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp: In member function ‘virtual void hise::MarkdownParser::ImageElement::GifPlayer::mouseDown(const juce::MouseEvent&)’:
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:781:38: error: expected type-specifier before ‘WebBrowserComponent’
        addAndMakeVisible(gifPlayer = new WebBrowserComponent());
                                          ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:782:13: error: base operand of ‘->’ is not a pointer
        gifPlayer->setSize(p.img.getWidth() + 50, p.img.getHeight() + 50);
                 ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:783:13: error: base operand of ‘->’ is not a pointer
        gifPlayer->setTopLeftPosition(0, 0);
                 ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:784:13: error: base operand of ‘->’ is not a pointer
        gifPlayer->goToURL(p.imageURL.toString(MarkdownLink::UrlFull));
                 ^
    ../../../../../HISE-master/hi_tools/hi_markdown/MarkdownElements.cpp:785:13: error: base operand of ‘->’ is not a pointer
        gifPlayer->addMouseListener(this, true);
    


  • Never mind, I found a PPA that provides a suitable version of libwebkit

    https://launchpad.net/~webkit-team/+archive/ubuntu/ppa


Log in to reply
 

3
Online

472
Users

1.6k
Topics

11.8k
Posts