Strange behaviour



  • I would like to use the Develop version but it shows a really unusable behaviour.

    Unfortunately, the ScriptContenInterface in this version already has scrollbars at a size of 100%.
    In the previous versions, scrollbars only appeared when the content was larger than the window. - Which is also a
    sensible behaviour.

    Because of these always present scrollbars the following happens when changing the value of a knob with the mousewheel:

    scrollwheel.gif

    Since I, like many others, like to use the mouse wheel to change the value, this is an unbearable limitation.

    Please make it so that you can either choose whether you want to have scrollbars at 100%.

    If not desired, then please describe where I can set this back to the original setting in Juce itself.
    That would be great



  • I think this was already requested in the feature request/bug report thread.



  • @d-healey I know - I hope it doesn't get lost there. Because that's really awful.
    The only reason I'm not working with the Develop at the moment - despite the benefits.



  • Yeah, I changed that. The mouse wheel scroll is now deactivated when you deactivate the edit mode (the thing with the grid). This should fix almost all weird issues and now you can enjoy the seamless mouse-wheel zoom at the mouse position...



  • @Christoph-Hart Jooo - Super - Now the development is fun again - Thank you You are the Greatest 🙂


Log in to reply
 

10
Online

1.3k
Users

4.2k
Topics

38.3k
Posts