latest build and latest tutorial dont work (no floating tiles and compilation error)

  • i have the most recent commit of hise compiled. and im trying to use the latest tutorial project.
    first off the preset browser no longer pops up in plugin preview. and when compiling it shows a red code firt about the floating tile display then says press any key to continue and says compilation.error. the tutorial and builds from before you got back worked aside from the vu meter not displaying externally. please fix this it is completely broken.

  • i tried recompiling the latest hise build and now it just crashes when i click plugin preview? its all messed up man.

  • something about floatingtile factory methods is making it crash on compile and freezes at plugin preview. latest hise build and tutorial commit

  • Ah sorry, I am currently reworking the FloatingTile stuff in order to have a automatic documentation system and this might have broken something along the way.

  • ok i thought i was going crazy. but yeah even the latest build as of this second it is still broken. let me know when its fixed im trying to work on this now

  • bump..kind of cant do anything here. its broken

  • Actually, it compiles fine here (I've just compiled and tested a library on all platforms). Can you try the latest build again (also make sure you recompile HISE)

  • ok so now it is compiling and even showing preset browser in compiled version but it is not showing it in plugin preview in hise

  • You mean in the popup that is opened if you click on the Home button?

    You can't open nested popups. Use View -> Add Interface Preview and it will show an own window.

  • alright. i built the libs for x64 and x86 aax but im still getting errors


  • Welcome to the nastier parts of the C++ language 🙂

    These error messages come from a C standard library mismatch. You need to build the AAX SDK with the correct runtime libraries (you can set these in the Project Properties of the AAX libs).

    You've built libraries which use the dynamic runtime library which is not the smartest thing (don't know why it's the default). Set both x86 and x64 Configurations it to static runtime linking.

    This is a screenshot of my Project settings of the AAXLibrary - unfortunately in German, but you should be able to extrapolate the necessary information without a German crash course 🙂


  • alright got it working! im gonna be setting my mac pro up to compile mac vst/au/aax this week so im sure ill have tons of issues lol. btw did you put anything anywhere about how to use a filmstrip vu meter? i can give you one that im using to test.

  • Make sure you don't install Xcode 9, it is buggy as hell according to everybody...

Log in to reply