getModulator outside of on init



  • According to the API doc getModulator() (and similar functions) can only be called in onInit, however I'm successfully using it in onControl, is this a bug? will it cause any problems?

    HiseSnippet 881.3oc0Vs0aSCCE1tqFwJ2g8BuEMIj5DPU6XbSSH5ZghpXWpnSCj3gIOGmVKRrKNNaTP7af+p7O.NNWVRKAXEAOfUUUN2r+x47cNwCzJFOLToQ3Kr+zIbD9hjgSklwcGSERT+mgvWlrCMzv0NIp5LcBMLj6hv3kdgUAd4pn30WeZGpOUx34pPnCTBFeaQfvjqcP6WJ786Qc46KBJ38Fs6yTxtJeUDfmkHMQSnr2QGw2kZcqBAcrfeRHB2jbu0aneWqi93VMla8BgbKYiNvS8rhChc.whzZtzb.DNBSveCVXxycEFkdngZ3vdR5nbmNbr5DYxQefHTbjO2JzBMDvTh5dJeW6Ku849RHs3QY7Bgg5NV36NHKsFhP3pCxSxKkjjWgrivUbp97j8UiM3jGQwzMtxrPt5LPt0YAxk.ObA3UMAdWiLjoESL4VrX65oZ+InKwHpxMwDMejSfxcyKUCpmgFmioZG.wFmm3zUAIMooA00sSjwnj0W0ZY063zD9s1ldQRlQnjNJ4tJCeOY80p8oZKW6y0l2hmWYlr6uV46y0kY0x2z+hvpKiBNhquCfX+Hdrev6A.63dhFi3lcTtQ9TnHTe0s6smyohqtF71ZctQH2rkwnEGEY30alsUaBmGTBls.V6rU.YI4rBNpj8kBydS3ortrj0Onwyqnp7jSQswIkRbKSUqRXMnz5nk+j5N3pIl8b4TdRR8EI.1w4H1hLJNUTbfA5G4dPGPVNsXagcTSpAnhMCwy1FJCEloE24+88JWLAuDBvChA4UHyvH98Xrml+9HtjMqRXrX+7ops+R6WSOl6ozAImWtmayGAmSQM6yCln.pJq3D3gAJkYrPNZ1gsqztaTnQEjs6H7sHquwbSSOdO3Ouaae7wcikQCM7IOiZnH7aIOXd++asPyW9V5rU9JojU4LRwtQb06z5jsN9Wkk0rTVVo8VKDhOkD8e.huFYfvvFWdebkRvKB8OGuoeQ9Rjm64wYlbvVkz6M+oe9cAfxqTQFn4bGJ7IiO.iS1MJXHb+GFGPhTx8sWMAWwNwMQtoUNtulKcalcalTisrx3TisxLhBnLs5PVxbZaSw4i0.XRFeypkgq3AxNsxlPawc.bQjCYLah3t.xKOh0W3Ht2BGwFKbD2egi3AKbDObgi3Q+hHr25aqHXbbRaAB8cfJgSvM
    

  • administrators

    I recently changed this so that you can call this in the onControl callback which is required when you want to create modulators dynamically, so no it shouldn't cause any problems.

    I think you can't do it in the MIDI callbacks though (and it would be pretty stupid to do so), but I'll have to update the API docs.


Log in to reply
 

3
Online

343
Users

1.1k
Topics

7.1k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.