Problem with building scriptnote (ipp disabled)



  • I have been dealing with Hise for a few days now. I managed to build Hise-master with Visual Studio 2017 and create+export a first standalone application. When trying to export the whole thing as a vst plugin I got an error message and found out via the forum that the master version is outdated. So I switched to scriptnote and did exactly the same steps as needed to build Hise-master: Cloning the project, adding the third party SDKs and since I don't want to use IPP I disabled it in ProJucer in the module hi_core (both in plugin and standalone).
    However, in Visual Studio I keep getting the error message: "...\hise-scriptnode\hi_streaming\hi_streaming.h(69): fatal error C1083: Unable to open file (include): "ipp.h": No such file or directory"
    How can this be possible when I have excluded the use of IPP exactly as before? Have I perhaps overlooked something?



  • In Projucer you might have this redundant value, set it to 0 (might also work if you just delete it too).

    46003e50-2201-49e3-9708-98afdeb9719a-image.png



  • This Solved it.

    Thanks a lot !!! @d-healey



  • I would like to follow up on this post and report on the further progress. Maybe this will help others.

    After I successfully compiled HISE-scriptnote I got an error message after opening and exporting my project which I reproduced here:

    ...\binaries\source\plugin.cpp(30): error C2039: "getExpansionKey": Is not an element of
    "hise::FrontendHandler" [C:...\Binaries\Builds\VisualStudio2017\My_App.vcxproj]
    ...\binaries\source\plugin.cpp(31): error C2039: "getExpansionType": Is not an element of
    n "hise::FrontendHandler" [C:...\Binaries\Builds\VisualStudio2017\My_App.vcxproj]

    This error was due to the fact that in Preferences I had not yet changed the HISE path from HISE-master to HISE-scriptnote.

    After that the following error occurred (and it was rather a hard nut to crack):

    hise-scriptnode\juce\modules\juce_audio_plugin_client\vst\juce_vst_wrapper.cpp
    (95): fatal error C1083: unable to open file (include): "pluginterfaces/vst2.x/aeffect.h": No such file or
    directory [C:...\Binaries\Builds\VisualStudio2017\My_VST.vcxproj]

    It appears that "aeffect.h" is no longer included in the steinberg SDK because VST 2 support has been discontinued.
    "https://www.steinberg.net/en/newsandevents/news/newsdetail/article/vst-2-coming-to-an-end-4727.html"

    I don't know if there is another solution to the problem, but I was able to help myself with an archived version.
    "https://www.steinberg.net/sdk_downloads/vstsdk367_03_03_2017_build_352.zip" (!)

    After downloading just copy the unzipped folder VST_SDK/VST2_SDK_pluginterfaces and paste it into HISE-scriptnode\tools\SDK\VST3 SDK.
    Then everything should work.



  • @JeHathor said in Problem with building scriptnote (ipp disabled):

    This error was due to the fact that in Preferences I had not yet changed the HISE path from HISE-master to HISE-scriptnote

    This one has gotten me a couple times.



  • @dustbro said in Problem with building scriptnote (ipp disabled):

    @JeHathor said in Problem with building scriptnote (ipp disabled):

    This error was due to the fact that in Preferences I had not yet changed the HISE path from HISE-master to HISE-scriptnote

    This one has gotten me a couple times.

    This is why I recommend everyone use git and only ever have one copy of the source code on your system (unless you really need more than one for some reason).



  • @d-healey That's what I'm doing now. Originally, I was keeping each version as a separate folder for instant access.


Log in to reply
 

11
Online

1.2k
Users

3.8k
Topics

33.6k
Posts