More Mac troubles.....



  • OK I'm trying to compile a stand alone version of my product on Mac Mojave with the latest compile of HISE, the process starts but only gets to here:

    Last login: Thu Nov 12 11:15:01 on ttys000
    Lindons-Mac-mini:~ lindon$ /Volumes/Untitled/AnalogElectrics/Binaries/batchCompileOSX ; exit;
    Re-saving file: /Volumes/Untitled/AnalogElectrics/Binaries/AutogeneratedProject.jucer
    Finished saving: Visual Studio 2017 - Builds/VisualStudio2017/
    Finished saving: Xcode (MacOSX)
    Finished saving: Linux Makefile
    Compiling Standalone application AnalogElectrics ...
    ▸ Building AnalogElectrics/AnalogElectrics - App [Release]
    ▸ Check Dependencies

    then it stops ----just does nothing...

    I've tried a different project and it compiles correctly (it doesnt stop at this point)

    Any clues what I'm doing wrong?

    The VSTi compile seems to work by the way...



  • Finished saving: Xcode (MacOSX)
    

    Can you open the Xcode project directly in Xcode and try to compile? That might give you some meaningful error messages.



  • Did you clear the build directory after exporting the VST?



  • Hold fire... it looks like a corrupt file in the "copy to the Mac process"....phew - this one has been a nightmare of hurdles to get out...so fingers crossed..



  • @d-healey Hi David, just in case I need it (I've just updated to Mojave and will build the latest Scriptnode very soon), what is the procedure to clear the build directory?



  • @alepan If I'm remembering correctly, In the build menu in xcode there is an option called clean. Or you can just delete the Binaries folder.



  • @d-healey Ok thanks!


Log in to reply
 

4
Online

882
Users

3.2k
Topics

26.7k
Posts