Convolution Broken...

  • exported plugins using convolution go silent with convolution engaged. there is obviously something terribly wrong with either the embedding or recall or sample rate handling of IRs. ive been troubleshooting this for 7 days. its broken. can you please look into this @Christoph-Hart thanks

    i have tried all different sample rates if IRs different bit depths. every different IPP version. about 40 different HISE builds that seem to work for everything else otherwise.

    the plugins once exported either are completely silent with convolution engaged or make a terrible digital distortion

    COMP1176all_dc.wav 1644-0_dc.wav

    here are two IRs

    both of which worked in HISE as of january. i see soul was added dont know what that is. but it seems to coincide with the death of IR in hise

    im using @d-healey develop build on pc and IPP 2019 v4 which seems to be the last working IPP

    this occurs in projects that are even just a simple convolution and nothing else in the plugin

  • it also will not even let you unload the IR by double left clicking like before. and when you select unload audio files from tools it does not remove the IR

  • @mwplugs Try this impulse F_Stereo.wav

  • @d-healey ok. a few questions. i use deconvolver. what samplerate bitdepth and sec length sweep do you use. reverse technique?

  • @mwplugs I made that impulse years ago, I can't remember what settings I used but probably a 20 seconds sine sweep at 24/48

  • @mwplugs I'm using deconvolver as well.

  • @mwplugs I've tinkered with all of the settings and usually just stick to MP Transform. Just made some impulses that worked fine with the convolution reverb in HISE (although I have other issues)

  • @dustbro im still troublshooting this. i havent tracked it down to any certain practice that causes the digital distortion at 44.1 and 48 khz samplerates. this happens regardless of samplerate and bitdepth of the IR.

    the only time i got it to function over all samplerates is with no IPP on the exported plugin.

    ive also noticed some weird things, the IR loaded just seems to hang in the memory. most IRs work one time if loaded into a empty Convo module and the plugin is exported. every other time it does not. it makes the digital distortion which simplly sounds like it doesnt know what to do with different data via samplerates etc

    im for more of cabinet IRs then reverbs. i have found that you have to have file long than the sweep during deconvo of it produces a file i guess to small for hise to utilize. like i said i had no issues ever up until a few months ago in hise now convolution is so buggy for me.

  • it seems IPP is the issue. whenever its enabled i have issues

  • @mwplugs I'm using the convolution on a new project with IPP enabled and it's working okay at all sample rates. Maybe it's the version of HISE that we're using. I think I'm on the version from Jan24.
    @Christoph-Hart I did notice that a project using the convolution FX will make PluginDoctor crash if "multithread" is enabled. Not sure if it's us or them...

  • @mwplugs What result did you get with the impulse I posted?

  • @dustbro jan 24th from which. scriptnode im guessing. there is no jan 24th build if so link me. and i had issues anytime an IR is loaded already in the convolution. basically if i create a new CR and load an IR the first time it works. it seems its just hanging inside the CR memory or something. i also always see RELEASE RESOURCES everytime i open HISE

  • @mwplugs said in Convolution Broken...:

    digital distortion at 44.1 and 48 khz samplerates

    OH no.... you may be right. I'm getting static at 44.1 and 48K as well on my new project. None on 88.2 and 96k.

    @Christoph-Hart HALP!! 🤣

    Here's the IR I'm using:

  • @mwplugs said in Convolution Broken...:

    i also always see RELEASE RESOURCES everytime i open HISE

    Me too. I don't think that is a cause for concern.

  • @dustbro its nice to know im not crazy lol. yeah i do very extensive testing on things. all different daws, systems on both mac and pc. but yes like i said after troubleshooting thousands of different variables it seems to come down to lower sample rates regardless of IR sample rates (44.1,48) ive gotten a few IRs to work. on all samplerates then out of nowhere it does the same thing. its very confusing.

  • also IRs smaller than a certain size dont show up at all. the longer the sweep since to yield more consistent results. but like ive said all aong...a year or so ago i never had any of these issues. it never had issues at other samplerates or was finnicky about the IR lengths bitdepth or sample rate. but im VERY relieved im not the only one experiencing this now so it can be addressed. i was starting to lose it a bit lol

  • @dustbro has anyone looked into this? its still broken..

  • @mwplugs We're at the mercy of @Christoph-Hart 's free time to fix things like this. If you're patient, it will eventually happen. 🙂

  • @dustbro yeah i figured. im just glad its now a known issue and im not just a crazy person. everyone else was saying it worked. my guess is they havent tried different sample rates

  • @mwplugs I've used it in the past with no issues at different sample rates. That was on a different rig though. It's gotta be the IPP implementation. I haven't had a chance to downgrade and test yet 😕

Log in to reply