VST3 build error: "nothing to be done for 'all'"



  • In the Hise Documentation / VST3 Support is stated

    Be aware that Steinberg stopped support for the VST 2.4 SDK in October 2018 so if you don't have a valid VST2 license agreement in place, you must use the VST3 SDK.

    Does this mean, i have to compile the plugins in VST3 format? How to do that? When i enable VST3 support in the project settings, the makefile won't compile on linux, telling me: "Nothing to be done for 'all'"



  • @toxonic You only have two things to do:

    • Enabling the VST3 support in the preferences
    • Extract the sdk.zip in the tools/SDK folder so the folder structure looks like this: HISE/tools/SDK/VST3 SDK

    Look at your chat messages for the zip password 😉



  • 😕 nope, still doesn't work, still the same error.
    i already had vst3 sdk installed in the tools/SDK Folder, but the one, that was linked on hise github, which contains some more folders, but the structure is the same. nevertheless, i tried the zipped one as you adviced, but still nothing. perhaps this issue is related to another one, i once posted here in the forum:
    the projucer binary, which came with hise, doesn't work on any of my linux OS, why i installed JUCE separately and use that projucer to compile hise and the plugins. the works quite well, as long as i use vst2, but with vst3 i stuck now. 😕



  • @toxonic said in VST3 build error: "nothing to be done for 'all'":

    i already had vst3 sdk installed in the tools/SDK Folder, but the one, that was linked on hise github, which contains some more folders, but the structure is the same.

    Well, I'm not sure, actually I had troubles in the past until I used the one that is provided in hise...



  • @ustk
    yeah, but no luck with that, though. 😕 thank you anyway! 😉 if anybody has got a hint for me, you're welcome! 🙂



  • This guide worked for me https://forum.hise.audio/topic/1444/vst-export-failed/82
    The vst3 sdk in the juce folder works.
    Are you pointing to the correct hise directory in preferences?



  • Nope, still nothing. but i had a look into the makefile, to search for the word "all" and found it only once in line 151:

      $(JUCE_OBJDIR)/include_stk_wrapper_97001de8.o \
    
    .PHONY: clean all strip
    
    all : 
    
    
    
    $(JUCE_OUTDIR)/$(JUCE_TARGET_SHARED_CODE) : $(OBJECTS_SHARED_CODE) $(RESOURCES)
    

    so, i just deleted that line and tried again and it began to compile for a while until i got the error message, that i didn't enable a plugin format (but i did in the project settings):

    Compiling include_juce_audio_plugin_client_utils.cpp
    In file included from /home/toxonic/Source_Applications/HISE/HISE-scriptnode/JUCE/modules/juce_audio_plugin_client/utility/juce_PluginUtilities.cpp:32:0,
                     from /home/toxonic/Source_Applications/HISE/HISE-scriptnode/JUCE/modules/juce_audio_plugin_client/juce_audio_plugin_client_utils.cpp:27,
                     from ../../JuceLibraryCode/include_juce_audio_plugin_client_utils.cpp:9:
    /home/toxonic/Source_Applications/HISE/HISE-scriptnode/JUCE/modules/juce_audio_plugin_client/utility/../utility/juce_CheckSettingMacros.h:35:3: error: #error "You need to enable at least one plugin format!"
      #error "You need to enable at least one plugin format!"
       ^~~~~
    Compiling include_juce_audio_processors.cpp
    Makefile:457: recipe for target 'build/intermediate/Release/include_juce_audio_plugin_client_utils_e32edaee.o' failed
    make: *** [build/intermediate/Release/include_juce_audio_plugin_client_utils_e32edaee.o] Error 1
    make: *** Auf noch nicht beendete Prozesse wird gewartet …
    
    

    any ideas?

    PS: i now had a look into the makefile for a vst2 and found that there are the lines i posted like this:

    .PHONY: clean all strip VST
    
    all : VST
    
    VST : $(JUCE_OUTDIR)/$(JUCE_TARGET_VST)
    
    
    $(JUCE_OUTDIR)/$(JUCE_TARGET_VST) : $(OBJECTS_VST) $(RESOURCES) $(JUCE_OUTDIR)/$(JUCE_TARGET_SHARED_CODE)
    

    could somebody tell me, how these lines should look in a vst3 makefile?



  • Bump. Noone on linux here, who could tell me, how the lines 151 - 155 in a makefile for a vst3 fx plugin should look like?



  • @toxonic said in VST3 build error: "nothing to be done for 'all'":

    Bump. Noone on linux here, who could tell me, how the lines 151 - 155 in a makefile for a vst3 fx plugin should look like?

    I use GNU/Linux but I've never built VST3.



  • @toxonic I'm on mac and pc here... sorry 😞



  • @d-healey
    makes sense, since most linux DAWs don't support vst3. but it seems, that it's not allowed, to distribute vst2 plugins, if you don't have a vst2 license from steinberg, which i do not have... 😕



  • Since JUCE doesn't use the Steinberg SDK headers I think you can still distribute VST2 plugins built with HISE even if you don't have a license agreement with Steinberg - https://forum.juce.com/t/juce-gpl-and-vst-sdk-license-mystery/14935/20


Log in to reply
 

10
Online

553
Users

2.1k
Topics

16.4k
Posts