HISE Build Fail (Scriptnode 22nd Oct Standalone) (SOLVED)



  • @Christoph-Hart Hi mate. I'm just trying to rebuild HISE from the latest scriptnode commit but getting all these errors in Xcode...

    Screen Shot 2019-10-23 at 22.04.09.png



  • @SteveRiggs
    Hi man, I have this exact problem. I try to fix it for like 2 weeks.
    878312dd-bc50-4194-aae8-34852d868b56-image.png



  • @Dlukas7 Damn! Fingers crossed the master will be able to fix it for us! 🤞



  • Well I built it on Windows and GNU/Linux just fine so there is no fix required on the HISE end of things. I'm currently building on Mojave (I'll let you know if I hit any problems).

    Try reinstalling IPP.

    Are you using git to pull updates from HISE or are you downloading the folder from github and replacing the new files? If the latter then that's a possible cause if you're not complely removing the old source files first. Make sure you also resave the .jucer file before compiling too.



  • Mojave build succeeded



  • @d-healey

    @d-healey said in HISE Build Fail (Scriptnode 22nd Oct Standalone):

    ...that's a possible cause if you're not completely removing the old source files first.

    What do you mean by old source files?
    Sometimes I have small issues when compiling a new version that I can solve, but sometimes I can't solve them so I need to redownload the whole thing from git...



  • @ustk Haven't you guys watched my git video yet 😛

    If you redownload from github manually then extract the zip over your existing HISE folder and choose to replace existing files things might get messed up. It is better to delete/rename your existing HISE folder first and start fresh.



  • @d-healey <- he's right. What I do is;

    1. rename my HISE folder to HISE_old_VXXX
    2. Download the latest from github
    3. extract the zip
    4. Compile

    and so far no problems wiht that appraoach...(apart from my typing...)



  • @Dlukas7 I do exactly as Lindon says, and I successfully built Hise with code from today.
    MacOS Mojave Xcode 10.1



  • @d-healey Weird. I've tried a repair install on IPP but still, the same errors and the build failed.

    It usually works the same way as I've done it this time.

    I just downloaded the new HISE Scriptnode branch folder from github, made a new folder on my hard drive so that it's separate from the old build, copied the stk files into tools, and then build from the new projucer file.

    I'm always wary about totally uninstalling the old version from my system before putting the new one on in case something goes wrong like this and I can't get it to reinstall for any reason, as I'm still on MacOS High Sierra and Xcode 8.

    Is that what I need to do then? Totally remove all traces of the old HISE build from the folder, and from the applications and application support folders before installing this one?



  • @SteveRiggs Is that what I need to do then? Totally remove all traces of the old HISE build from the folder, and from the applications and application support folders before installing this one?

    Well there isn't really an install process for HISE. You download a folder from github and you build HISE in there. If you then copy it to Applications that's a separate copy not a shortcut (if I understand Mac OS correctly). So when you get the newer version you just need to rename/delete the previous source code file you downloaded from github, you can also remove the file you copied to Applications if you want but it's not necessary for building the latest.



  • @d-healey Sorry my bad, I meant compile not install 😛

    It looks like its just an old version 1.6 that's in the applications folder. I must have put that there when I first built it months ago. I usually just build in the actual folder and make a shortcut/alias in the dock on the macs desktop and run from that.

    I'm slightly confused where the source code is/needs copying to or renaming though. In the HISE downloads section on the website where it says "Download HISE Source Code" it takes me to a github page that hasn't been updated since 23rd May 2019 which is the master branch. Surely thats not it as it's the new scriptnode branch I need?

    I have 3 folders now in my HISE folder with the new one from yesterday that I downloaded. I was just trying to build that one from fresh inside the highlighted folder on the screenshot. Where would the source code be located? Is it outside of this folder somewhere? Sorry about this.

    I spotted a HISE folder in the application support folder but not sure if anything in there needs changing?

    Screen Shot 2019-10-24 at 14.57.47.png

    Screen Shot 2019-10-24 at 14.59.49.png



  • @SteveRiggs

    How do you make a shorcut to HISE in MacOS?



  • @d-healey Very strange. That's the exact video I follow every time I do a new build. Same process this time.

    I understand now that the folder is actually the source code.

    That should work then but I'm still getting the same errors and a failed build. I've tried with both Universal Binary (32/64-bit) and also 64bit intel but get the same errors with both.

    I also just tried renaming the old build folder before attempting the new build. Still no good 😞



  • @d-healey To make an alias/shortcut I just right click on the HISE icon in the MacOSX/build/Release folder and go to 'make alias' and then drag and drop that onto the dock and rename it

    Screen Shot 2019-10-24 at 15.42.29.png



  • Are you sure that you are opening the new .jucer file and not the old one? By default projucer opens that last opened .jucer file.



  • @d-healey

    Yeah, I went to 'new project' in projucer, then 'open existing project', and chose the 'HISE Standalone.jucer' file from the newly downloaded source code folder.

    Then I go to 'Save Project and Open in IDE' and it opens Xcode.

    I notice when Xcode opens though, the last failed build is still there with all of the errors.

    It does say it's indexing the files and the progress bar goes along like it's reading the new file but then once it's done it still has the failed build and errors there in the top bar and side panel. Should that be happening? Surely it should refresh? When I try and build it still fails every time.

    Screen Shot 2019-10-24 at 15.58.34.png

    Screen Shot 2019-10-24 at 15.58.43.png



  • @SteveRiggs I'm not sure, I don't know enough about xcode. If you've deleted/renamed the old source code folder though then I don't think xcode could still be loading it, unless it has some weird cache thingy.

    Does the newly downloaded jucer file have all the correct paths and flags setup for IPP? I use git pull so I rarely have to check this myself.



  • @d-healey

    It looks as if the IPP paths are right, and the path in Xcode looks like it's coming from the new source code folder.

    I've also renamed the old source code folder temporarily but it's still failing

    Screen Shot 2019-10-24 at 16.11.04.png

    Screen Shot 2019-10-24 at 16.12.14.png



  • I also just tried deleting the new source code folder and redownloading a fresh one. Still the same errors though and failed to build.


Log in to reply
 

13
Online

544
Users

2.1k
Topics

16.2k
Posts