New compiling error...

  • What does it mean? My other projects are compiling fine...

    • I tried to empty the "Binaries" folder
    • The preferences are the same as in the other projects
    ▸ Building library libSystem.a
    ▸ Building System/System - AU [Release]
    ▸ Check Dependencies
    ▸ Compiling
    ▸ Compiling
    ▸ Linking System
    ❌  Undefined symbols for architecture x86_64
    > Symbol: _getrlimit
    > Referenced from: in lto.o
    ** BUILD FAILED **
    The following build commands failed:
    	Ld /Users/greg/Library/Audio/Plug-Ins/Components/System.component/Contents/MacOS/System normal x86_64
    (1 failure)
    ❌  ld: symbol(s) not found for architecture x86_64
    ❌  clang: error: linker command failed with exit code 1 (use -v to see invocation)
    Compiling finished. Cleaning up...
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    [Process completed]

  • Have you set export to 32bit?

  • @d-healey Nope... It looks like this but no...

  • @Christoph-Hart Any particular point to check?

  • Googling the error yields this result:

    How did you solve it before?

  • @Christoph-Hart Oups... I don't even remember I already tried 11 days ago 🙄

    In fact, I've never solved this issue.
    That's what is strange, all the other projects are compiling fine, but not this one (except standalone)
    I also tried with a previous Hise version where everything is compiling, but still not this project...

  • @Christoph-Hart I think I found something, I declared 34 reg, I thought I was at 32...

  • @Christoph-Hart Actually it's not the problem...

  • Yeah, it would be weird. The error you're seeing means that there is some OS library call (_getrlimit) that can't be found by the compiler at a very late stage. This usually happens if you have some sort of library version mismatch between the C++ standard library and your compiler.

    Maybe calling your plugin System causes the OS to resolve symlinks in a very nasty way, so the only advice I can give is to change the project name and see if that helps.

  • @Christoph-Hart Yep, I wondered that too so I tried to rename it but same problem...
    I even copied the project_info.xml and user_info.xml from another project.
    I also tried to validate the .xml, still nothing...
    The project contains only two sound generators and 3 FXs.

    Again, the standalone compiles fine...

    I used only stock Hise components for the moment, so nothing comes from outside, no external code, image, or anything, only the onInit. It is a really simple project, except the script which is a bit heavy and probably not very well made (90% of it is an heavy repaint function, and automatic random MIDI triggering), but I don't think this can impact the compiler. Or is it?

    If you have some time for that, I could wrap it if you want to test it by yourself 🖖

  • Wow, that is really strange... As I said I tried to rename the "System" project so it can be less confusing. So I tried Sys-tem and SystemBeta, both didn't work...
    Well, that simply wasn't enough! When trying a name that doesn't contain anything related to System, it works!
    So my project is now on called Planets...
    Ahhh... Computers... 😬

  • @Christoph-Hart Arghh.... Hair pulling session! 😬
    The post above is wrong...
    Back on the project today (so with the new name), the compiler throws the same error again and again for both AU and VST3 export
    What did I do since yesterday? Just added a panel with an image in it, and changed the colour of two buttons...

  • @Christoph-Hart said in New compiling error...:

    This usually happens if you have some sort of library version mismatch between the C++ standard library and your compiler.

    How would I check that?
    And why this error for this project and not for the others?

    Also, my project crashes sometimes if I push it hard, both in Hise or the standalone export. Probably because a "dirty" code, even though I checked it hundreds of times, I've never found what causes the crash.
    Is it possible a dirty code can be linked with the AUi/VSTi compiling issue?

Log in to reply