Out of heap space - again .....



  • OK so suddenly the plugin is reporting out of heap space, and I cant see why - its not got a lot of graphics, and the IRs add up to 21Mb of data.

    If I go to the project settings and turn OFF embed audio files then I get a bunch of 'impulses': is not a member of 'PresetData' like errors....

    How do I get my project cleaned up? any ideas? I have a bunch of IRs in the Audio Files folder, in the Samples folder all I have are the .ch1 files

    When I run "copy external files into folder" it tells me there are 40 IR files - there are not these only 14

    and there are 88 samples - there are not there are none.

    help.....

    Interestingly I just noticed when i try a compile the console tells me this:

    VintageOrgan02: Writing {PROJECT_FOLDER}IRS/Ambient 1.wav ... 3278 kB
    VintageOrgan02: Writing {PROJECT_FOLDER}IRS/Ambient 2.wav ... 3569 kB
    VintageOrgan02: Writing {PROJECT_FOLDER}IRS/Cavern.wav ... 4403 kB

    -- there once was an IRS folder , now there isnt....so its getting this stuff from somewhere....



  • Do you have Rebuild Pool Files enabled in preferences?



  • @d-healey ....and now my entire project is crashing and wont load.#



  • @Lindon Tell me you saved it as XML 🙂



  • @d-healey yep. but it wont even load as XML -- it says "building modules..." then crashes HISE



  • @Lindon For "Images" and "AudioFiles" folders, there is a total 50MB limitation as far as I know.

    If your "Images" + "AudioFiles" folders exceeds 50MB, you can optimize your image files and IR samples.



  • Run your XML through this to check for errors - https://xmlvalidation.com/



  • @d-healey All valid XML...



  • @Lindon Try running the UI data xml through the validator too



  • @d-healey yeah I did......

    so everything is valid. But when I try and load Project and point at the xml it says "Building modules..." and never returns.. it just hangs there.



  • I often have a crash when loading my project (both XML and preset, because I always save both at the same time for security)
    generally, when one is crashing, the other crashes too...
    when I run my XML in a validator I get no errors.
    What I tend to do when Hise crashes loading a project, is to go in the "Main Workspace" (modules) instead of going in the "scripting/interface workspace" before loading the xml. This way I have less chance to crash...

    It seems that the crash is not due to the project itself, but an instability somewhere in Hise, generally when loading a big project... My current project has approximately 700 components in the interface, and Hise is not happy (very, very laggy on my i7-3.5GHz-32GoDDR3) when the interface window is showing up, but everything is back to normal when I only have the script/module window.

    When it crashes, it crashes with all my different build of Hise.



  • @ustk yes I get HISE crashing every single time I have a loaded project and then select Recent projects...

    I select another project - HISE loads it ( I think) and then crashes immediately...

    Meanwhile back at my problem...
    I've tried loading my project from everywhere I can think of --- all cases it does this "Building modules..." and never comes back...

    as I've said I really really do want all this nice new stuff, but theres some basic stuff that needs fixing first.



  • Agree that we need that kind of issues to be fixed, but the fact is that @Christoph-Hart doesn't know necessarily what's going on with our troubles, which doesn't help him much I guess...
    It would be cool to send the complete project folder to him so he might check our problems

    Have you tried to rise the "Compile Timeout" in Preferences/Development?



  • oh no, now I cant believe whats going on. I just spent the last three hours rebuilding my project for it to fail in the same way again.....it was all loading correctly then I created a sample map with the sample pre-load set = -1 and re-(hand) entered all the loop points and cross fades and now it wont load at all....

    @Christoph-Hart can I zip up my project and get you to look?



  • @Lindon So the sample map loading strikes again!



  • Yeah, send it over.



  • @d-healey yes.

    So more investigation:

    I have two sample maps loading - FastLeslie and SlowLeslie

    one entry from the fast Leslie xml looks like this:

    <sample Root="53" LoKey="53" HiKey="53" LoVel="0" HiVel="127" RRGroup="1"
    FileName="D:\Audio\ChannelRobot\AA HISE Work\VintageOrgan\Samples\fast\Fast_F#5.wav"
    Duplicate="0"/>

    on entry from the slowLeslie looks like this:

    <sample Root="54" LoKey="54" HiKey="54" LoVel="0" HiVel="127" RRGroup="1"
    FileName="D:\Audio\ChannelRobot\AA HISE Work\VintageOrgan\Samples\slow\F#3.wav"
    Duplicate="1" LoopEnabled="1" LoopEnd="240798" LoopStart="74783"
    LoopXFade="8800" SampleStart="5218"/>

    • so the SlowLeslie has loops turned on and some pretty specific loop points and cross-fade.

    HISE never finishes loading SlowLeslie......

    If I copy the contents of FastLeslie to SlowLeslie, then everything loads fine....

    So questions:

    whats this doing? ----> Duplicate="1"



  • @Christoph-Hart sending...



  • It tells the sampler that this sample is using an existing sample so it shares the same preload buffer.

    Try removing it using a text editor and check if it loads (then do the same thing with the "LoopEnabled" property.



  • I downloaded the project but there are no samples, so there's no way for me to reproduce.

    But there are two things I notice from looking at the SampleMap:

    1. It uses absolute paths
    2. There's no ID

    Not sure how you ended up with this, but it should use the {PROJECT_FOLDER} wildcard and have a valid ID when you save the map.


Log in to reply
 

7
Online

553
Users

2.1k
Topics

16.5k
Posts