VST export failed

  • Can anyone help with this flock.cpp issue?

    c:\program files\hise-scriptnode\juce\modules\juce_audio_processors\format_types\juce_vst3headers.h(119): fatal error C
    1083: Cannot open include file: 'base/source/flock.cpp': No such file or directory

    I've gotten this in the past when trying to export VST3 format (currently on PC), but decided to ignore it until it was needed.
    I'm using the sdk from scriptnode.

  • @dustbro Double check that you actually have the file in there. If you do, try to specify the absolute location. If that doesn't work, just comment out that part of the code in the juce_vst3headers.h and see what happens.
    I had to comment out about 3 various lines of code that we giving errors and was able to compile after that. Give it shot and let us know how you go.

  • @ulrik It appears that my file structure is already like this
    vst location.png

    @gorangrooves @Christoph-Hart It looks like the flock.cpp files is located in a different folder
    HISE is looking for base/source/flock.cpp
    but the file is located in base/thread/source/flock.cpp
    flock location.png

  • I tried copying the file froom /thread/source to /source with no luck.

    Within juce_VST3Headers.h we have

    #if VST_VERSION >= 0x030608
     #include <base/thread/source/flock.cpp>
     #include <pluginterfaces/base/coreiids.cpp>
     #include <base/source/flock.cpp>

    What's the difference? and if they are different, where can I find the one I need?
    Also, the VST3 folder within \tools\SDK\VST3 SDK\base\source is very different than the one in \JUCE\modules\juce_audio_processors\format_types\VST3_SDK\base\source.
    Why do 2 exist?

  • @dustbro said in VST export failed:

    I tried copying the file froom /thread/source to /source with no luck.

    Looks like i had to copy the file



     \tools\SDK\VST3 SDK\base\source

  • @dustbro Ok, is it the expanded SDK that followed Hise?
    Cause the Steinberg SDK does not have the same structure

  • @ulrik 🤷🏼♀

    c:\program files\hise-scriptnode\tools\sdk\vst3 sdk\base\source\flock.cpp(40): fatal error C1083: Cannot open include f
    ile: 'base/thread/include/flock.h': No such file or directory

    looks like I have more files to copy 💩

  • c:\program files\hise-scriptnode\tools\sdk\vst3 sdk\base\thread\include\flock.h(105): error C3646: 'SMTG_OVERRIDE': unk
    nown override specifier

    It appears that it's just looking for the SDK located in


    can I just redirect HISE to use this SDK instead of the one within tools?

  • @dustbro sorry I can't figure it out what is wrong 🤔

  • @ulrik said in VST export failed:

    orry I can't figure it out what is wrong

    Figured it out.
    #1 - copy the sdk from the JUCE folder to TOOLS folder


    #2- copy vst2.x folder to new sdk

    \tools\SDK\VST3 SDK\pluginterfaces\vst2.x

    #3- in Tools folder


    #4 - in Tools folder

    VST3 SDK

  • Man I can't get HISE to compile either. I have extracted the sdk.zip with the secret password already. I can see vst2.x folders in the right place, but compiler in Xcode still gives me this

    'pluginterfaces/vst2.x/aeffect.h' file not found

  • @Dewdman42 Post a pic of your folder structure to the vst folder just to verify that it is correct. And are you compiling HISE as a plugin or exporting a plugin from HISE?

Log in to reply