VST export failed

  • Hey guys
    Since I build the last master branch, the vst export fails
    But it is working with a build from a week ago

    ▸ Compiling include_juce_product_unlocking.mm
    ▸ Building library libForceIT.a
    ▸ Building ForceIT/ForceIT - VST [Release]
    ▸ Check Dependencies
    ▸ Compiling include_juce_audio_plugin_client_VST2.cpp
    ❌  /Users/greg/Desktop/HISE 9-May/HISE-master/JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp:95:10: 'pluginterfaces/vst2.x/aeffect.h' file not found
    #include "pluginterfaces/vst2.x/aeffect.h"
    ** BUILD FAILED **
    The following build commands failed:
    	CompileC build/ForceIT.build/Release/ForceIT\ -\ VST.build/Objects-normal/x86_64/include_juce_audio_plugin_client_VST2.o /Users/greg/Documents/_PROGRAMMING/ForceIT/Binaries/JuceLibraryCode/include_juce_audio_plugin_client_VST2.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler
    (1 failure)
    Compiling finished. Cleaning up...
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    [Process completed]

    effectively there's no such file/folder in "pluginterfaces"
    I have all my SDKs, and the Hise path is the good one...
    Any clue?

  • Yes this is the outfall from the VST SDK mess that Steinberg caused.

    Basically I was updating JUCE to the latest version in order to support VST3. Since the VST3 SDK can be dual licensed, it's now included in the JUCE codebase so that you don't need to care about the VST SDK anymore unless you want to compile VST2 plugins (which everybody still does). In this case you need to get the old version of the VST3 SDK that Steinberg stopped distributing in October 2012, then copy some files manually in the directory where the VST3 SDK is located OR tell the Projucer where to find the old SDK (which is located in HISE Path/tools/SDK/VST3 SDK).

    TLDR: Make sure you use the new Projucer binary (because the old one will not create a project file that points to the custom SDK). Then make sure that the old SDK is still in place. BTW, everything is already included in the repository but as password protected zip called tools/SDK/sdk.zip (because I can't distribute the VST SDK it in a public repo). The password is NOT 1234, but if you read it backwards, you might get lucky.

  • @Christoph-Hart said in VST export failed:

    you don't need to care about the VST SDK anymore

    Do you mean we don't need to put them in the SDK folder anymore, and recompile Hise?
    Because I am not able to export VST3 either...
    The only thing I get now is the "VST SDK is missing" warning

  • @Christoph-Hart Any clue on this? Is the VST3 implemented or on track to be implemented maybe? I am not interested in exporting VST2, so I'm just waiting for VST3, but I don't understand if it's ready at the moment or not... 😇

  • Theres a box you need to tick in the settings to enable VST3 export.

  • @Christoph-Hart I wondered that, but I didn't find... sorry but I have to ask for more precision 🙃

  • Enter VST3 in the search bar of the settings window 🙂

  • "When the sage points at the moon, the fool looks at the finger" 😀

  • @Christoph-Hart Ok, now I'm a burden...
    I tried to redownload/recompile a proper version of Hise (the last master)
    I did it without, then with the VST SDK
    I ticked the VST3 support in preferences

    Nothing works: "VST SDK is missing"

  • Does VST3 export work for anybody?

  • @ustk I have not tried it yet

  • Guys, the issue with SDK files missing can be sorted by editing the file which is referencing to them, then editing the relative path to the absolute path on your computer. When your VS2017 compiling fails, it gives you a list of files with errors. Open the file and find the lines of code in question. They will contain the relative path. That's what I did when compiling of HISE failed with the latest branch.

  • @gorangrooves Thanks, but my build actually works using xcode, it's when I export the my Hise project in VST that I have the missing SDK

Log in to reply