Serious sample map bug



  • This post is deleted!


  • @Christoph-Hart I just tested this with a debug build. At the point I attempt to do a mic merge or if I import the samples using velocity spread I get this in the console: JUCE Assertion failure in StreamingSamplerSound.cpp:796

    When I try to save the sample map after the failed merge I get this:

    JUCE Assertion failure in juce_TemporaryFile.cpp:50
    JUCE Assertion failure in juce_TemporaryFile.cpp:79
    JUCE Assertion failure in juce_TemporaryFile.cpp:96
     wasn't found.
     wasn't found.
    JUCE Assertion failure in ModulatorSamplerData.cpp:705
    

    If I only use 1RR group then none of these messages occur.

    Here are the samples I'm using is someone has time to test it - https://www.dropbox.com/sh/0dyo1kzo919yi1x/AADiL8i0-5FR-N-4BNrOFNcda?dl=0



  • I just built the latest master branch and found a weird thing going on with sample maps (not related to the main issue of this thread I don't think).

    The drop down menu in the sampler to select a sample map only shows the currently loaded sample maps instead of all the sample maps that are available.

    7fdadc4e-018c-43d6-87e0-decf7933c95f-image.png



  • @d-healey I have seen the same thing, and suddenly they appeared after manipulations I don't remember... are these sample maps created in this project or another one?



  • @ustk They were created in this project. This only happens with a build from the master branch yesterday, I also have an earlier build and the problem is not present.



  • Weird. Can you pin point it to a specific commit - just go back each commit, rebuild and see where it breaks?



  • @Christoph-Hart said in Serious sample map bug:

    Weird. Can you pin point it to a specific commit - just go back each commit, rebuild and see where it breaks?

    I shall do so now



  • So I just rebuilt several commits and the problem has gone, so I have no idea what caused it but it doesn't seem to be a bug introduced in the latest version at least...



  • Back to the previous issue....

    When I go to save the sample map after doing a mic merge (if HISE doesn't crash first). I get a weird file browser, not the usual one, and even though I type in a file name and hit save it doesn't save a file and just clears the sample map. I get the previous Assertion Failures in the terminal too.

    56d998b8-43de-405c-b498-bc595bf18002-image.png



  • I think I've figured out the root cause of the issue. Nothing to do with groups or velocity layers, HISE just chokes if I map too many samples in a single sampler and save the sample map. It seems to start bugging out at about 500-700 samples.



  • More progress. I think I've found a workaround that even allows me to use the velocity spread functionality. I import the samples via the auto-mapper then before doing anything else I purge the sampler and reload it. After that everything seems to work fine... so far 🙂



  • Still having glitchyness with this. HISE is instantly crashing when trying to save a particular sample map as a monolith.


Log in to reply
 

4
Online

472
Users

1.6k
Topics

11.8k
Posts