Serious sample map bug

  • Here's what happens. I drag in my velocity layers one by one and map them (because velocity spread doesn't work). I then save the sample map. Then I do a mic merge and hit save again but all that happens is the mapping window is cleared.

    So I restart HISE, open the sample map and try and merge the mic positions again. This time HISE just closes.

    The sample map itself is weird. There is no ID set and there are no <file> tags.

    Here's a video demonstrating the issue:

  • Bump bump. I hit this roadblock again with another project.

  • I've done some more tests and it seems this issue was present pre HISE 2.0. It only happens when using multiple velocities per RR group and multiple mics.

  • @d-healey strange... I use multiple vel + RR + multiple mics, and it always worked, even using the parser for the velocities so I can import everything at once...

    But the ID problem in the sample map is not new and it happened to me (sometimes the ID is one from another sample map and refuses to be replaced/accepted)
    But importing the samples and saving the sample map never did that to me

  • @ustk that's interesting. I'll try my laptop and see if the issue is some how confined to my desktop

  • @d-healey I've hit some show stoppers with my AMD machine that don't exist with my INTEL. What are you running over there?

  • @dustbro Both of mine are intel

  • @ustk Are you using a debug or release build?

  • I think the last I'm using is a release, and the previous was debug, but not sure... sorry I can't check I am abroad for 1-2 weeks...

    I don't even know the difference, could you quickly explain, please?

  • @ustk said in Serious sample map bug:

    I don't even know the difference, could you quickly explain, please?

    I'm not 100% sure myself but sometimes stuff works in the debug version and not in the release version. The release version is more resource friendly though.

  • I tried on my Laptop on Linux Mint 19 (same OS as my desktop) and had the same problem.

    I also noticed that the moduleEnums.xml file on my desktop only contained

    <?xml version="1.0" encoding="UTF-8"?>

    Although I don't think this is related.

    I'll keep testing and try out some other builds.

  • This post is deleted!

  • @Christoph-Hart I just tested this with a debug build. At the point I attempt to do a mic merge or if I import the samples using velocity spread I get this in the console: JUCE Assertion failure in StreamingSamplerSound.cpp:796

    When I try to save the sample map after the failed merge I get this:

    JUCE Assertion failure in juce_TemporaryFile.cpp:50
    JUCE Assertion failure in juce_TemporaryFile.cpp:79
    JUCE Assertion failure in juce_TemporaryFile.cpp:96
     wasn't found.
     wasn't found.
    JUCE Assertion failure in ModulatorSamplerData.cpp:705

    If I only use 1RR group then none of these messages occur.

    Here are the samples I'm using is someone has time to test it -

  • I just built the latest master branch and found a weird thing going on with sample maps (not related to the main issue of this thread I don't think).

    The drop down menu in the sampler to select a sample map only shows the currently loaded sample maps instead of all the sample maps that are available.


  • @d-healey I have seen the same thing, and suddenly they appeared after manipulations I don't remember... are these sample maps created in this project or another one?

  • @ustk They were created in this project. This only happens with a build from the master branch yesterday, I also have an earlier build and the problem is not present.

  • Weird. Can you pin point it to a specific commit - just go back each commit, rebuild and see where it breaks?

  • @Christoph-Hart said in Serious sample map bug:

    Weird. Can you pin point it to a specific commit - just go back each commit, rebuild and see where it breaks?

    I shall do so now

  • So I just rebuilt several commits and the problem has gone, so I have no idea what caused it but it doesn't seem to be a bug introduced in the latest version at least...

  • Back to the previous issue....

    When I go to save the sample map after doing a mic merge (if HISE doesn't crash first). I get a weird file browser, not the usual one, and even though I type in a file name and hit save it doesn't save a file and just clears the sample map. I get the previous Assertion Failures in the terminal too.


Log in to reply