Container modulators not working



  • Modulators (tested CC and LFO) are having no effect when applied to the gain of a container. I'm also noticing some glitchyness/artifacts/squeaks/pops with gain modulators applied directly to sound generators.

    HiseSnippet 787.3oc6W00aSCCE0tsAw3ioMzPhG6C.uf.sNJe8z5VW6TEqaUMkAuM4kbaqEN1EGmB8eI+T1+.vNtaIYDUVpX6EVdnJ9ZesO93iO2ldRgGDFJjH7JClMAP3G33NiqF2bLgxQc1CgW0oKITAxp1P6NaBILD7QXb48MAvqTAE+b116RXDtGjDBgNVP8fCnATURzdM9HkwZS7gAzfTitdiNdBdSASDowSYmMQSHdekLBNjXFVIGD9Ns7oJgzUQTPHBWYWg+L2whuysi+XZH8TFXZTC4pmHa31BluAwl2QMGSY98NeeGhPXmdIrPYKKrgSWpO8h3IrwZwcTMIiz7AtzhfWszvaybgWsbfGJE5pXQmFDB+HFQkEYlii4cPEYOo5vU.Ojplk93p.vs.rINEdu2E3USZMEbkTvXfLFuqaYxTQ+q.9Sgv.RLhRh0gOEjJSRIhtj47vnfSAYReOugafPnFmU3QarGLjDwTGSXQP9yT7BuGQQP3m4rU8Wk8Y5Q5eF9ByqenYbazkY2xWM1c4E.q6zip7FmuBnTNDJBcsKXmec5gNsFND7TIfshS6ubyd2YUKTtuiKkCwdbw.4wwsq9YxTn59.GjFRcAtb+7p5xM4J6xcjmRu5CjDd3DQXlI1EBnCDbCgjDTeMnsD9VeygbVwJQlaWmsca8dL2bbIpHYrZYm.QDWkQcTdo7GxZCkZ74XVT4Vq2+gVuk58GkyWSKuClvfVZaRlPGw5TL2u6hnoAbWAWLYrfS8RKF5CJIcznzloFy2b1a6nT5x1IQ1nQefAjzB6m13.sfjH0TFrHZYo8LyTEZQGcOwwB2plKoUulNBWNE2hJd9nKW7bqaqddMV8r7+mUO6KhTT9ntD8U+en+exZ8fqtpkGnQBmCL8B4fKYNnss2zz1V1h6G23W5m4cVyzFOuyZm24MxZDP7jhS7rpQi6vciin2273urXE8m3naWsFZpUBa3l.8ErS77Lj8K0rS9YrUgy30ENi5ENi2T3Ldagy3cENi2ufLLtY6DoDA1qd5.8ZYsKvs3FuiXUN52.WnaxOC
    


  • I think I've found a related bug. I have a simple gain envelope for my sampler, if I put it into polyphonic mode I get no sound and a warning: You need at least one envelope in the gain chain


  • administrators

    No that's not a bug, it's a feature: if a sound generator does not have a polyphonic envelope, it will click, so with the new system, it will mute the sound and print this message that people don't do stupid things.

    I'll take a look at the container modulation, but what other glitches have you noticed? The whole modulation system got a HUGE rewrite which massively decreases the CPU usage, but it might cause some edge case issues on certain configurations (although it runs smooth on all my systems).



  • @christoph-hart

    No that's not a bug, it's a feature: if a sound generator does not have a polyphonic envelope, it will click, so with the new system, it will mute the sound and print this message that people don't do stupid things.

    I'm not sure I understand. I have a sampler with velocity sensitive samples, I put a simple envelope on the gain and set it to polyphonic mode (because I don't want one key to affect another key) I get silence. What do I do so that I get what I want without silence? 😛


  • administrators

    Are you sure you don't set it to monophonic mode? Polyphonic is the 3x3 dot icon, Monophonic is the big circle symbol.



  • @christoph-hart Aha you are correct I already have it in poly mode! I notice that even though it is in poly mode it sometimes goes into a mono mode where playing one note will affect already sounding notes (I can't reproduce this yet but I'm working on it). Is mono mode no longer to be used with samplers?


  • administrators

    No, polyphonic mode is supposed to be polyphonic - all voices are rendered independently. If you can reproduce your issue, I'll take a look.



  • @christoph-hart So far it seems to be playing well so maybe I did something. If it happens again I shall try to capture it in a bottle. Do you get the glitchyness with gain modulators? I'll make a video of the issue tomorrow.



  • Here be the video: https://youtu.be/eWLQJlKH7E4



  • @d-healey Any progress on this issue? Is it something that's just happening on my system or are you getting it too?



  • Bumpy bump... the is the last road block I've come to that's preventing me releasing some libraries so I'm keen to understand if the issue is on my end or not.


  • administrators

    Ah sorry David I‘ll look into it after the weekend.



  • @christoph-hart Thank you 🙂


  • administrators

    Whoah, that's a strange one that doesn't happen on my system (it's so elementary I would have noticed it). Can you check if it happens on a Windows system too? So far I can describe this problem:

    • if a time variant modulator is active, there is a burst of modulation values for the first buffer in the release phase of a note.
    • just happens on Linux (?)

    Also can you render a audio file of it, then I can take a look at it. Tools -> Record one second audio file was added exactly for this purpose (although it's lying and actually records 8 seconds). Also please supply your buffer size and sample rate as these specs are important numbers to figure out what's wrong.



  • @christoph-hart Could you provide a Windows binary? I don't have a build system for Windows at the moment.



  • @christoph-hart Doesn't matter, I got my Windows using brother to build and test it for me. The result is the same.

    As soon as he added the LFO the message Master Chain: Illegal call in audio thread detected I get the same message on my system.

    I got him to make the 8 second audio file, it's silent though, is that how it's meant to be?

    Here's the link to the audio files (Linux and Windows) and the Windows build we used - https://www.dropbox.com/s/hitn7c6t9ip0ffv/HISE.zip?dl=0

    We both had buffer set to 512 and Sample Rate set to 48. He also tried 1024 and 256 but it didn't change anything.


  • administrators

    The error message is a result of the over-verbosity of the new audio thread guard system, which monitors unwanted operations in the audio calculation, but sometimes it fires (mostly during initialisation of modules) without a serious reason. I tried to get rid of false positives, but some slip through. TLDR: shouldn't be the cause of the problem.

    Weird that the audio file is silent - silly question: have you played something :)?

    1. Start the recording by selecting the menu item
    2. During the next seconds, hit random keys and make sound
    3. Get the HISE audio output as .wav file

    If this doesn't work, can you load HISE into a sequencer on your Linux system, and export the glitch as audio file (or any other way of recording the HISE output if the inbuilt tool fails for whatever reason)? Also if you run the Debug build, does it fire a assertion when the glitch appears?


  • administrators

    Also maybe I didn't follow your exact steps:

    1. Add a sine generator
    2. Add a LFO modulator
    3. Play notes -> glitch at the note release

    Have I missed something?



  • @christoph-hart I did not play any notes, that explains that issue 🙂 I shall make a new file.

    Your steps are correct for creating the glitches. The other issue can be demonstrated just by adding an LFO to the master chain, it doesn't move at all and there is no display in the plot. I haven't checked the debug build, I will do that today.


  • administrators

    Don't worry about the LFO in the master chain, this one I can replicate 🙂


Log in to reply
 

1
Online

315
Users

914
Topics

5.9k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.