Compile errors ((



  • Hooray!!



  • Hi

    I am trying to export with no success
    First, the standalone export works
    I want now to export VST and AAX, but as AAX seems to be a pita, let's begin with a VST

    I have installed the IPP, but I always have this failure:
    alt text
    So I deleted the paths in debug and release, and set hi_core IPP to disabled...
    In Hise, I also disabled IPP in pref/dev tab
    But this error doesn't want to stop

    I'd like to have the IPP though because I need convolution, but with or without, it is stuck...



  • Currently I am not able to export any plugin format…
    Any idea guys?



  • @ustk said in Compile errors ((:

    Currently I am not able to export any plugin format…
    Any idea guys?

    I have no problems, my Mac configuration is Mac Pro with High Sierra, XCode 10.1 and last Hise release with the IPP installed and enabled...



  • Are you sure you installed IPP correctly? The linker error complains that the IPP library files can't be found at the usual location. Check what's at:

    opt/intel/ipp/lib/
    


  • Thanks guys,

    Xcode 10.1 as well, last Hise version, and I tried the provided Projucer and with the last update.
    High Sierra as well and last IPP.
    Everything has been installed these last days for the first time so it is a clean install (except for High Sierra that has been installed onto ElCapitan)

    Yes, I checked the location of the IPP and it is good.
    Actually, it is an alias pointing to this folder compilers_and_libraries_2019.1.144

    alt text
    I tried to extract the IPP and replace the alias but it didn't work either so back to normal.

    I don't understand why it doesn't find something that exists...
    I am admin of the iMac, but is it enough?



  • Hi,

    after working 8h/day trying to export with Hise, I went just a bit further after reading many things online I just don't understand.
    I installed homebrew, and re-installed the command line tools for xcode
    I don't know if it was the thing to do, but now the message changed:

    Last login: Sat Jan 19 19:54:07 on ttys001
    /Users/greg/Documents/_PROGRAMMING/Essai\ Hise\ /Binaries/batchCompileOSX ; exit;
    iMac-de-Gregory:~ greg$ /Users/greg/Documents/_PROGRAMMING/Essai\ Hise\ /Binaries/batchCompileOSX ; exit;
    Re-saving file: /Users/greg/Documents/_PROGRAMMING/Essai Hise /Binaries/AutogeneratedProject.jucer
    Finished saving: Visual Studio 2017
    Finished saving: Xcode (MacOSX)
    Finished saving: Xcode (iOS)
    Finished saving: Linux Makefile
    Compiling FX plugin Essai Hise ...
    ▸ Compiling CopyProtection.cpp
    ▸ Compiling PresetData.cpp
    ▸ Compiling Plugin.cpp
    ▸ Compiling include_juce_audio_devices.mm
    ▸ Compiling include_juce_audio_formats.mm
    ▸ Compiling include_juce_audio_basics.mm
    ** BUILD FAILED **
    
    
    The following build commands failed:
    	CompileC /Users/greg/Documents/_PROGRAMMING/Essai\ Hise\ /Binaries/Builds/MacOSX/build/Essai\ Hise\ .build/Release/Essai\ Hise\ \ -\ Shared\ Code.build/Objects-normal/x86_64/CopyProtection.o /Users/greg/Documents/_PROGRAMMING/Essai\ Hise\ /Binaries/Source/CopyProtection.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler
    (1 failure)
    ▸ Compiling include_hi_zstd_3.mm
    ▸ Compiling include_hi_zstd_2.mm
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    
    [Process completed]
    

    Does it look familiar to someone?

    Thanks,
    greg



  • Did you tinker with the CopyProtection feature?
    I see it calling /Binaries/Source/CopyProtection.cpp



  • I did nothing concerning copy protection in Hise.
    I don't even know with what it's related here...



  • This made me think my Hise project was potentially corrupted or something...
    I created a new project with a simple interface (one button and knob), and no code.

    export VST => success! It opens in pro tools via Blue Cat Patchwork!

    I'll try to export my code step by step now from the old project to the new one and see...



  • Now with AAX export I got this:

        
    ▸ Linking essaiHise2
    
    ❌  ld: library not found for -lAAXLibrary_libcpp
    
    
    
    ❌  clang: error: linker command failed with exit code 1 (use -v to see invocation)
    
    
    ** BUILD FAILED **
    
    
    The following build commands failed:
    	Ld /Library/Application\ Support/Avid/Audio/Plug-Ins/essaiHise2.aaxplugin/Contents/MacOS/essaiHise2 normal x86_64
    (1 failure)
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    
    [Process completed]
    


  • @ustk were you previously able to compile AAX? or is this your first time?



  • No, it is the first time I can go so far…



  • I found something here:
    https://forum.juce.com/t/aax-libc-library/15731/16

    I'll check that tomorrow to see if I can do something…



  • @ustk For AAX plugins, downloading sdk is not enough. Before exporting AAX plugins; you need to change the runtime library link settings to static in the AAX library and recompile them. The header files should be included automatically. It's the .lib files that you need to create on your own using the AAX SDK Solution file.



  • I tried to compile it with Xcode 10, and obviously, I got a "deprecated architecture i386" error
    as I am a noob and don't know if I can fix this, I installed vs2015 community on my PC so I can compile the lib at least there, then copy the lib on my mac. (I don't even know if it can work, please excuse my idiocy 🙃 )

    once imported on the mac, here's what I got:
    alt text

    Good? not good?
    gosh it is such a pain to make everything working
    A complete tuto would be so cool instead of looking for info everywhere and still have something that doesn't work after a week working full time on it...



  • @ustk

    • Yes lib location is right. But you if you will make32 bit plugins, you have to compile it for 32 bit too seperately (But AFAIK XCode10 doesn't let 32 bit )
    • I am using XCode8 without any error. (on Sierra)
    • For PC, I suggest VS2017. (Windows 10)
    • I think you should compile the lib files seperately in mac and pc.


  • @orange said in Compile errors ((:

    on

    Thanks, orange!

    No, I don't intend to release anything in 32bits anyway.
    The main format I want to work with is AAX64

    So if the file looks good (visually), you think it doesn't work because I compiled it on windows?
    I thought the name was different...

    I will try to install Xcode 8, I'm on High Sierra
    Is it not a problem to uninstall Xcode 10 for reinstalling 8?



  • Static library files compiled on windows obviously can‘t be used in macOS. Unix based static libraries have the format libX.a



  • Makes sense... I think, much more to you 😁

    When discovering Hise for the first time and when you know just a bit of KSP and/or JS, you think it will be an "easy" task to make a plug, at least not much harder than Kontakt...
    But the upstream preparation is so hard for the "non-coders" and with so little information, especially the basics in fact, which should, I assume, be known already... Well, it's not my case obviously 😀

    I got to codesign after that... Lucky not to have a rope in the studio... Who said I have XLRs?


Log in to reply
 

9
Online

491
Users

1.7k
Topics

13.0k
Posts