Multi-mic issues

  • I'm experimenting with loading multi-mic samples into HISE and I've found a few issues. I'm testing this with 8 mic channels.

    • If I try setting up the multi-mics in the token parser when mapping the samples HISE crashes, so I have to map the samples first and then setup the multi-channel using the merge option in the tools menu.

    • When I first loaded in my 2 RRs only the first RR would trigger, once I'd purged and reloaded the samples both RRs trigger.

    • The other issue is if I purge just the first channel none of the other channels play when I hit a key, it's like all of the channels are purged, although the memory usage isn't affected.

  • I'll look into it when I find the time. But I probably remove the multi mic option in the token parser (I hardly ever use it myself and merging them after importing is much easier).

  • Yeah sounds like a good move

  • Opening a preset with multi-mic samples crashes HISE, I'm using the latest version in standalone on Windows 10.

    I just add 1 sampler, and a set of samples, 2 mic channels, 2 RRs. I map them in the usual way and merge them, I save the preset, close HISE, reopen, load the preset and HISE crashes.

  • Does it crash with any samples or just a particular collection?

    I checked it on Win7 with the latest build and it works fine (I don't think it's the windows version though)

  • I've only tried with one set of samples so far, I'll try some others in a little while and let you know

  • If it only happens with these samples, please upload them somewhere and I'll try to fix it.

  • I tried another set of samples, no RRs this time and 4 mic positions, still have the same issue. I've tried it on two computers, both running Win 10.

    Here's a link to the project and samples - redacted

  • Alright I can reproduce it (even on OS X). I'll figure this out and upload a new build...

  • OK it is fixed (you somehow managed to set the Duplicate flag for every sample which shares references to already loaded samples, but then it didn't load anything...)

    I also fixed the first channel purge problem and removed the multi mic token. But I can't reproduce the RR bug. Can you give me a STR list?

  • Where does this duplicate flag live? I don't recall seeing it. What's an STR list?

  • Steps to reproduce, a list with every step that leads to the bug.

    Don't worry about the Duplicate flag, it is set automatically when you use a sample twice. If the flag isn't set the loading time is a bit faster because it doesn't need to look in the sample pool if the sample is already there.

    I don't know why this happened but it is not critical - I just didn't stumbled about this scenario yet so thanks for spotting!

  • I've done some more testing and the RR issue only happens when there is more than one mic position. I notice in the purge channel box it says NoMultiChannel even though I have merged the samples. Once I click on that box I can see the channels listed.

    So to reproduce the issu:

    • Load in the samples - (3MB) - and map them to the correct note number and RR using the sample name. (2 mics and 2 RRs)
    • Merge the multi-channel samples
    • Press a key with a sample mapped to it and you should get silence
    • Purge and reload one of the channels and next time you press a key it should all work as expected

    There is also still the issue that if the first channel is purged none of the others sound either.

    As an aside, could you make it so that the token sample mapper remembers the last used settings for the current project (or even globally)? I'm mapping samples to several samplers and they all have the same file name structure so it would save time if I didn't have to reselect all the tokens each time.

  • Alright, everything is fixed now (including the first channel purge bug and the RR bug).

    You can already copy the file importer settings to a XML file (or to the clipboard) so you don't have to reenter everything.

  • Ah brilliant! I look forward to trying the new version.

  • It's online.

Log in to reply