Monolith dont work



  • Hello,

    I am in the testing phase, and it does not work.

    I put on a pc the VST file with the monolith file (.ch1). When I load the instrument, the plugin asks me where the samples are, what I tell him the folder with the monolith. Everything is going well so far. I delete the vst and reload, and load the samples (which are strangely very fast for 3gb of monolith compress).

    Then I should be ready to play, but, I have no sound. It does not work.

    If I redo all the same operation with the original samples, in WAV, everything works fine.

    What happens with the monolith?


  • administrators

    Is this one 3GB monolith file? Because it might be possible that your OS chokes with files > 2GB. Can you try with a subset of your samples that go below the 2GB limit? If that's the case, I have to split monolith files for bigger sample sets.



  • Yes, please add splitting, I will likely go over the limit at some point.



  • Hello,

    The monolith file weighs exactly 2.7gb!

    It is a piano with 10 layer ... I will try with 4 layer to reduce, anyway I want to make a light version!

    P.S. I am writing to you privately on the chat forum ... as you asked me in another thread.



  • I try with 3 layer, the file weighs less 1gb.

    It still does not work .... Or it's me who does not understand how the monolith works!


  • administrators

    Ah, OK then there's definitely something off here (the monolith samples are well tested for files < 2GB).

    Can you post the content of the following files found in your %APPDATA% folder of your plugin:

    GeneralSettings.xml
    LinkWindows



  • <?xml version="1.0" encoding="UTF-8"?>
    <GLOBAL_SETTINGS SAMPLES_FOUND="1" MIDI_CHANNELS="1" OPEN_GL="0" GLOBAL_BPM="-1" SUSTAIN_CC="64" TRANSPOSE="0" MICRO_TUNING="0" SCALE_FACTOR="1" DISK_MODE="0"/>



  • D:\HISE\Zzz Projet Final Hise\VST\Gold Piano


  • administrators

    Hmm everything looks Ok there. Could it be possible that you don't use the monolith file from your SampleMap? Try moving the monolith file out of your HISE project folder, and open your project in HISE, if it still loads the samples, you are referencing the originl files.



  • well i think i could have the same problem maybe.
    i first imported SFZ files, exported it as big monolith file (.ch1 & .xml) with samplemap.
    but after that if i load the samplemap, the path of the samples are always the .wav files, not the .ch1

    if i understand well after converting samples to monolith .ch1 we can use only these in the app and don't need anymore the base wav files ?


  • administrators

    Yes, that is the idea. Can you check the SampleMap XML file you've created when exporting the monolith? It should have the SaveMode property set to 2 (which means monolith file). If it's 0, then it will keep using the original wav files.

    However it will still show the path to the original wave file in HISE (this is necessary in case you want to do some regex processing on the filenames).



  • uh ?
    savemode = 2
    so it seems that for now if i want to distribute my app, i just must put the app file, the presets files (stored in appdata/roaming/etc...) and the .ch1 sample folder ?

    good !!!
    because with .wav files we don't know what user could do with samples (you know what i mean ?), but with .ch1 it's just for Hise app/players ...

    agree with U that it's useful to use Installer for distribute it. i work with InstallForge. Not the best; but free and not so bad 😉


  • administrators

    Actually, the UserPreset files will be embedded into the app and extracted on first launch, so you don't even have to copy them with your installer, but you definitely need to copy the .dll VST plugin files.

    And I actually added a Sample archiver to HISE which compresses all HLAC monoliths into a split archive for easier distribution to the end user (I'll build a sample installer app that can be shipped with your plugin and takes care of extracting the monoliths and creating the link file).

    I am using InnoSetup for Windows and Packages for OSX, which I've found to be the best, free solutions. There is an example script for the HISE installer for InnoSetup which you could adapt for your plugin.



  • Hello,

    I think there is really a problem with the monolith. My file was already on 2 (savemode) ....

    I admit to not knowing or directing myself!


  • administrators

    The monolith format is definitely working (it's being used in production already), but I am sure there is some mixup in your project. Can you upload your project folder as zip archive (without the Samples and Binaries subfolder) then I'll take a look? You can upload it on WeTransfer and send me the download link via PM if you don't want to do this publicly 🙂



  • hello !
    it seems i have errors on 3 samplemaps. If saved to 1 (by default it save it to 1) it's ok. If i change the samplemap.xml savemode to 2 => sample.ch1 not found !
    if loading the samplemap.xml in hise => no samples and/or grey samples with start & end sample to 0 = not readable.
    if changed again to savemode 1 => load ok. But it's not monoliths.



  • It's the same here!



  • @Alex = for my part i started from scratch for these samples. i think the problem was the encoding of wav file and/or the information (sample start/end/loop/volume/etc...).
    i re-recorded my instrument. resaved it with infos, and now it's working.

    if samples you use is not from you (on the net for example), sometimes something maybe wrong. I wanted to use net samples (to win time) and in final i had problem. So i put On my instrument and sampled by myself. i was wanting wining time, i lost time... i had a doubt at the begining because i have more than 140 samplemaps and only 3 (not mine of course) had errors, even mines had not.

    that's why i felt the monolith convertion was not in cause.
    probleme solved for me 😉


  • administrators

    Hi Staiff,

    can you send me one of the wave files that will cause the monolith to stop working, then I'll take a look what causes this.



  • Hello,

    All samples come from me. I work on a vst piano with 3 version; free, lite, pro with 1,4,9 layer and we recorded them directly in the studio.

    The monolith works with 1 and 4 layer, but it seems that for the pro version (9) the file is too big. Yet I reduced it.

    Anyway, it is clear that some things do not work for me. I just did not go to details like monoliths. It's sure I'll lean over the top. I need it.


Log in to reply
 

2
Online

315
Users

919
Topics

6.0k
Posts

Looks like your connection to Forum was lost, please wait while we try to reconnect.