Problems when building, IPP disabled

  • Hi guys,

    I saw a previous post about this problem, but that didn't really solve my problem.
    I'm new to Hise and I'm trying to build a simple project in Xcode.
    I have disabled IPP in the projucer but I'm still getting the error "No such file or directory: /opt/intel/ipp/lib/libippi.a". And 3 other similar errors.

    I tried to install the IPP library, but I am using OS Yosemity and it didn't support that. So, is there another solution than upgrading my laptop?
    Thank you!


  • Hi,

    you also need to remove the libraries from the linker field in the Projucer. Open the HISE Standalone.jucer file in the Projucer, click on the Xcode (MacOSX) target and delete this from the Extra Linker Flags field:

    /opt/intel/ipp/lib/libippi.a  /opt/intel/ipp/lib/libipps.a /opt/intel/ipp/lib/libippvm.a /opt/intel/ipp/lib/libippcore.a

    Then remove the include directories from the Debug and Release configurations (Remove everything in the Header Search Paths and Extra Library Search Paths. Now click on Save Project and open in IDE, select MacOSX as target and compile it again with XCode.

  • Hi Christopher,

    Thank you. That solved the problem.

    I am now getting some errors about Juce macro's when I opened the xcode project of my plugin made in Hise.

    "You need to enable at least one plugin format!
    or "You need to define the Juce Plugin_IsSynth value"

  • Can you post the content of the AutogeneratedProject.jucer file in the Binaries subfolder of your project?

  • What content do you mean?
    There already is content in the Binaries folder (the .jucer file, the unix compile file, and the folders Builds, Compiled, JuceLibraryCode, Source)

  • I meant the actual file content (it's an xml file) so that I can check what's wrong there.

  • You mean the project_info.xml?

    Building the plugin did work. Standalone didn't.

  • Nope, I meant the actual file AutogeneratedProject.jucer 🙂

    If you've exported a plugin, it should create this file in the Binaries subfolder. In order to see what's wrong, I need to take a look at it.

  • Here is a link to the .jucer file:

Log in to reply