Open GL on Mac



  • I have read through all the posts here and am not really clear from it.

    I have the problem that on my Mac when I have loaded a background image the whole thing is no longer operable.
    No more knob can be moved smoothly.

    Now you can as I read OpenGl for the PlugIn switch on.

    Is it also possible for the standalone version?

    I do not want to write out a PlugIn after each change.



  • @MikeB I'm not really clear on the question. Once you compile the plugin, you can have the option to use OpenGL or not.

    In my experience using a large background image (png) severley impacts GUI performance, unless OpenGL is switched on.



  • That with the PlugIn is clear

    BUT I work in the standalone - and here I can not even click a button without delay.
    OpenGL does not seem to work here.



  • @MikeB it works in standalone. Give me 20 mins and I’ll write a proper answer



  • @MikeB So you might know some of this but here is what I've done to get OpenGL working on both plugin and standalone formats:

    1 - Place a Floating Tile set to Custom Settings in your project
    2 - Set "GraphicRendering": true, in the Data section
    3 - Set this flag below within your project Preferences in the Extra Definitions categories

    HISE_USE_OPENGL_FOR_PLUGIN=1
    

    Screenshot 2021-05-16 at 19.44.57.png

    So in my experience, at this point, the setting for OpenGL will not appear in the Custom Setting floating tile in HISE itself, but it will appear in your compiled plugin / standalone app. Remember to make the Customs Settings window large enough in your project to include all the settings.

    Another way to set the OpenGL to be on/off in your compiled plugin/standalone is to navigate to the AppData folder and open the 'General Settings.xml' file and change the OpenGL setting as per below:

    <?xml version="1.0" encoding="UTF-8"?>
    
    <GLOBAL_SETTINGS DISK_MODE="0" SCALE_FACTOR="1.5" VOICE_AMOUNT_MULTIPLIER="2"
                     MIDI_CHANNELS="1" SAMPLES_FOUND="1" OPEN_GL="1"/>
    
    

    Hope this helps. @Casey-Kolb may have more to add to this, however, as his excellent Cube plugin uses OpenGL as well 🙂



  • Thanks for the description - but here is a little misunderstanding!
    If you read my text - you will see that I am talking about the Mac 🙂
    And I am talking about HISE Backend Standalone

    On my PC everything runs great - with and without OpenGL
    I can develop my application also on PC but I would like to do it on Mac if possible.



  • @MikeB In my experience, everything is the same for Mac and PC. Set the Definition in Preferences in the Mac section as well (and every other OS you want it to work in).

    What do you mean by 'HISE backend Standalone'?

    HISE itself cannot use OpenGL (as far as I am aware). Only in the compiled plugin.

    Do you have a 4k monitor?



  • @DanH said in Open GL on Mac:

    What do you mean by 'HISE backend Standalone'?

    By HISE Backend Standalone I mean the program in which we develop all our plugins.

    HISE itself cannot use OpenGL (as far as I am aware). Only in the compiled plugin.

    This is what I was afraid of

    Do you have a 4k monitor?

    Yes - if I reduce the resolution to HD it works fine.
    But for that you don't run a 4k monitor to work in HD :-))

    I will probably do the coding on the PC and the graphical work on the Mac.

    Thanks for your help



  • @MikeB Thanks for the reply. So my advice is this:

    If your project is running slow in HISE on a 4k monitor then you should try and change it to make it run smoothly.

    The majority of plugins work fine in 4k, and they don't use OpenGL. You want your plugin to work fine in 4k without OpenGL if possible. This will also make using HISE easier!

    Use paint routines vector graphics if you can.

    Good luck!



  • @MikeB
    My 2 Cents!

    This Glitchy Thing Happens Because You Made A Gigantic GUI Or You Have Too Many Controls.

    Forget About The 4K Display, Anything Over 1000 X 600 Will Cut Out On Most Laptop/Computers Out There.
    And Users Can't See The Whole UI!



  • @Natan - Thanks for this

    I have bought about 400 plugins over the last years.
    I have made many screenshots and looked what size the individual plug-ins have.
    Since a few years the GUIs are getting bigger and bigger - which is of course due to the bigger screens and resolutions. Also, most modern VSTs can be scaled the way you like it.

    My decision was 1200x700. On the PC no problem, On my old MacPro (2013)
    with only a single background image is hardly operable. - Where only in the backend -the compiled PlugIn works with OpenGL turned on.

    The user can scale the window so that people with laptops can simply scale to 75% or 50%.
    the 4K user to 150 or 200%.

    That's what scalability is for.

    That this doesn't work on my old Mac is really due to the graphics card and the limited OpenGL support.

    As already mentioned, I will solve the problem by programming on the PC and editing the graphics on the Mac. Since I have a server on which all data is stored, this works quite well.



  • @MikeB said in Open GL on Mac:

    As already mentioned, I will solve the problem by programming on the PC and editing the graphics on the Mac. Since I have a server on which all data is stored, this works quite well.

    Wise Move 👏 Keep it Up 🦾


Log in to reply
 

10
Online

1.4k
Users

4.4k
Topics

40.7k
Posts