VST SDK is missing



  • Hello to all, I been trying to figure out how to export my plugin, but im having issues. I followed David steps http://forum.hise.audio/topic/356/vst-sdk-is-missing/8, and i'm still having issues. I downloded the latest Steinberg VST SDK, extracted it to my Desktop, ran the copy_vst2_to_vst3_sdk.bat file, and Placed the VST3_SDK folder in the HISE >> tools >> SDK folder.

    I then pointed my compiler directory in compile settings to Desktop/HISE-Master/

    But anytime I try to export my plugin, I get "VST SDK is missing".. Can anyone help me with this?? Thanks



  • Naming the folder exactly "VST3 SDK" (Without underscore) worked for me.



  • Thanks so much @ Ksn.. this worked!... Quick Question...I have 2 files in the Binaries/Complied folder, one is a object file, the next is a exports library file. How do I get these two to become a .dll file that I place into my VstPlugins folder to use as a plugin within Reaper???



  • Yeah, apparently Steinberg changed their folder name in the most recent download archive, thanks for pointing this out.

    Actually, you should already find your plugin .dll in the Compiled folder. Did the compilation succeed (the last message in the terminal popup should be something like "Compilation succeeded" 🙂



  • Actually i'm getting a huge red error message log that says a snippet like below

    hi_scripting.obj : error LNK2001: unresolved external symbol "private: void __c
    decl TableEditor::refreshGraph(void)" (?refreshGraph@TableEditor@@AEAAXXZ) [C:
    Users\ace\Music\Hise\Binaries\Builds\VisualStudio2015\Titus Hise Demo.vcxproj]
    hi_scripting.obj : error LNK2001: unresolved external symbol "private: void __c
    decl TableEditor::createDragPoints(void)" (?createDragPoints@TableEditor@@AEAAX
    XZ) [C:\Users\ace\Music\Hise\Binaries\Builds\VisualStudio2015\Titus Hise Demo.v
    cxproj]
    hi_scripting.obj : error LNK2001: unresolved external symbol "public: void __cd
    ecl TableEditor::connectToLookupTableProcessor(class Processor *)" (?connectToL
    ookupTableProcessor@TableEditor@@QEAAXPEAVProcessor@@@Z) [C:\Users\ace\Music\Hi
    se\Binaries\Builds\VisualStudio2015\Titus Hise Demo.vcxproj]
    hi_scripting.obj : error LNK2001: unresolved external symbol "public: __cdecl T
    ableEditor::TableEditor(class Table *)" (??0TableEditor@@QEAA@PEAVTable@@@Z) [C
    :\Users\ace\Music\Hise\Binaries\Builds\VisualStudio2015\Titus Hise Demo.vcxproj
    ]
    .....\Compiled\Titus Hise Demo x64.dll : fatal error LNK1120: 185 unresolved
    externals [C:\Users\ace\Music\Hise\Binaries\Builds\VisualStudio2015\Titus Hise
    Demo.vcxproj]

    Compiling finished.Cleaning up...
    Press any key to continue . . .



  • It looks like a mismatch between the HISE version and the source code. Have you used the 1.0.0 version from the download page together with the current GitHub source code?

    This is the 1.0.0 source code package:

    https://github.com/christophhart/HISE/archive/1.0.0.zip

    Actually, I've added this link to the main download page to avoid this problem in the future, thanks for the heads up.



  • Awesome, got it working!! Thanks so much Chris!!


 

1
Online

353
Users

1.1k
Topics

7.5k
Posts