Export as HLAC Monolith crash



  • Greetings, I started experiencing constant crashes when trying to export samples as monolith with the following info (The app was freshly compiled on 21.08.2017) :
    Application Timestamp: 59398cc3
    Fault Module Name: HISE.exe
    Fault Module Version: 1.0.0.0
    Fault Module Timestamp: 59398cc3
    Exception Code: c0000005
    Exception Offset: 000000000048ceeb
    I also tried launching already built HISE from this website, but it instantly crashed on launch with the same exception code (c0000005)
    The OS version is win7 64x.
    5f142154f3b3fabc49399c



  • Can you try exporting it in Debug mode and get a better crash location (if you run it from within HISE, it should point you directly to the location in the source code). The exception code is just saying it's accessing an illegal address somewhere.

    Just open Hise Standalone.sln in VS, switch from Release to Debug mode and press the Compile button - beware that this build is vastly slower, so make sure you use the Release build for actual work.

    And the crash from the downloaded version is because it tries to load the interface state from the most recent version and I didn't had safe checks in the 1.0.0 version that prevents this (silly me). If you delete the editorData.json file found at %APPDATA%/HISE/, it should start again.



  • Thanks, deleting editordata.json worked like magic for downloaded version,
    and the Debug version pointed out to the alt text



  • Not sure what is going wrong, but now I'm experiencing the same crashes even on the downloaded version of HISE.



  • I've just commited a fix for this. However it seems that somehow your input audio files can't be opened (that's why it's crashing), I added an error message with the faulty file name. Let me know if this fixes your problem.



  • Thanks for the reply, the crash itself is fixed, yet the problem still exists in the other way. (Pic related)alt text
    because the project_info.xml file exists and seems to be fine, nevertheless I'm copypasting it's contents here https://pastebin.com/sMsnyPJj
    I also tried launching it as admin, but it didn't help.



  • It tries to export the project.xml file as audio data, which is pretty weird.

    Have you copied the Musicbox samples in the Samples subfolder?



  • Yes, the samples are copied in the project Samples data folder



  • Can you upload the project folder somewhere? There must have gone something wrong with the file locations.


 

1
Online

353
Users

1.1k
Topics

7.5k
Posts