Woah... big fail in panels...



  • So Im trying to copy a panel (and its contents) from one project to another.

    The way I do this (and I assume everyone does it) is to grab the JSON for the panel (Ctrl-J)
    create a new panel in my new project and copy the JSON into it...

    This has worked flawlessly until now, now Im getting alot of errors, coming from a thing called "Master Chain" saying :

    Component with name Button1 wasn't found

    there doesnt seem to be anything wrong with the JSON...

    heres the snippet.

    HiseSnippet 870.3ocsV0sSaCCE1tTinL.ARa2mKAIFJoT15zj1JTfopsBczMztZL2DWpEI1QNN.USSZR618vrGgs2n8FrYmj13BAFTo0qx4Oe9NeGeNtcDbWRTDW.fUd2vPB.t.p6PlbPyAXJCzZW.bITabjjHrRUsyvPbTDwC.gy7JsBXkxfje+9k6f8wLWRtJ.3XN0k7FZ.UlqsSiWS882G6QdGMvv6ZMZ4xYM497XEdlAYCBwtmgOkb.V6VID.N6ddTIWzUhkjHkO6v8F1c.+BVp+GSin87IZAGPW0AkpFzb.02qynZMB.fk6jW4yjV4OD0l5QGqOmAVNwfUdDlb.rzjPp7DPx4lfz9beO8AbCvCZ.uxovaETWWAMTlaQisGfZwTMm9XEsaBqTeAvegZxUNvjaDfOiruPILNfUcpZaut0V11q879wLWIkyr3rC3RxgrUWa9OOek4+x7VW0T+9EZSmGA22mHJzrtUKts.WkEGziHV25breLYrip5eRBd16FA6lV1FNxYsXT4ggjL47VfSAs.PFuoaFYHT4pLoUrTVqXmXojy.T0gTAkJTEj.eyQ.v6asKVhGcPpyTkmPhPR0kCbWx4pQjzdbEztjnyj7P0s8l7fPNSi.3hoocwQ2.vLheRVeDpifDQjcI9DWEGkZ4x7ra2X3Xgu1twETO4fwJV96MFPnmNHez7GgM5wEdDwQXOZbjYUz6TyASI4R4H44POaqZ0qVWMsJTv0D2YqNx.rjDLJlEPU2rV85N1UqYaXn5UrDfcE7wr+JnC3VsmPEzHan+YywwfZ94aMnFqO03ZfuXtEX3wr2TaYNTx2IoCAegJAC0ebFD.x5.H3pk.fQrOB9M.39VLUMJlFezrOu80KlwHBb8EKp0abuXerbxcd5k6YFTyoSrbQuAgEQkCMW9eOVDZW3hvBmBuivcETGpzcPw3sTA3UQ2+uwa1yJKh1qee0MnbvVFs+Gl12PtGP4HdrjxNsMVJn5KhGDGzUMi4RTHgotLDou3URuoKU1VKqYltDlWhveT+xL5nkgYFcFYLc.8D2zwQ8CWyknQgIVxa1UPIyqVNiVKhP1anlqUumdhqqlJdrB6EGS0oHlMmhXpMEwr0TDySlhXd5TDS8aMF8ekY6XIOHcLQonydIOOAg6wvpaYI2HA+kjqfJh
    


  • @Lindon Reading the "PresetSelectorPanel" json:

    "type": "ScriptPanel",
    "id": "PresetSelectorPanel",
    "x": 16.0,
    "y": 59.0,
    "width": 898.0,
    "height": 267.0,
    "borderRadius": 0.0,
    "bgColour": "0",
    "textColour": "954828",
    "parentComponent": "MasterPanel",
    "itemColour": "2348810240",
    "itemColour2": "2348810240",
    "macroControl": "No MacroControl",
    "childComponents": [

    I don't know if this is the issue you're seeing?
    "parentComponent": "MasterPanel"



  • @ulrik -- oh yeah well spotted _ that could be it...



  • @ulrik -- yep you . are. the. man.



  • @Lindon I'm glad I could help 🙂


Log in to reply
 

7
Online

1.1k
Users

3.6k
Topics

31.2k
Posts