Building HISE on macOS (10.13) errors and questions about using /auto_build/ files in hise source folder



  • I just tried to compile the latest commit of the branch "scriptnode" (2020-08-20) on my macOS system. 21 errors and about 59 warnings. The errors stop the build.

    Specs of my system and build paths:

    • macOS High Sierra 10.13.6 + Xcode 8.3.3 (have not installed xcpretty yet)
    • the folder I use for compiling hise from:
      /Applications/HISE-scriptnode-2020-08/
    • got all SDKs in the correct folder: /tools/SDK/
    • IPP is installed for High Sierra, that was the version that was last supported on this OS, namely the 2019-5. Any other version supported is going to be a version released in 2019 as you cannot install anything newer nor older on High Sierra.

    First off: I did not modify the "HISE Standalone.jucer" file at all, it is as it comes with the download of the latest /tree/scriptnode/ files from github. Also, I already have a working compiled version of the HISE release version 2.1 successfully on this very system. That version resides in a parallel folder to the new scriptnode branch, that I am now attempting to compile.

    Here are the errors from the build with nothing changed in the .jucer file:

    Screen Shot 2020-08-20 at 03.41.24.png

    The errors include "No member named 'writeToConsole' in 'hise::MainController'" and many more like that one. Is there a path I need to set or do I have to go through all settings manually now as well? Seems like the flags have all been updated to the ones used by @d-healey in his macOS compiling hise video for the most part.

    Any idéas on what might be my issue? (SOLVED, this part is solved, see below)

    (no paths have been tampered with, using defaults. IPP is fine, Xcode 8.3.3 is "top notch HISE material" 😀)

    Regrading the /tools/auto_build/ folder:

    I also now just see the folder /tools/auto_build/ where in I find these files:

    • 01_BuildHISE.sh, 02_BuildInstaller.sh etc.

    One of those files should do what I need, just build HISE, but which one?
    Is it the "01_BuildHISE.sh"?
    Is it the "NewBuildOSX" executable file?

    Sorry, the intro.rtf there does not shine a light on how to build with the auto-build folder. But the idéa is promising, please tell me how to auto-build! 🙂

    (I have tried to make alternative settings, like double checking the IPP, setting it to "ENABLED" explicitly, with no changes to the errors shown above. The same errors occur)


    UPDATE:
    I found out that I had by mistake opened the Projucer application of an earlier build of hise. I double clicked on the new .jucer file for the HISE standalone build in a new folder I made for the scriptnode branch. The older one was the main release 2.1. That one´s Projucer application did not correctly read the .jucer file of the new scriptnode version, which is based on a newer version of JUCE. Hence referencing the wrong files or not connecting the correct modules.

    I have thus solved this. The build of HISE Standalone on my system with HISE scriptnode branch (2020-08-20) build with no errors but 150+ warnings on my system. Details above.



  • @andioak

    I tried making alternative settings in the .jucer project, basically setting everything I want included in the HISE standalone app to "Enabled", renders less errors, but still seems to produce errors with non-declared stuff, like the image below:

    Screen Shot 2020-08-20 at 13.18.38.png

    I´m guessing from the current issue by @d-healey, "Latest build errors", that there are a few bugs in need of straightening out. Is this what might cause these errors seen in my images?

    @Christoph-Hart



  • SOLVED the issue, see last part, if you have the same issues.


Log in to reply
 

11
Online

747
Users

3.0k
Topics

24.8k
Posts