AAX compile on a Mac



  • @Lindon I see you spoke about compiling the SDK. I don't understand if you succeeded though, so that might be your problem here...
    I just compiled the last SDK yesterday and it works...



  • Try starting xcode from the command line with sudo, then it should work.



  • @ustk -- nope not compiled the SDK -- what did you do to get it to compile?



  • OK so I ran XCode as sudo, and it still fails like this

    f4f783c5-2c36-4ce6-aa2b-4c3dff3fc221-image.png

    that "ld: library not found for -lAAXLibrary_libpp" might be the indicator that Im missing something in the AAX SDK....



  • @Lindon Open HISE/tools/SDK/AAX/Libs/AAXLibrary/MacBuild/AAXLibrary.xcodeproj and perform a standard "Build for profiling"
    Note that the root folder has been renamed just AAX



  • @Lindon Yes that's it, library not found means you are compiling without having the lib in the SDK... Compile the SDK first and it should work



  • @ustk OK so I down load the SDK (AAX_SDK_2p2p2) extract it to a drive.

    -- go to: /AAXSDK_2p2p2/libs/MacBuild and double click on AAXLibrary.xcodeproj

    -- xcode opens and tells me:

    43dbf5bb-650b-4f01-a8b1-7d490fce4a65-image.png

    --stuck!



  • @Lindon Why don't you use the 2.3.2 version?



  • @Lindon oh hang on 2p3p2 seems to be compiling....



  • @ustk sorry yeah I had tried 2p3p2 I thought - perhaps not...



  • @Lindon fingers crossed 😉



  • @ustk yep well that worked - so what do put in the tools/SDK folder for HISE now? the entire AAX_SDK_2p3p2 folder? do I rename it AAX SDK ?



  • sigh---- ok well now I get these errors:

    ❌ error: You don’t have permission to save the file “Info.plist” in the folder “Contents”.

    ❌ error: couldn't remove '/Library/Application Support/Avid/Audio/Plug-Ins/RetroVolt.aaxplugin/Contents/PkgInfo' after command failed: Permission denied

    ❌ error: couldn't remove '/Library/Application Support/Avid/Audio/Plug-Ins/RetroVolt.aaxplugin/Contents/Info.plist' after command failed: Permission denied





  • oh no --so close...

    So I opened up permission on everything in this chain and ran again - this time it built the plug but failed at the end:

    ** BUILD FAILED **

    The following build commands failed:
    SetOwnerAndGroup lindon:staff /Library/Application\ Support/Avid/Audio/Plug-Ins/RetroVolt.aaxplugin
    (1 failure)
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.



  • @ustk said in AAX compile on a Mac:

    @Lindon https://forum.hise.audio/topic/2432/aax-compile-on-a-mac/13

    yes I've done all this and compiled the AAX SDK and loaded it in as AAX and run my builds and still I'm getting these permission errors....



  • @Lindon What do you mean by "loaded it in as"? You just place the whole folder in the hise/tool/SDK, rename it AAX and compile right?



  • @ustk yes.

    Now I ran xcode using sudo and it tells me it was a success -- but I cant find the AAX plugin anywhere... do you know where it should be I thought it would be in: library/Audio/plugins/DigiDesign

    -- where would it be any ideas?



  • @Lindon said in AAX compile on a Mac:

    @ustk yes.

    Now I ran xcode using sudo and it tells me it was a success -- but I cant find the AAX plugin anywhere... do you know where it should be I thought it would be in: library/Audio/plugins/DigiDesign

    -- where would it be any ideas?

    Oh hang on is it in:

    Library/Application Support/Avid/Plug-Ins/<myproduct>.aaxplugin

    Is that it?

    Why oh why in heavens name cant all plugins get put in a common place on the Mac?



  • OK so if I run xcode as sudo I can get this to compile, but its a PITA, so I'd really really like it to compile "out of the box" in HISE...

    So here's whats happening when I ask HISE to build me an AAX plugin:

    We start with the fairly standard:

    Lindons-Mac-mini:~ lindon$ /Volumes/Untitled/BeatskillzTemplate/Binaries/batchCompileOSX ; exit;
    Re-saving file: /Volumes/Untitled/BeatskillzTemplate/Binaries/AutogeneratedProject.jucer
    Finished saving: Visual Studio 2017
    Finished saving: Xcode (MacOSX)
    Finished saving: Xcode (iOS)
    Finished saving: Linux Makefile
    Compiling Instrument plugin RetroVolt ...
    

    this is followed by the usual array of warning messages... then we get to the business end of things:

    ▸ Building library libRetroVolt.a
    ▸ Building RetroVolt/RetroVolt - VST3 [Release]
    ▸ Check Dependencies
    ▸ Compiling include_juce_audio_plugin_client_VST3.cpp
    ▸ Linking RetroVolt
    ▸ Touching RetroVolt.vst3
    ▸ Building RetroVolt/RetroVolt - AAX [Release]
    ▸ Check Dependencies
    ▸ Compiling include_juce_audio_plugin_client_AAX.mm
    ▸ Linking RetroVolt
    
    
    
    
    ❌  ld: can't write output file: /Library/Application Support/Avid/Audio/Plug-Ins/RetroVolt.aaxplugin/Contents/MacOS/RetroVolt for architecture x86_64
    
    
    
    ❌  clang: error: linker command failed with exit code 1 (use -v to see invocation)
    
    
    ** BUILD FAILED **
    
    
    The following build commands failed:
    	Ld /Library/Application\ Support/Avid/Audio/Plug-Ins/RetroVolt.aaxplugin/Contents/MacOS/RetroVolt normal x86_64
    (1 failure)
    Compiling finished. Cleaning up...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    

    Is it something I've set up wrong?


Log in to reply
 

13
Online

648
Users

2.6k
Topics

21.5k
Posts