Sliderpack default value funkiness



  • Hello my friends.

    I've notices that even if sliderpack default value is at 0.0. If I print values, I get 1.0, I'm I the only one? I'm on the develop branch

    here's a snippet ->

    HiseSnippet 830.3oc6V0saSCCE1tqdPKLDCwCPzDB0pMlRY+.ntI5V6Fp.aqhNp3Bjl7RbVsVhcjiyfJDua7Hwa.bbR1R5naZqRb27EQ57ymymO9b74zSIcXQQREBW4vQgLD9gj9iD5gsGR4BT2NH7iH6QizLkUppsGERihXtHLdl2YTfqTFkr98a2l5SENrbUHz.I2g8Qd.WmqsWqOv882k5xNjGTv6Ua00QJZK8kw.elgXiBoNmROgsO03VIBBO6NtbsT0WS0rHvmskti5OT9MQp+C3Q7i8YFgFn9vFkpF0dH22s24m0HDBWtW9IelzS9SI6wc4WnOOB73DCV4HJFCvkFmRkGiRMtJJsqz20rAWA8vEnW4T5MOouihGpysX31CHcEvkiGEB6EoUpunReESZKAOD5kCnmx1UABWfn1511KYslsc8lUqBg9Hs0YTkUeetKS0Ch8Mr1z5b3mvzskAgRAHTagB9rfAsmTYUiuocS9FELY.sebPplnZ0axWbw5Uq.aYjzmsbnhC60k7OUb.0OlsktFud8ldwBGMWJrjh8kZ1AhZ0q9ipUp9ypVW1jm2DsYNCJouOSMQylzP00ArlHN3XlZIH7.z5BGg6lwu7m8lc46jFRK3nTzUv0GDxxjySOZLgzCT1chIQIig.UzIoIOIKMIOph3vFMGoPXFkbLJVl5R0TTomOCAxHVFVdKZ99l1vmUN3N46juSNWFg9b2NlBlrxOnRDpNCYJM27H.tC6LnoW5q1UHcXQmpkgI9l87IBeuaQw52yKTeeqQ4BazJJwqsBjwh71q+53VAzBXdVKWlGM1WOHsnmPrWF547uMXf1bR2Xepd7dell7YFf2DGqIioQhHhqGUbHfaQCQ6I1Pbhu3cCo67jdbsyvIy2RSfuvc3+a9lMdwbjc77XN5bxVlr6Wl1YItET4SxXMWbxdTshC4EDSCYXBKGFvDgf4C+HBtjoqRprsQ1DY5yDtIB+AVYFaXjwYFabtQT.0QIOxIsWjY.l6mnA3jHY1sJvPjfr0EsdRyBCf4pNxwwDJdAv8Ii4kSAlUlBLqNEXVaJvr9Tf4USAlWesXLiztUrVFjVl.J5sSxiZX7NBJjkkjQh9KfQeQ7N
    


  • @marcLab your SP has the range from 0 - 10, and all the sliders were at value 1

    HiseSnippet 799.3oc6VstaSCCE1tsFQKLDCwCPzDB0pMpRgsARcSzsdAUfsUQgI9ARStItqVKwNxwYPEBIdz3Qh2.33jrlrQ2zVk3ey+6by4KmK96LPIcXggREBW9iSCXH78ICmJzSZOgxEn9cP3GP1iFpYJqDU6NMfFFxbQXbw2XTfKWBEe98q2k5QENrLUHzgRtC68betNS6fVui640i5x9H2Om2q2puiTzV5Ii.7TjXiBnNmPOlsO03VABBemttbsTMTS0rPDtztR2oCmH+pHw+C4g7QdLiPCzP3hRT2S54ZPrQKp8Dtm6fy9uCQvsLHKKTLIK7XxdbW9L8YYiGFavJKh74CbgqBdMVP3gyAuRIvaYxPGEOPmYwfs6Q5KfB0XJTBxCqDeQE9BlzVBdHz08omv5o.gYQTcSa60r1v1tVyJUfxPn15TpxZnG2koF.0gFVaacV3Gyzsk9ARAHTckb9rhI5wRkUU911M4akyjIn8i7SzDVsVS9pqVqRY3JCkdr5AJNbWWv+DwCodQrczU40p0bbjvQykBKoXeolcfnZsJeuR4J+nh0EMMd7bsY9GTROOlZtlMsjpqJvphH+QL0ZP5Af0LGgZy4K9jqWw2IIklyQonufqOHfItrVBTZcvzbjhJ3yqiaMdTZqQVlDwgtfkH4RsnXnOav6miZ4R0TTgmVj.cA0u8b641ykePnO0uiYfIc7ClDgoy.lRyMC93NrSARujWpKS5vBOQKCh8M8ISfG6FLr9sLFx21ZZlvVsBi8ZGeYjHid8WiZ4SyEySZg9WBDfFS5F4Q0mmayPnmZ.dy6bjHFhBQHWOMOg+Mfvy9ZS3ccg6xjAbsyj4i2ByAuP85+MdSWeXIR2wiYN5LvVhz6yK5tB2.n7AYjlKNdOpVwgd.hgvE1lxgAHQHXdFdIbACCRhrsQ1jYFxDtwB+ANoFaXjwoFablQjO0QIOxIg2wrfxci0.XRDumVYXgQP1ZFMCgXW2F4C6McjiiIU7L.6yOlmu.w7hEHl0WfX1XAhYyEHlWt.w7pqLFyJq6Dok9IiIfhAcie.Ci6JnPWVbGI5u.ipP8AB
    

    what is strange you mean?



  • @ulrik If I set the default value to 0, I also get 1.



  • @marcLab have you opened my example?



  • @ulrik hummm...yep your example is giving me a 0.0..that's great. I don't, know why I got all 1.0 with the other example..strange.



  • @ulrik reimported my initial snippet and now it's fine...


Log in to reply
 

14
Online

1.6k
Users

4.6k
Topics

42.5k
Posts